[solved] wifi error: "No secrets were profided"

Kernels & Hardware, configuring network, installing services

[solved] wifi error: "No secrets were profided"

Postby peer » 2021-02-06 08:13

debian buster, kde

When my pc tries to connect to my router it takes a long time. Then I get an error message "No secrets were provided" and the connection is deactivated. After that the pc tries to reconnect and then it succeeds.

output of lspci:
Code: Select all
02:00.0 Network controller: Qualcomm Atheros AR93xx Wireless Network Adapter (rev 01)

output of: lspci -vv -s 02:00.0
Code: Select all
02:00.0 Network controller: Qualcomm Atheros AR93xx Wireless Network Adapter (rev 01)
        Subsystem: Qualcomm Atheros AR93xx Wireless Network Adapter
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f7d00000 (64-bit, non-prefetchable) [size=128K]
        Expansion ROM at f7d20000 [disabled] [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath9k
        Kernel modules: ath9k

This happens on the 5ghz band. It was a long time not possible to connect on 5Ghz. The SSID was not visible. Now I noticed that the band is visible again( probably a driver update: ath9k).

What causes the error: "No secrets were provided"and how can I fix this??
Last edited by peer on 2021-02-07 07:33, edited 1 time in total.
peer
 
Posts: 159
Joined: 2017-03-26 10:14

Re: wifi error: "No secrets were profided"

Postby FreewheelinFrank » 2021-02-06 09:19

It seems to be an issue with the way whatever manages the network and whatever stores your password are configured meaning that whatever manages your network can't obtain the required password.

To fix it I would investigate network manager and KDE wallet- if indeed that is how you manage the network and store passwords.

I like search results that contain the words "fixed" or "solved", like these:

https://superuser.com/questions/1463425 ... n-kde-neon

https://bbs.archlinux.org/viewtopic.php?id=198606

Bear in mind that the advice might not be applicable to your set up or configuration, so if you try anything, make sure you remember what you have done so you can reverse it if it doesn't help or makes things worse. I would try investigating the network manager password setting in KDE wallet as described in the first link first.

I'm not a KDE user, so maybe somebody who is can give you more specific advice.
User avatar
FreewheelinFrank
 
Posts: 288
Joined: 2010-06-07 16:59

Re: wifi error: "No secrets were profided"

Postby peer » 2021-02-06 15:23

I tried the solutions in the first link but they did not work. I will look in the second link

edit:
Unfortunately, the solutions in the second link do no work either.
ls -l /etc/systemd/system/multi-user.target.wants
I also tried the other networks I can connect to. All of them gave the same error: "No secrets were profided"
peer
 
Posts: 159
Joined: 2017-03-26 10:14

Re: wifi error: "No secrets were profided"

Postby Head_on_a_Stick » 2021-02-06 15:59

peer wrote:Unfortunately, the solutions in the second link do no work either.
ls -l /etc/systemd/system/multi-user.target.wants

Read the thread again. My suggestion to remove the extraneous dhcpcd service was only part of the solution. Have you checked the KDE "wallet"?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: wifi error: "No secrets were profided"

Postby peer » 2021-02-07 05:56

dhcpd is not installed
I changed the suggested option in kwallet and removed the config files.

The problem still exists

edit:
I retried the suggestion to change the password storage from encrypted to unencrypted in network manager. Yesterday this did not work. Then I tried some other suggestions including removing the config files. Now I retried the encryption suggestion and now it seems work ok. I'll monitor a few reboots to see if the problem is solved.
edit:
I did try several times to reboot and it works.
peer
 
Posts: 159
Joined: 2017-03-26 10:14

Re: [solved] wifi error: "No secrets were profided"

Postby FreewheelinFrank » 2021-02-07 08:49

Glad to hear it's working.

I wonder if this might explain what happened?

Connect to network with secret on boot

By default, NetworkManager will not connect to networks requiring a secret automatically on boot. This is because it locks such connections to the user who makes it by default, only connecting after they have logged in. To change this, do the following:

Right click on the nm-applet icon in your panel and select Edit Connections and open the Wireless tab
Select the connection you want to work with and click the Edit button
Check the boxes “Connect Automatically” and “Available to all users”
Additionally, ensure that under "Wi-Fi Security", "Store password for all users (not encrypted)" is selected

Log out and log back in to complete.


https://wiki.archlinux.org/index.php/NetworkManager

See also discussion here:

https://forum.kde.org/viewtopic.php?f=225&t=123271

Would a driver update result in misconfigured settings? Maybe somebody else would know. It would be good to pin down exactly what happened and how to fix it for anybody else arriving here after a search. Trying a bunch of stuff which doesn't fix the issue and then mysteriously does may have solved the issue, but ideally we'd be able to say, OK, now we know what happened, the solution is to do x, not well, try x, y and z and maybe that will work.
User avatar
FreewheelinFrank
 
Posts: 288
Joined: 2010-06-07 16:59

Re: [solved] wifi error: "No secrets were profided"

Postby peer » 2021-02-07 11:53

yes, that did it.
So what I did to fix the problem was.
1. remove the configuration files of kwallet: ~./config/kwallettrc and the map ~./local/share/kwalletd

2. Right click on the nm-applet icon in your panel and select Edit Connections and open the Wireless tab
Select the connection you want to work with and click the Edit button
Check the boxes “Connect Automatically” and “Available to all users”
Additionally, ensure that under "Wi-Fi Security", "Store password for all users (not encrypted)" is selected
peer
 
Posts: 159
Joined: 2017-03-26 10:14


Return to System configuration

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable