Package is not installed: E: Failed to fetch

Kernels & Hardware, configuring network, installing services

Package is not installed: E: Failed to fetch

Postby amid » 2021-02-15 04:36

Hello everyone!

My system:
Linux debian 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64 GNU/Linux

I can't install binwalk package.


Code: Select all
user@debian:~$ sudo apt install binwalk
[sudo] password for user:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libappindicator3-1 libindicator3-7 libjsoncpp1
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  arj blt cramfsswap fonts-lyx libafflib0v5 libdate-manip-perl libewf2
  libjs-jquery-ui liblzo2-2 libmng1 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-help libqt4-network libqt4-script libqt4-scripttools
  libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml
  libqt4-xmlpatterns libqtassistantclient4 libqtcore4 libqtdbus4 libqtgui4
  libtsk13 mtd-utils ncompress python-matplotlib-data python3-binwalk
  python3-cycler python3-dateutil python3-decorator python3-kiwisolver
  python3-matplotlib python3-opengl python3-pyparsing python3-pyqt4
  python3-pyqtgraph python3-scipy python3-tk qdbus qt-at-spi qtchooser
  qtcore4-l10n sleuthkit squashfs-tools tk8.6-blt2.5 ttf-bitstream-vera
Suggested packages:
  blt-demo libjs-jquery-ui-docs libqt4-declarative-folderlistmodel
  libqt4-declarative-gestures libqt4-declarative-particles
  libqt4-declarative-shaders qt4-qmlviewer libqt4-dev libicu57 qt4-qtconfig
  python-cycler-doc ffmpeg inkscape ipython3 python-matplotlib-doc
  python3-cairocffi python3-gobject python3-nose python3-tornado ttf-staypuft
  libgle3 python-pyparsing-doc python3-pyqt4-dbg python-pyqtgraph-doc
  python-scipy-doc python3-tk-dbg autopsy mac-robber
The following NEW packages will be installed:
  arj binwalk blt cramfsswap fonts-lyx libafflib0v5 libdate-manip-perl libewf2
  libjs-jquery-ui liblzo2-2 libmng1 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-help libqt4-network libqt4-script libqt4-scripttools
  libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml
  libqt4-xmlpatterns libqtassistantclient4 libqtcore4 libqtdbus4 libqtgui4
  libtsk13 mtd-utils ncompress python-matplotlib-data python3-binwalk
  python3-cycler python3-dateutil python3-decorator python3-kiwisolver
  python3-matplotlib python3-opengl python3-pyparsing python3-pyqt4
  python3-pyqtgraph python3-scipy python3-tk qdbus qt-at-spi qtchooser
  qtcore4-l10n sleuthkit squashfs-tools tk8.6-blt2.5 ttf-bitstream-vera
0 upgraded, 52 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.1 MB/44.3 MB of archives.
After this operation, 183 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Err:1 http://deb.debian.org/debian buster/main amd64 qtcore4-l10n all 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:2 http://deb.debian.org/debian buster/main amd64 libqtcore4 amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:3 http://deb.debian.org/debian buster/main amd64 libqt4-xml amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:4 http://deb.debian.org/debian buster/main amd64 libqtdbus4 amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:5 http://deb.debian.org/debian buster/main amd64 qdbus amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:6 http://deb.debian.org/debian buster/main amd64 libqt4-dbus amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:7 http://deb.debian.org/debian buster/main amd64 libqt4-network amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:8 http://deb.debian.org/debian buster/main amd64 libqt4-script amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:9 http://deb.debian.org/debian buster/main amd64 libqt4-sql amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:10 http://deb.debian.org/debian buster/main amd64 libqt4-xmlpatterns amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:11 http://deb.debian.org/debian buster/main amd64 libqtgui4 amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:12 http://deb.debian.org/debian buster/main amd64 libqt4-declarative amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:13 http://deb.debian.org/debian buster/main amd64 libqt4-designer amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:14 http://deb.debian.org/debian buster/main amd64 libqt4-help amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:15 http://deb.debian.org/debian buster/main amd64 libqt4-scripttools amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:16 http://deb.debian.org/debian buster/main amd64 libqt4-sql-mysql amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:17 http://deb.debian.org/debian buster/main amd64 libqt4-svg amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:18 http://deb.debian.org/debian buster/main amd64 libqt4-test amd64 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
Err:19 http://deb.debian.org/debian buster/main amd64 libtsk13 amd64 4.6.5-1
  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/qtcore4-l10n_4.8.7+dfsg-18_all.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqtcore4_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-xml_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqtdbus4_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/qdbus_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-dbus_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-network_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-script_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-sql_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-xmlpatterns_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqtgui4_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-declarative_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-designer_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-help_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-scripttools_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-sql-mysql_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-svg_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/libqt4-test_4.8.7+dfsg-18_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/s/sleuthkit/libtsk13_4.6.5-1_amd64.deb  404  Not Found [IP: 151.101.14.132 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


I done
Code: Select all
user@debian:~$ sudo apt update

but without a result.

Tried to install a separate package: qtcore4-l10n
I found it in the repository:
Code: Select all
user@debian:~$ sudo apt search qtcore4-l10n
Sorting... Done
Full Text Search... Done
qtcore4-l10n/stable 4:4.8.7+dfsg-18 all
  Qt 4 core module translations


But when it's installing:
Code: Select all
user@debian:~$ sudo apt install qtcore4-l10n
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libappindicator3-1 libindicator3-7 libjsoncpp1
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  qtcore4-l10n
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 662 kB of archives.
After this operation, 4,911 kB of additional disk space will be used.
Err:1 http://deb.debian.org/debian buster/main amd64 qtcore4-l10n all 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/qtcore4-l10n_4.8.7+dfsg-18_all.deb  404  Not Found [IP: 151.101.14.132 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


What am I doing wrong?
Last edited by amid on 2021-02-15 08:03, edited 1 time in total.
amid
 
Posts: 8
Joined: 2021-02-15 04:02

Re: Package is not installed: E: Failed to fetch

Postby Head_on_a_Stick » 2021-02-15 05:13

Your kernel version is ancient so I presume you've never updated your system.

Try
Code: Select all
# apt update
# apt upgrade
# apt install binwalk

And for the autoremove message see viewtopic.php?t=104157
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13280
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Package is not installed: E: Failed to fetch

Postby amid » 2021-02-15 06:23

Head_on_a_Stick wrote:Your kernel version is ancient so I presume you've never updated your system.

Try
Code: Select all
# apt update
# apt upgrade
# apt install binwalk

And for the autoremove message see viewtopic.php?t=104157


Code: Select all
user@debian:~$ sudo apt update
[sudo] password for user:
Hit:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://deb.debian.org/debian buster InRelease                           
Hit:3 http://security.debian.org/debian-security buster/updates InRelease     
Hit:4 http://deb.debian.org/debian buster-updates InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.


Code: Select all
user@debian:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libappindicator3-1 libindicator3-7 libjsoncpp1
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Nothing to upgrade
Can I decide problem with autoremove late? Right now, I'm more concerned about binwalk

source.list
Code: Select all
deb http://deb.debian.org/debian/ buster main
deb-src http://deb.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main contrib
deb-src http://security.debian.org/debian-security buster/updates main contrib

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib
deb-src http://deb.debian.org/debian/ buster-updates main contrib


Code: Select all
user@debian:~$ uname -a
Linux debian 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux


The problem is not solved. Any ideas?
amid
 
Posts: 8
Joined: 2021-02-15 04:02

Re: Package is not installed: E: Failed to fetch

Postby sunrat » 2021-02-15 08:23

You appear to have multiple problems here. If your system has been properly upgraded your kernel should be many versions newer. Show us:
Code: Select all
apt policy linux-image-amd64

If it's not installed, install it and try the 3 commands from Head_on_a_Stick again.

Those qt packages are available so the not found error is worrying.
https://packages.debian.org/search?keywords=libqtcore4
https://packages.debian.org/buster/qtcore4-l10n

Autoremove is irrelevant to the install issue.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3419
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Package is not installed: E: Failed to fetch

Postby amid » 2021-02-15 08:32

sunrat wrote:You appear to have multiple problems here. If your system has been properly upgraded your kernel should be many versions newer. Show us:
Code: Select all
apt policy linux-image-amd64

If it's not installed, install it and try the 3 commands from Head_on_a_Stick again.

Those qt packages are available so the not found error is worrying.
https://packages.debian.org/search?keywords=libqtcore4
https://packages.debian.org/buster/qtcore4-l10n

Autoremove is irrelevant to the install issue.


Code: Select all
user@debian:~$ sudo apt policy linux-image-amd64
linux-image-amd64:
  Installed: 4.19+105+deb10u9
  Candidate: 4.19+105+deb10u9
  Version table:
 *** 4.19+105+deb10u9 500
        500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.19+105+deb10u4 500
        500 http://deb.debian.org/debian buster/main amd64 Packages


Tried again 3 commands from Head_on_a_Stick and nothing. What should I do more?
amid
 
Posts: 8
Joined: 2021-02-15 04:02

Re: Package is not installed: E: Failed to fetch

Postby sunrat » 2021-02-15 11:10

So you have an up-to-date kernel metapackage but an ancient kernel if what you wrote in the first post is accurate. I'm confused.
Show:
Code: Select all
uname -a


You don't need to run that command with sudo, nor the apt policy command above. Apt only needs admin permissions when it is to make changes and it's a bad habit to do that when not needed.

The kernel may yet be a side issue. Needs to be sorted anyway. Buggered if I know why your sources look OK but you can't install packages which are in the repos to which those sources point.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3419
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Package is not installed: E: Failed to fetch

Postby amid » 2021-02-15 12:00

sunrat wrote:So you have an up-to-date kernel metapackage but an ancient kernel if what you wrote in the first post is accurate. I'm confused.
Show:
Code: Select all
uname -a


You don't need to run that command with sudo, nor the apt policy command above. Apt only needs admin permissions when it is to make changes and it's a bad habit to do that when not needed.

The kernel may yet be a side issue. Needs to be sorted anyway. Buggered if I know why your sources look OK but you can't install packages which are in the repos to which those sources point.


Ok, right now
Code: Select all
user@debian:~$ uname -a
Linux debian 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux


I'm not a guru in Linux. But I'm pointing out that apt form wrong URL for packages. For example http://deb.debian.org/debian/pool/main/q/qt4-x11/qtcore4-l10n_4.8.7+dfsg-18_all.deb really doesn't exist. Сorrect the package URL is http://deb.debian.org/debian/pool/main/q/qt4-x11/qtcore4-l10n_4.8.7+dfsg-18+deb10u1_all.deb
Could explain it to me, please?
amid
 
Posts: 8
Joined: 2021-02-15 04:02

Re: Package is not installed: E: Failed to fetch

Postby sunrat » 2021-02-15 20:10

amid wrote:
sunrat wrote:
Code: Select all
user@debian:~$ uname -a
Linux debian 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux


I'm not a guru in Linux. But I'm pointing out that apt form wrong URL for packages. For example http://deb.debian.org/debian/pool/main/q/qt4-x11/qtcore4-l10n_4.8.7+dfsg-18_all.deb really doesn't exist. Сorrect the package URL is http://deb.debian.org/debian/pool/main/q/qt4-x11/qtcore4-l10n_4.8.7+dfsg-18+deb10u1_all.deb
Could explain it to me, please?

Your kernel is the current one. Weird the package above is not showing the current version. To show available versions:
Code: Select all
apt policy qtcore4-l10n
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3419
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Package is not installed: E: Failed to fetch

Postby amid » 2021-02-16 08:54

sunrat wrote:Your kernel is the current one. Weird the package above is not showing the current version. To show available versions:
Code: Select all
apt policy qtcore4-l10n


Code: Select all
user@debian:~$ apt policy qtcore4-110n
N: Unable to locate package qtcore4-110n
amid
 
Posts: 8
Joined: 2021-02-15 04:02

Re: Package is not installed: E: Failed to fetch

Postby sunrat » 2021-02-16 09:59

Typo, you put a 1 instead of a lower case "l".

You should get this:
Code: Select all
$ apt policy qtcore4-l10n
qtcore4-l10n:
  Installed: 4:4.8.7+dfsg-18+deb10u1
  Candidate: 4:4.8.7+dfsg-18+deb10u1
  Version table:
 *** 4:4.8.7+dfsg-18+deb10u1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

Unless it's not installed but it would still show a candidate.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3419
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Package is not installed: E: Failed to fetch

Postby amid » 2021-02-16 10:08

sunrat wrote:Typo, you put a 1 instead of a lower case "l".

You should get this:
Code: Select all
$ apt policy qtcore4-l10n
qtcore4-l10n:
  Installed: 4:4.8.7+dfsg-18+deb10u1
  Candidate: 4:4.8.7+dfsg-18+deb10u1
  Version table:
 *** 4:4.8.7+dfsg-18+deb10u1 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

Unless it's not installed but it would still show a candidate.


Sorry, I wasn't being mindful
Code: Select all
user@debian:~$ apt policy qtcore4-l10n
qtcore4-l10n:
  Installed: (none)
  Candidate: 4:4.8.7+dfsg-18
  Version table:
     4:4.8.7+dfsg-18 500
        500 http://deb.debian.org/debian buster/main amd64 Packages


Code: Select all
user@debian:~$ sudo apt install qtcore4-l10n
[sudo] password for user:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libappindicator3-1 libindicator3-7 libjsoncpp1
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  qtcore4-l10n
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 662 kB of archives.
After this operation, 4,911 kB of additional disk space will be used.
Err:1 http://deb.debian.org/debian buster/main amd64 qtcore4-l10n all 4:4.8.7+dfsg-18
  404  Not Found [IP: 151.101.14.132 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/q/qt4-x11/qtcore4-l10n_4.8.7+dfsg-18_all.deb  404  Not Found [IP: 151.101.14.132 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
amid
 
Posts: 8
Joined: 2021-02-15 04:02

Re: Package is not installed: E: Failed to fetch

Postby sunrat » 2021-02-16 12:28

Looks like your repo package list is not updated. Run (as root or sudo)
Code: Select all
 apt update
and post the output.
Also post
Code: Select all
apt policy
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3419
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Package is not installed: E: Failed to fetch

Postby amid » 2021-02-16 13:22

sunrat wrote:Looks like your repo package list is not updated. Run (as root or sudo)
Code: Select all
 apt update
and post the output.
Also post
Code: Select all
apt policy


I already repeated this command many times:
Code: Select all
user@debian:~$ sudo apt update
[sudo] password for user:
Hit:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://security.debian.org/debian-security buster/updates InRelease     
Hit:3 http://deb.debian.org/debian buster InRelease                           
Hit:4 http://deb.debian.org/debian buster-updates InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.


Code: Select all
user@debian:~$ apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google LLC,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 http://deb.debian.org/debian buster-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://deb.debian.org/debian buster/main amd64 Packages
     release v=10.8,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin deb.debian.org
Pinned packages:
amid
 
Posts: 8
Joined: 2021-02-15 04:02

Re: Package is not installed: E: Failed to fetch

Postby Head_on_a_Stick » 2021-02-16 19:16

Try changing the security line, I use this:
Code: Select all
deb https://deb.debian.org/debian-security buster/updates main contrib non-free

If you're still having problems then change the redirector URLs to a local mirror instead.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13280
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Package is not installed: E: Failed to fetch

Postby amid » 2021-02-17 05:02

Head_on_a_Stick wrote:Try changing the security line, I use this:
Code: Select all
deb https://deb.debian.org/debian-security buster/updates main contrib non-free

If you're still having problems then change the redirector URLs to a local mirror instead.


Thank you very much! I replaced deb.debian.org with a mirror and everything is working! :D
amid
 
Posts: 8
Joined: 2021-02-15 04:02


Return to System configuration

Who is online

Users browsing this forum: No registered users and 17 guests

fashionable