Sound (ESD) conflicts in Gnome

Kernels & Hardware, configuring network, installing services

Sound (ESD) conflicts in Gnome

Postby gregkedro » 2007-06-01 13:21

Hey, everybody. Has anyone ever run into problems with Gnome's ESD daemon making a dog's breakfast (a flat, stinkin mess) out of their sound?

Yesterday I was pulling my hair out over sound conflicts with a Genius soundcard I have (C-Media CM8738 using snd-cmipci).
1. mplayer wanted to use hw:0.1 (and therefore I had to switch Exchange DAC to ON for it to pipe to my speakers).
2. Audacity wanted to used hw:0.1, too (same deal with DAC switch).
3. System sounds wanted hw:0.0 (DAC to off in order to hear them).
4. Rhythmbox was hw:0.0, too (same DAC setting as system sounds).

[BTW, hw:0.0 is my first DAC and hw:0.1 is second DAC. Sound channel stuff on my cheapy sound card.]

Then I tested things with mpg321 (love it!) and got this error:

Code: Select all
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
ALSA snd_pcm_open error: Device or resource busy


When I did an fuser -v /dev/dsp to see what was causing the havoc and rendering my dog's breakfast... lo and behold I see this:

Code: Select all
                     USER        PID ACCESS COMMAND
/dev/dsp:            greg       3531 F.... esd


It's esd that's causing the problem -- esound in Gnome.

When I log into KDE or Fluxbox, all the programs mentioned above run perfect with no conflicts, no dog's breakfast... everyone is peachy and happy with defaults.

Is this a quirk with Gnome? Or am I missing some wee little piece of information what will allow me to continue using Gnome as my default desktop (I'm starting to get used to it, and like it a bit).

Thanks!

-Greg
User avatar
gregkedro
 
Posts: 83
Joined: 2007-05-24 21:37
Location: San José, Costa Rica

Postby wanderlust » 2007-07-15 12:33

Hello.
I had alike problem. Rhytmbox worked, but neither totem nor audacity didn't work wirk sound out put, cause resourse was busy. I just disabled system sounds, and it al worked perfectly. After this, I re-enabled ESD and this all still works :-) Maybe this will help you.
wanderlust
 

Postby gregkedro » 2007-07-15 12:41

I switched to KDE and it all worked fine, no tweaking necessary. I beat my head against wall trying to get things working in Gnome, and ended up switching to KDE.

-Greg
User avatar
gregkedro
 
Posts: 83
Joined: 2007-05-24 21:37
Location: San José, Costa Rica

Postby radamis » 2007-07-15 16:38

Adding:
Code: Select all
default_options=-as 1

to /etc/esound/esd.conf helped me considerably. ESD by default takes control of the sound system and won't let anything else use it. The above line tells ESD that after 1 second of being idle release the sound system for others to use. It didn't help with the 1-3 second delay between the audio app and the speakers when the audio was going through esd(made watching movies a little weird).
radamis
 
Posts: 58
Joined: 2007-06-13 02:32
Location: Canton, Michigan

Postby rippin » 2007-07-16 03:20

radamis wrote:Adding:
Code: Select all
default_options=-as 1

to /etc/esound/esd.conf helped me considerably. <snip>.


Excellent ! Now I can have my ALSA and ESD ,too! Thanks so much for posting that.
HITman
(Honor,Integrity,Truthfulness are my guides)
User avatar
rippin
 
Posts: 37
Joined: 2007-05-25 00:11
Location: Wyoming, USA

Postby jonny_noog » 2008-04-05 10:39

Sorry to bring up an old thread, but I've been using the "default_options=-as 1" line described here successfully in my /etc/esound/esd.conf file for some time now, just did an upgrade and something odd seems to have happened to esd, I've got sound through ALSA, but no GNOME system sounds (even though they were working previously) and when I try to test esd via the GNOME sound preferences, I get:

Code: Select all
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not establish connection to sound server


as a pop-up error. I tried removing libesd0 and replacing it with libesd-alsa0 but no luck.

The error seems to suggest to me that esd isn't running, though it always used to start automatically as far as I knew... I can't see any process containing "esd" or "esound" running if I look, so I'm thinking this may be my problem. I tried to type "esd" just to see if I could get it started manually, but command not found.

Is there another command to start it? Is the process called what I think it is? Anyone know if anything has happened with esd in Lenny recently?
Last edited by jonny_noog on 2008-04-05 11:18, edited 1 time in total.
I thought what I'd do was, I'd pretend I was one of those deaf-mutes.
User avatar
jonny_noog
 
Posts: 456
Joined: 2006-12-17 02:28
Location: ~/

Postby MeanDean » 2008-04-05 10:56

see if esound is installed
dpkg -l | grep esound
then maybe
apt-get install esound
or
apt-get install pulseaudio
or
apt-get install pulseaudio esound
User avatar
MeanDean
 
Posts: 3956
Joined: 2007-09-01 01:14

Postby jonny_noog » 2008-04-05 11:26

Wowz! Fast service Dean.

'dpkg -l | grep esound' wrote:ii esound-clients 0.2.36-3 Enlightened Sound Daemon - clients
ii esound-common 0.2.36-3 Enlightened Sound Daemon - Common files


But no esound, hmm. What is the relationship between esd and esound anyway? And how does pulseaudio fit in to the equation? I have read the name while Googling my problem but don't really get how it fits in.

'aptitude search esound' wrote:p esound - Enlightened Sound Daemon - Support binaries
i A esound-clients - Enlightened Sound Daemon - clients
i A esound-common - Enlightened Sound Daemon - Common files
p pulseaudio-esound-compat - PulseAudio ESD compatibility layer
p pulseaudio-esound-compat-dbg - PulseAudio ESD compatibility layer debugging symbols


So you reckon one of these pulse audio packages would be worth a go along with esound? I'll see what they taste like.
I thought what I'd do was, I'd pretend I was one of those deaf-mutes.
User avatar
jonny_noog
 
Posts: 456
Joined: 2006-12-17 02:28
Location: ~/

Postby jonny_noog » 2008-04-06 00:05

For anyone who may run into similar issues to me, this morning I installed the esound package and also did another full-upgrade for good measure, which pulled in:

Code: Select all
===============================================================================
[UPGRADE] gnome-app-install 0.5.2.3-1 -> 0.5.2.5-1
[UPGRADE] gstreamer0.10-alsa 0.10.17-3 -> 0.10.18-3
[UPGRADE] gstreamer0.10-gnomevfs 0.10.17-3 -> 0.10.18-3
[UPGRADE] gstreamer0.10-plugins-base 0.10.17-3 -> 0.10.18-3
[UPGRADE] gstreamer0.10-tools 0.10.17-2 -> 0.10.18-4
[UPGRADE] gstreamer0.10-x 0.10.17-3 -> 0.10.18-3
[UPGRADE] libbrlapi0.5 3.9-5 -> 3.9-6
[UPGRADE] libfam0 2.7.0-13.1 -> 2.7.0-13.2
[UPGRADE] libgstreamer-plugins-base0.10-0 0.10.17-3 -> 0.10.18-3
[UPGRADE] libgstreamer0.10-0 0.10.17-2 -> 0.10.18-4
[UPGRADE] python-brlapi 3.9-5 -> 3.9-6
[UPGRADE] python-gobject 2.14.1-2 -> 2.14.1-3
[UPGRADE] python-gst0.10 0.10.10-1+b1 -> 0.10.11-1
[UPGRADE] seahorse 2.20.3-2 -> 2.22.0-1
[UPGRADE] wget 1.10.2-3 -> 1.11.1-1
===============================================================================


And my problem is solved. Not sure if it was just installing esound that did it or if it was also a matter of some of these gstreamer packages needing to get back in sync or whatever. I would have thought that the esound package was installed before, not sure when it decided to leave, But all's well that ends well, I guess.

After doing a bit more reading on pulseaudio I think I now have a slightly better understanding of how it fits in, basically as a replacement for esd/esound so I gather, and it seems like it would be worth a go when I get some more time.

Does anyone know what the current state of pulseaudio support is in relation to MPlayer and IceWeasel? Documentation I have read suggests that for MPlayer one needs the latest SVN development code for pulseaudio support. And for IceWeasel/Flash audio support, some manual tweaking is required. Just wondering if this was still the case in relation to Lenny?
I thought what I'd do was, I'd pretend I was one of those deaf-mutes.
User avatar
jonny_noog
 
Posts: 456
Joined: 2006-12-17 02:28
Location: ~/


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable