fixing broken packages

Kernels & Hardware, configuring network, installing services

fixing broken packages

Postby SoulNOTHING » 2004-10-17 14:49

i have 16 broken packages and im unsure how to get them off of the computer ive run apt-get -f install and this is what i get

Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
kdelibs-bin kdelibs-data kdelibs4
The following packages will be upgraded:
kdelibs-bin kdelibs-data kdelibs4
3 upgraded, 0 newly installed, 0 to remove and 283 not upgraded.
17 not fully installed or removed.
Need to get 0B/16.5MB of archives.
After unpacking 4243kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 171450 files and directories currently installed.)
Preparing to replace kdelibs4 4:3.2.3-2 (using .../kdelibs4_4%3a3.3.0-99_i386.deb) ...
Unpacking replacement kdelibs4 ...
dpkg: error processing /var/cache/apt/archives/kdelibs4_4%3a3.3.0-99_i386.deb (--unpack):
trying to overwrite `/usr/lib/libknewstuff.so.1.0.0', which is also in package korganizer
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace kdelibs-bin 4:3.2.3-2 (using .../kdelibs-bin_4%3a3.3.0-99_i386.deb) ...
Unpacking replacement kdelibs-bin ...
dpkg: error processing /var/cache/apt/archives/kdelibs-bin_4%3a3.3.0-99_i386.deb (--unpack):
trying to overwrite `/etc/kde3/khotnewstuffrc', which is also in package korganizer
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace kdelibs-data 4:3.2.3-2 (using .../kdelibs-data_4%3a3.3.0-99_all.deb) ...
Unpacking replacement kdelibs-data ...
dpkg: error processing /var/cache/apt/archives/kdelibs-data_4%3a3.3.0-99_all.deb (--unpack):
trying to overwrite `/usr/share/apps/knewstuff/types', which is also in package korganizer
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/kdelibs4_4%3a3.3.0-99_i386.deb
/var/cache/apt/archives/kdelibs-bin_4%3a3.3.0-99_i386.deb
/var/cache/apt/archives/kdelibs-data_4%3a3.3.0-99_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

this is how the repository looks in apt source config

# deb http://swemmel.fh-worms.de/~inf418/debi ... /kde3.3.0/ ./

im totally lost any help would be appreciated

i do have kde 3.2 on my computer
when the soul is nothing the heart is everything
SoulNOTHING
 
Posts: 12
Joined: 2004-10-09 01:57

Postby SoulNOTHING » 2004-10-17 21:50

all right i got that fixed seems the sites package are just bad

anyone have a link to kde repositorie with 3.3 im a gnome person and thougt id giver kde a try
when the soul is nothing the heart is everything
SoulNOTHING
 
Posts: 12
Joined: 2004-10-09 01:57

Postby SoulNOTHING » 2004-10-18 18:15

all right i got some more broken packages nvidia based

heres what i get when i run apt-get -f install

Code: Select all
RAZORSkyline:~# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  nvidia-modules-2.4.25-fiasko-ide-pentium-iii
  nvidia-modules-2.4.27-fiasko-ide-pentium-iii
  nvidia-modules-2.4.27-fiasko-scsi-pentium-iii
  nvidia-modules-2.6.7-fiasko-ide-pentium-iii
0 upgraded, 0 newly installed, 4 to remove and 126 not upgraded.
Need to get 0B of archives.
After unpacking 115kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 143237 files and directories currently installed.)
Removing nvidia-modules-2.4.25-fiasko-ide-pentium-iii ...
/var/lib/dpkg/info/nvidia-modules-2.4.25-fiasko-ide-pentium-iii.prerm: line 6: /usr/lib/nvidia-modules-2.4.25-fiasko-ide-pentium-iii/nvidia-installer: No such file or directory
dpkg: error processing nvidia-modules-2.4.25-fiasko-ide-pentium-iii (--remove):
 subprocess pre-removal script returned error exit status 1
Removing nvidia-modules-2.4.27-fiasko-ide-pentium-iii ...
/var/lib/dpkg/info/nvidia-modules-2.4.27-fiasko-ide-pentium-iii.prerm: line 6: /usr/lib/nvidia-modules-2.4.27-fiasko-ide-pentium-iii/nvidia-installer: No such file or directory
dpkg: error processing nvidia-modules-2.4.27-fiasko-ide-pentium-iii (--remove):
 subprocess pre-removal script returned error exit status 1
Removing nvidia-modules-2.4.27-fiasko-scsi-pentium-iii ...
/var/lib/dpkg/info/nvidia-modules-2.4.27-fiasko-scsi-pentium-iii.prerm: line 6: /usr/lib/nvidia-modules-2.4.27-fiasko-scsi-pentium-iii/nvidia-installer: No such file or directory
dpkg: error processing nvidia-modules-2.4.27-fiasko-scsi-pentium-iii (--remove): subprocess pre-removal script returned error exit status 1
Removing nvidia-modules-2.6.7-fiasko-ide-pentium-iii ...
/var/lib/dpkg/info/nvidia-modules-2.6.7-fiasko-ide-pentium-iii.prerm: line 6: /usr/lib/nvidia-modules-2.6.7-fiasko-ide-pentium-iii/nvidia-installer: No such file or directory
dpkg: error processing nvidia-modules-2.6.7-fiasko-ide-pentium-iii (--remove):
 subprocess pre-removal script returned error exit status 1
Errors were encountered while processing:
 nvidia-modules-2.4.25-fiasko-ide-pentium-iii
 nvidia-modules-2.4.27-fiasko-ide-pentium-iii
 nvidia-modules-2.4.27-fiasko-scsi-pentium-iii
 nvidia-modules-2.6.7-fiasko-ide-pentium-iii
E: Sub-process /usr/bin/dpkg returned an error code (1)


any help would be appreciated
when the soul is nothing the heart is everything
SoulNOTHING
 
Posts: 12
Joined: 2004-10-09 01:57


Return to System configuration

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable