Need help installing Xfce 4.6 in Lenny backports [SOLVED]

Kernels & Hardware, configuring network, installing services

Need help installing Xfce 4.6 in Lenny backports [SOLVED]

Postby Mr. Swillis » 2009-09-13 00:13

Hello,

I was really excited to see Xfce 4.6 available in Lenny backports, but I'm not having the best of luck getting it installed. Has anyone gotten this to work successfully? I added backports to my sources.list -

Code: Select all
deb http://ftp.us.debian.org/debian/ lenny main non-free contrib
deb-src http://ftp.us.debian.org/debian/ lenny main non-free contrib

deb http://security.debian.org/ lenny/updates main non-free contrib
deb-src http://security.debian.org/ lenny/updates main non-free contrib

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free


deb http://www.debian-multimedia.org lenny main

deb http://www.backports.org/debian lenny-backports main contrib non-free


- and then ran -

Code: Select all
sudo aptitude -t lenny-backports install xfce4


- and then got this:

Code: Select all
The following packages have unmet dependencies:
  xfce4: Depends: xfdesktop4 (>= 4.6.1) but 4.4.2-7 is to be installed.
         Depends: thunar (>= 1.0.1) but 0.9.0-10 is to be installed.
         Depends: thunar-volman (>= 0.3.80) but it is not installable
         Depends: xfce4-mixer (>= 4.6.1) but it is not installable
         Depends: xfce4-appfinder (>= 4.6.1) but it is not installable
         Depends: orage (>= 4.6.1) but it is not installable
  thunar: Depends: thunar-data (= 0.9.0-10) but it is not installable
  xfce4-settings: Conflicts: xfce4-mcs-plugins but 4.4.2-4 is to be installed.
  xfdesktop4: Depends: xfdesktop4-data (= 4.4.2-7) but it is not installable
  libthunar-vfs-1-2: Depends: thunar-data (= 0.9.0-10) but it is not installable
The following actions will resolve these dependencies:

Install the following packages:
thunar-data [0.9.0-10 (stable)]
xfdesktop4-data [4.4.2-7 (stable)]

Keep the following packages at their current version:
xfce4 [Not Installed]
xfce4-session [Not Installed]
xfce4-settings [Not Installed]


Anyone see anything that I'm obviously doing wrong? I've done this type of thing before back when I was running testing and installing occasional things from unstable, but that's to be expected sometimes in that scenario with mismatched versions and such. With backports, I guess I thought the whole point was to be able to install newer stuff on an older system...

Swill
Last edited by Mr. Swillis on 2009-09-13 14:51, edited 1 time in total.
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Bulkley » 2009-09-13 00:36

Wouldn't it be easier to upgrade to Squeeze? It looks like it can't find or doesn't want thunar.
Bulkley
 
Posts: 3977
Joined: 2006-02-11 18:35

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Mr. Swillis » 2009-09-13 00:50

Heh, well yeah, but that's really not the point. The idea of backports is to have the newer versions of a few select packages available (xfce in this case) but to be able to run them on "stable". I'm not in the mood for a rolling release and don't need bleeding edge versions of everything. I just like the idea of Xfce 4.6 due to the number of things that were fixed from 4.4. And it's a super small set of apps that should be relatively isolated from the rest of the system. I know I could go the "manual" route and slap it in place with no problem, but using apt makes things a little cleaner/easier when upgrading (say a new patch makes it into the backports repo) or uninstalling.

Swill
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Bulkley » 2009-09-13 00:56

Can you put a hold on the thunar that you have and upgrade the rest? Can you do the XFCE upgrade piecemeal?
Bulkley
 
Posts: 3977
Joined: 2006-02-11 18:35

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Mr. Swillis » 2009-09-13 01:06

Yeah, I was just pondering trying it piece by piece. Some posts I've read claim that what I've already tried should work, but I recall seeing something earlier about each dependency needing to be specifically from backports. I'll give it a whirl and see how it goes.

Swill
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Mr. Swillis » 2009-09-13 01:17

Bleh, run into dependency hell going that route. Oh well, not that big of a deal. I wonder if there is simply some issue with the available package versions in backports at the moment or something. They at least seem to have some pieces of it there, but maybe not the whole thing.

Swill
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby julian67 » 2009-09-13 01:40

You mention adding the backports repo but did you update successfully before trying to install new packages? And was your system up to date before you added the new repo?

I had a look at the xfce packages in lenny-backports and it seems complete. I also looked at the dependencies of the xfce4 metapackage and that looked good. So the issue seems to be at your end. Maybe you have held packages with aptitude? I think if you run
Code: Select all
# apt-get update && apt-get upgrade && apt-get -t lenny-backports install xfce4
it should succeed. You should expect to see some packages removed altogether, i.e. xfce4-mcs-manager and dependencies, because there are in some cases new applications instead of upgrades. You may need to add a few things individually.
Wisdom from my inbox: "do not mock at your pottenocy"
User avatar
julian67
 
Posts: 4648
Joined: 2007-04-06 14:39
Location: Just hanging around

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Mr. Swillis » 2009-09-13 01:53

Yep, I've be playing around with apt preferences to try and get it to work, so I've run update several times. Just to make sure, I removed /etc/apt/preferences, ran apt-get update, upgrade, and install xfce4 just as you mentioned, but get this:

Code: Select all
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  xfce4: Depends: xfdesktop4 (>= 4.6.1) but it is not going to be installed
         Depends: thunar (>= 1.0.1) but it is not going to be installed
         Depends: thunar-volman (>= 0.3.80) but it is not going to be installed
         Depends: xfce4-mixer (>= 4.6.1) but it is not going to be installed
         Depends: xfce4-appfinder (>= 4.6.1) but it is not going to be installed
         Depends: orage (>= 4.6.1) but it is not going to be installed
         Recommends: desktop-base (>= 5.0.4) but 5.0.3 is to be installed
         Recommends: tango-icon-theme (>= 0.8.90) but it is not going to be installed
E: Broken packages


This is a totally fresh install too, just did it last night. My typical post-install tasks are to add backports and multimedia to sources.list, run update and upgrade, then install some codecs/plugins and setup nvidia drivers. Aside from that, I really haven't been messing with until deciding to play around with this Xfce install.

Swill
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby julian67 » 2009-09-13 02:13

Looking at your output the package manager wants to install the recommends, desktop-base and tango-icon-theme, but the recommended versions are not in backports or the official lenny repos.

Maybe you have to set your /etc/apt/apt.conf to not install recommends?
Wisdom from my inbox: "do not mock at your pottenocy"
User avatar
julian67
 
Posts: 4648
Joined: 2007-04-06 14:39
Location: Just hanging around

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Mr. Swillis » 2009-09-13 06:52

Yeah, still no dice. When I ignore recommends, it just gives me the same error minus the last two "recommended" packages. I dug a bit deeper once more by trying one package at a time and found this strange little trail. I first tried "xfce4", which gave me this list of failed dependencies:

Code: Select all
  xfce4: Depends: xfdesktop4 (>= 4.6.1) but it is not going to be installed
         Depends: thunar (>= 1.0.1) but it is not going to be installed
         Depends: thunar-volman (>= 0.3.80) but it is not going to be installed
         Depends: xfce4-mixer (>= 4.6.1) but it is not going to be installed
         Depends: xfce4-appfinder (>= 4.6.1) but it is not going to be installed
         Depends: orage (>= 4.6.1) but it is not going to be installed


I then try the first one in the list, xfdesktop4, which complains about this:

Code: Select all
  xfdesktop4: Depends: libthunar-vfs-1-2 (>= 0.9.0) but it is not going to be installed
              Depends: xfdesktop4-data (= 4.4.2-7) but 4.6.1-1~bpo50+1 is to be installed


Again, I pick the first one in the list, libthunar-vfs-1-2, and get this:

Code: Select all
The following packages have unmet dependencies:
  libthunar-vfs-1-2: Depends: thunar-data (= 0.9.0-10) but 1.0.1-1~bpo50+1 is to be installed


And BAM! It appears that libthunar-vfs-1-2 is set with a hard dependency on thunar-data 0.9.0-10, BUT the repo has a *newer* version, 1.0.1-1. Typically, the dependencies are set with a ">=" when moving up a version, but this is a hard "=", which is... strange? Seems strange to me anyway. I tried installing thunar on its own too, which also has a dependency on thunar-data, and sure enough, it was also set to a hard "=" on 0.9.0-10.

Does that sound like package maintenance issue to anyone? It's a confusing catch 22 that messes with my head a little, so maybe I'm over thinking this a bit. I'll go watch the Back to the Future trilogy and see if that clears anything up for me...

Swill
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby bugsbunny » 2009-09-13 13:07

You do know that if you answer "n" (for no) aptitude will cycle through other solutions, eventually installing all the needed packages from backports? In any case you can short circuit the process with some manual intervention. Easiest way at this point is to run:
Code: Select all
# aptitude -t lenny-backports install xfce4 libthunar-vfs-1-2+M thunar xfdesktop4+M orage+M thunar-data+M xfce4-appfinder+M xfce4-mixer+M xfce4-appfinder+M


That should be enough to point it in the right direction. At the prompt (Y/n/?) you can also specify exact packages and versions. Try entering the ? to see your options. You can respond, for example:
Code: Select all
+Mxfce4-panel/lenny-backports
or
Code: Select all
+Mxfce4-panel=4.6.1-3~bpo50+1
Both of those will tell aptitude to install xfce4-panel using the version from backports, and to flag it as automatically installed.

If you just let aptitude cycle through it's options it will eventually find the right solution. If you help it along it will find the solution you want quicker. One of the changes in newer versions of aptitude is that the weighting of different options has changed so that it's more likely to come up with the "correct" solution quicker.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Mr. Swillis » 2009-09-13 14:25

Yeah, I did try cycling through, but never got to a point where the solution was any good. It kept wanting to leave a bunch of stuff uninstalled (key ingredients mind you). It seems to do this also when I try tings like this:

Code: Select all
aptitude -t lenny-backports install xfce4 libthunar-vfs-1-2+M thunar xfdesktop4+M orage+M thunar-data+M xfce4-appfinder+M xfce4-mixer+M xfce4-appfinder+M


One thing I'm curious about now is whether or not anyone has even done this successfully. After finding the weird dependency issues in my previous post, I'm starting to doubt the integrity of the packages/repo themselves. I'm tempted to try on another box too, just to see.

Swil
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Mr. Swillis » 2009-09-13 14:44

Yeah, something's up. I just set my pinning for all packages to use backports and fired up synaptic so I could more clearly see what version it's actually trying to install. When I check libthunar-vfs-1-2, it's pulling up 0.9 instead of 1.0. I checked some of the other packages in the group just to make sure I had the pinning setup right and most of them are on the right version. However, I did also find that xfdesktop was coming up as 4.4, while xfdesktop-data was coming up as 4.6. Strange things are afoot at the Circle K...

Swill
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny from backports

Postby Mr. Swillis » 2009-09-13 14:50

Annnd... here we go. Available architecture in the repo is limited on many of the pieces, which is probably why this is happening. Some packages, like thunar-data, are available for all architectures, but many of the others, like xfdesktop4 and libthunar-vfs-1-2, are only available on Amd64. This makes me sad, but at least it explains things. Thanks for all the replies!

Swill
And you ate the whole... wheel of cheese? How'd you do that? Heck, I'm not even mad; that's amazing.
Mr. Swillis
 
Posts: 22
Joined: 2008-02-28 04:13

Re: Need help installing Xfce 4.6 in Lenny backports [SOLVED]

Postby bugsbunny » 2009-09-13 15:10

Ah - in that case just wait and try again in a few days. It means that things are building at the moment and the builds just haven't finished yet.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Next

Return to System configuration

Who is online

Users browsing this forum: No registered users and 16 guests

fashionable