[solved] system time is too slow

Kernels & Hardware, configuring network, installing services

[solved] system time is too slow

Postby mnielsen » 2010-03-31 07:30

Hi

I have an issue with the clock on my system. It has been an issue for some time. I think it is since I update to kernel 2.6.34rc2.

Last night I use ntputil-debian to synchronize the time to 0:15. This morning at 8:00, the time was 2:45.
This is quite annoying - I am starting to be late more often :-)

I have not tried much, since I have no idea where to start.
The values above is with kernel parameters clocksource=acpi_pm - that was just a guess based on reports related to the time running twice as fast as normal.
It is obviously not working.

I have run out of search words and I have no idea of what modules this may relate to, so any suggestions will be appreciated.

I'm running an updated debian/testing on a Lenovo Ideapad S12.

Edit:
More info:

I tried reverting to the old kernel
leon:~# cat /proc/version
Linux version 2.6.32-trunk-686 (Debian 2.6.32-5) (ben@decadent.org.uk) (gcc version 4.3.4 (Debian 4.3.4-6) ) #1 SMP Sun Jan 10 06:32:16 UTC 2010

After reboot time was 18:45, both in reality and on the pc.
Later, without using the pc, at 20:26, the internal time was 19:20

leon:~# ntpdate-debian
31 Mar 20:26:01 ntpdate[2864]: step time server 212.242.32.206 offset 3899.378076 sec
(that is 65 minutes)

So it is not a kernel 2.6.34rc2 issue.

Can anyone tell me how a linux system keeps track of time?
Last edited by mnielsen on 2010-03-31 20:51, edited 1 time in total.
mnielsen
 
Posts: 2
Joined: 2010-03-31 06:52

Re: system time is too slow

Postby mnielsen » 2010-03-31 20:51

Having worked my way through this problem, I ended up with a working solution!

Add "nohz=off" to the kernel parameter list - mine is in /boot/grub/menu.lst

This will disable dynamic ticks, tickless, or whatever it is called. I still use hpet as clocksource.

Positive side effects:
- The frequency scaling governor is now working. It actually uses the full 1.6Ghz now.
- The Lenovo Ideapad S12 random freeze seems to be gone also. Freeze like in nothing happens until mouse move or keyboard event.

The Tickless thing is very cool. I feel I should report it somewhere.
Any suggestions?
mnielsen
 
Posts: 2
Joined: 2010-03-31 06:52


Return to System configuration

Who is online

Users browsing this forum: dorohoro, Johen Scott and 14 guests

fashionable