[SOLVED] Laptop does not resume from suspend

Kernels & Hardware, configuring network, installing services

[SOLVED] Laptop does not resume from suspend

Postby lbm » 2011-01-27 09:36

I have installed squeeze on a HP notebook. I have one small problem though.
It does not resume from suspend. If I shutdown -> suspend, or close the the lid, or shut downs (suspends) as expected, but when I then power it backup up, the screen just stays black.

Hibernate is working fine.

Any ideas, how I can fix this.

Thanks.

output of lspci (if needed)
Code: Select all
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.2 IDE interface: Intel Corporation Mobile 4 Series Chipset PT IDER Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650
01:00.1 Audio device: ATI Technologies Inc RV635 Audio device [Radeon HD 3600 Series]
03:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300
86:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 06)
86:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 25)
86:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 14)
86:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 14)
86:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev bb)
86:09.5 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ff)
Last edited by lbm on 2011-01-31 16:09, edited 1 time in total.
User avatar
lbm
 
Posts: 473
Joined: 2009-05-16 09:24
Location: Denmark

Re: Laptop does not resume from suspend

Postby Sephiroth » 2011-01-27 21:37

I had this same problem in Squeeze (not Lenny) on an Acer Aspire 5102WLMi. I disabled KMS and the problem disappeared. To disable KMS for an ATI card like yours and mine, you simply edit /etc/modprobe.d/radeon-kms.conf. There is only one line in the file. Change it from a 1 to a 0 (zero), save the file, and reboot. Also make sure that you have the "firmware-linux-nonfree" package installed. My ATI card required it, though yours is higher-end than mine.
Intel C2Q 3.06GHz, 8GB PC-10600, Dual 250GB SATA 3.0GBps RAID-0, Dual GTX295 2GB, X-Fi Gamer
P4/3.20GHz HT, 2GB DDR400, 120GB SATA, 7800GS 256MB, Audigy IV w/4.1 Speakers
AMD Turion64x2 1.60GHz, 1GB DDR2(667), 120GB PATA, ATI1100M
Sephiroth
 
Posts: 1012
Joined: 2007-07-05 03:30
Location: North Carolina, USA

Re: Laptop does not resume from suspend

Postby mzilikazi » 2011-01-27 22:56

In a completely different laptop I can create the same behavior with kernel 2.6.32 or older. The display never comes back from suspend. Needless to say I use a newer kernel. :)
Debian Sid Laptops:
AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55 / 1.5G
Intel(R) Pentium(R) Dual CPU T2390 @ 1.86GHz / 3G
User avatar
mzilikazi
Forum Ninja
 
Posts: 3321
Joined: 2004-09-16 02:14
Location: Colorado Springs, CO

Re: Laptop does not resume from suspend

Postby TobiSGD » 2011-01-27 23:02

Had the same problem with my HP 615, the liquorix-kernel fixed the issue.
User avatar
TobiSGD
 
Posts: 859
Joined: 2010-05-08 22:27
Location: Hannover, Germany

Re: Laptop does not resume from suspend

Postby lbm » 2011-01-28 16:14

Sephiroth wrote:I had this same problem in Squeeze (not Lenny) on an Acer Aspire 5102WLMi. I disabled KMS and the problem disappeared. To disable KMS for an ATI card like yours and mine, you simply edit /etc/modprobe.d/radeon-kms.conf. There is only one line in the file. Change it from a 1 to a 0 (zero), save the file, and reboot. Also make sure that you have the "firmware-linux-nonfree" package installed. My ATI card required it, though yours is higher-end than mine.


I asume you are using the radeon driver then? I am using fglrx.
User avatar
lbm
 
Posts: 473
Joined: 2009-05-16 09:24
Location: Denmark

Re: Laptop does not resume from suspend

Postby cynwulf » 2011-01-28 16:58

I have the same problem on my old laptop with the i915 driver. If I close the lid it freezes. The fact that the latest intel driver requires KMS in order for xorg to work at all doesn't help either. It was freezing at the point where it changes to the framebuffer console using the stock squeeze 2.6.32 kernel and only works ok with a 2.6.35 or higher kernel.
cynwulf
 
Posts: 2396
Joined: 2008-09-25 08:49

Re: Laptop does not resume from suspend

Postby lbm » 2011-01-28 17:07

TobiSGD wrote:Had the same problem with my HP 615, the liquorix-kernel fixed the issue.

It does unfortunately not support fglrx at this time. :(
User avatar
lbm
 
Posts: 473
Joined: 2009-05-16 09:24
Location: Denmark

Re: Laptop does not resume from suspend

Postby lbm » 2011-01-28 17:21

If I shutdown from gnome, and select suspend, it is working. Weird.
User avatar
lbm
 
Posts: 473
Joined: 2009-05-16 09:24
Location: Denmark

Re: Laptop does not resume from suspend

Postby oOarthurOo » 2011-01-28 19:39

Start by checking /var/log/pm-suspend.log

It should all be success or not applicable. Anything else would be a good starting point for inquiry.

Next is to start reproducing using pm-suspend from terminal as root and supplying various quirks. Open-suse had some of the best documentation on the quirks that I recall coming across. Once you find a quirk that works you can edit /usr/lib/pm-utils/sleep.d/quirksfile to match.

If you switch to a VT1 then back to X and the video comes up, there's a quirk for that.
oOarthurOo
 
Posts: 545
Joined: 2008-10-25 12:00
Location: Canada

Re: Laptop does not resume from suspend

Postby lbm » 2011-01-28 20:14

Thanks for the reply. Output from the log.

Seems to be some issues with 99video ....

Code: Select all
Fri Jan 28 20:02:52 CET 2011: performing suspend
Fri Jan 28 20:14:36 CET 2011: Awake.
Fri Jan 28 20:14:36 CET 2011: Running hooks for resume
/usr/lib/pm-utils/sleep.d/99video resume suspend:Couldn't get a file descriptor referring to the console
Couldn't get a file descriptor referring to the console
Returned exit code 1.
/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler resume suspend:success.
/usr/lib/pm-utils/sleep.d/95led resume suspend:not applicable.
/usr/lib/pm-utils/sleep.d/95anacron resume suspend:success.
/usr/lib/pm-utils/sleep.d/94cpufreq resume suspend:success.
/usr/lib/pm-utils/sleep.d/90clock resume suspend:not applicable.
/usr/lib/pm-utils/sleep.d/75modules resume suspend:success.
/usr/lib/pm-utils/sleep.d/70action_wpa resume suspend:success.
/usr/lib/pm-utils/sleep.d/55NetworkManager resume suspend:success.
/usr/lib/pm-utils/sleep.d/49bluetooth resume suspend:not applicable.
/etc/pm/sleep.d/10_unattended-upgrades-hibernate resume suspend:success.
/usr/lib/pm-utils/sleep.d/00powersave resume suspend:success.
/usr/lib/pm-utils/sleep.d/00logging resume suspend:success.
/usr/lib/pm-utils/sleep.d/000kernel-change resume suspend:success.
User avatar
lbm
 
Posts: 473
Joined: 2009-05-16 09:24
Location: Denmark

Re: Laptop does not resume from suspend

Postby Sephiroth » 2011-01-29 02:44

Not the official driver. I was told all I needed to do was install "firmware-linux-nonfree" and it would work. It does, and quite well too. The card is an ATI1100M, not a high-end card. Would I see any benefit (increased FPS) by switching to fglrx?
Intel C2Q 3.06GHz, 8GB PC-10600, Dual 250GB SATA 3.0GBps RAID-0, Dual GTX295 2GB, X-Fi Gamer
P4/3.20GHz HT, 2GB DDR400, 120GB SATA, 7800GS 256MB, Audigy IV w/4.1 Speakers
AMD Turion64x2 1.60GHz, 1GB DDR2(667), 120GB PATA, ATI1100M
Sephiroth
 
Posts: 1012
Joined: 2007-07-05 03:30
Location: North Carolina, USA

Re: Laptop does not resume from suspend

Postby lbm » 2011-01-29 11:33

To be hornest, I do not know.
User avatar
lbm
 
Posts: 473
Joined: 2009-05-16 09:24
Location: Denmark

Re: Laptop does not resume from suspend

Postby TobiSGD » 2011-01-29 21:20

lbm wrote:
TobiSGD wrote:Had the same problem with my HP 615, the liquorix-kernel fixed the issue.

It does unfortunately not support fglrx at this time. :(

Writing this from my laptop with liquorix-kernel and fglrx from experimental. Works fine.
User avatar
TobiSGD
 
Posts: 859
Joined: 2010-05-08 22:27
Location: Hannover, Germany

Re: Laptop does not resume from suspend

Postby oOarthurOo » 2011-01-29 21:24

If it's choking on that 99video try moving it out of the way.
Code: Select all
mkdir /usr/lib/pm-utils/sleep.d/disabled
mv /usr/lib/pm-utils/sleep.d/99video /usr/lib/pm-utils/sleep.d/disabled/99video


Also have a look in /usr/lib/pm-utils/videos-quirks/20-video-quirk-pm-hp.quirkdb

Look for your model and see what if any quirks it is trying to apply.
oOarthurOo
 
Posts: 545
Joined: 2008-10-25 12:00
Location: Canada

Re: Laptop does not resume from suspend

Postby lbm » 2011-01-31 16:09

oOarthurOo wrote:If it's choking on that 99video try moving it out of the way.
Code: Select all
mkdir /usr/lib/pm-utils/sleep.d/disabled
mv /usr/lib/pm-utils/sleep.d/99video /usr/lib/pm-utils/sleep.d/disabled/99video


Also have a look in /usr/lib/pm-utils/videos-quirks/20-video-quirk-pm-hp.quirkdb

Look for your model and see what if any quirks it is trying to apply.


I moved the 99video, as described and it is now working! Thanks a lot!
User avatar
lbm
 
Posts: 473
Joined: 2009-05-16 09:24
Location: Denmark

Next

Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable