Kernel: Disabling IRQ #17

Kernels & Hardware, configuring network, installing services

Kernel: Disabling IRQ #17

Postby MarcusW » 2011-04-03 15:33

Hey.

I run multiseat, and after gdm has been up for a while all of my terminals get the message
Code: Select all
Kernel: Disabling IRQ #17

and the htpc seat gets a bunch of rendering errors and becomes really unresponsive. The problem goes away when I restart GDM but I don't want to have to do that a couple of times per day. Both of the seats are running Nvidia, latest beta driver (the latest stable had the same problem). My motherboard is an Asus P67 Sabertooth, and the problem first came after I switched from my old motherboard. From some googling I found something about enabling the kernel option "noirqdebug". Can I try it without compiling the kernel myself, maybe by adding something in proc or grub?

Thanks,
Marcus
MarcusW
 
Posts: 183
Joined: 2009-12-04 14:52
Location: Sweden

Re: Kernel: Disabling IRQ #17

Postby aab » 2011-04-05 16:01

Yes, just add "noirqdebug" in /etc/default/grub, between the quotes of the line GRUB_CMDLINE_LINUX_DEFAULT. Then run update-grub, and restart.
aab
 
Posts: 19
Joined: 2010-10-08 17:44

Re: Kernel: Disabling IRQ #17

Postby MarcusW » 2011-04-05 17:40

aab wrote:Yes, just add "noirqdebug" in /etc/default/grub, between the quotes of the line GRUB_CMDLINE_LINUX_DEFAULT. Then run update-grub, and restart.


Thanks! I added it in "grub.cfg" and it seems to help, but I didn't know where to put it so it would survive the next "update-grub". :)
MarcusW
 
Posts: 183
Joined: 2009-12-04 14:52
Location: Sweden


Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable