Disable gdm3 startup beep

Kernels & Hardware, configuring network, installing services

Disable gdm3 startup beep

Postby Iorek » 2011-06-10 16:20

Hello!

I got a problem with a Dell Latitude E5500. I can not disable the hardware beep after the gdm3 login screen has been loaded. All alsa beeps and system sounds are disabled and/or muted. I also tried setterm -blength 0, xset -b in startup scripts. They disable terminal-beeps, but not the halt or the gdm login beep. I tried wasting around with the gconftool, but nothing happened. It is an annoying sound. If you use, init 0 to shut down, no beep comes up.

Has anyone a solution?


wkr

Iorek
"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former." Albert Einstein

I only say: Excuse me for being!
Iorek
 
Posts: 105
Joined: 2009-07-10 12:23
Location: Germany

Re: Disable gdm3 startup beep

Postby golinux » 2011-06-10 16:37

This worked for me:

In /etc/gdm3/greeter.gconf-defaults look for this line and make sure it's set to false:

Code: Select all
# Play system beeps - especially the one when the greeter is ready
/desktop/gnome/sound/event_sounds      false


There is also a Gnome Login Sound option under preferences Startup Applications that you can disable.
May the FORK be with you!
User avatar
golinux
 
Posts: 1377
Joined: 2010-12-09 00:56
Location: not a 'buntard!

Re: Disable gdm3 startup beep

Postby Iorek » 2011-06-10 17:18

Hey golinux!

I also tried the option for gdm3. But nothing happens. Disabling the startup-programs does not help, etiher. I think it must have something to do, with a hardware problem, because I have seen this problem on other Dell machines, too....maybe a special hardware broadcast message, that the motherboard throws as a beep. But I do not know, if and how I can disable that.


wkr
"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former." Albert Einstein

I only say: Excuse me for being!
Iorek
 
Posts: 105
Joined: 2009-07-10 12:23
Location: Germany

Re: Disable gdm3 startup beep

Postby Revenger » 2011-06-10 19:50

I blacklisted pc speaker module to disable gdm beep.

Code: Select all
echo "blacklist pcspkr" >> /etc/modprobe.d/blacklist.conf
Next time someone says 'Go to hell' to me, I come right here.

Do you need bad help?
Revenger
 
Posts: 383
Joined: 2010-11-16 11:47

Re: Disable gdm3 startup beep

Postby Iorek » 2011-06-10 20:30

Hey Revenger!

That was my first guess, but it is already blacklisted and has never been loaded. I think this module was removed to be loaded, maybe for that reason. But I still got the problem.

I think it is a little bit strange, because I was able to disable all terminal beeps even without x. I think it is a problem with the runlevel. It gets disabled after that beep on startup and halt in an other runlevel.


wkr
"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former." Albert Einstein

I only say: Excuse me for being!
Iorek
 
Posts: 105
Joined: 2009-07-10 12:23
Location: Germany

Re: Disable gdm3 startup beep

Postby rivenathos » 2011-06-10 20:34

The method mentioned above by golinux worked like a charm for me. I now have a quiet start up.
Currently running Debian 9 GNOME on a Dell OptiPlex 3010, Dell Inspiron 1545, and a Dell Inspiron 531.
Linux User #461545
User avatar
rivenathos
 
Posts: 203
Joined: 2009-01-09 11:57
Location: Georgia, USA

Re: Disable gdm3 startup beep

Postby Iorek » 2011-06-20 21:20

Hey!

The method with the gdm-config file does not work. In fact it is a Mint LMDE installation. It seems as if everytime you reboot the system a standard config file gets loaded. If I edit the lines, they are not there after reboot. How can I fix this?


wkr
"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former." Albert Einstein

I only say: Excuse me for being!
Iorek
 
Posts: 105
Joined: 2009-07-10 12:23
Location: Germany

Re: Disable gdm3 startup beep

Postby hinaeen » 2011-07-09 23:57

Hello,

Just disable the Beep in alsamixer, you can use the graphical applet in systray, select the sound card indicating (Alsa mixer) and mute the Beep selector.
hinaeen
 
Posts: 1
Joined: 2011-07-09 23:55

Re: Disable gdm3 startup beep

Postby Iorek » 2011-07-10 14:15

Hey,

the beep is disabled in alsa. But nevertheless a beep sound comes on startup. After login everything is muted....
"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former." Albert Einstein

I only say: Excuse me for being!
Iorek
 
Posts: 105
Joined: 2009-07-10 12:23
Location: Germany

Re: Disable gdm3 startup beep

Postby -Robert- » 2011-07-10 14:36

Try this:
golinux wrote:This worked for me:

In /etc/gdm3/greeter.gconf-defaults look for this line and make sure it's set to false:

Code: Select all
# Play system beeps - especially the one when the greeter is ready
/desktop/gnome/sound/event_sounds      false



and run

Code: Select all
# invoke-rc.d gdm3 reload
User avatar
-Robert-
 
Posts: 23
Joined: 2011-03-31 15:16
Location: The Netherlands

Re: Disable gdm3 startup beep

Postby dtl131 » 2011-07-13 20:24

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=628858
If that doesn't work, open a new bug.

Another possible workaround is to install libcanberra-pulse, so event sounds require pulseaudio to be loaded (and it probably isn't loaded until your user session begins). IIRC, it won't fall back to using alsa to play the login prompt.
dtl131
 
Posts: 449
Joined: 2011-07-11 19:56

Re: Disable gdm3 startup beep

Postby deb-wrangler » 2011-10-07 12:54

That sound drove me mad.

I found that running
# gdmsetup
as root or superuser
then unchecking all boxes under "Sounds" on the "Accessibility" tab
got rid of it.
deb-wrangler
 
Posts: 1
Joined: 2011-10-07 12:40

Re: Disable gdm3 startup beep

Postby enok » 2012-01-22 14:10

I had the same issue with the system beep when the gdm3 login screen loaded and when I rebooted. It turns out it was the sound card module (snd_hda_intel) that was causing it. The snd_hda_intel has an option, "beep_mode", that grabs the system beep when it loads, overriding pcspkr. And, of course, "beep_mode" is enabled by default. That's why you still get the beep even when you remove and blacklist pcspkr.

Code: Select all
# modinfo snd_hda_intel | grep beep
parm:           beep_mode:Select HDA Beep registration mode (0=off, 1=on, 2=mute switch on/off) (default=1). (array of int)


To disable the system beep:

Code: Select all
# echo "options snd_hda_intel beep_mode=0" >> /etc/modprobe.d/alsa-base.conf
# echo "blacklist pcspkr" >> /etc/modprobe.d/blacklist.conf


That should get rid of the annoying beep you get when gdm3 loads and in the console. The Intel HD audio chipset is common in laptops now, so if you have a laptop that won't stop beeping, snd_hda_intel is likely the culprit. I haven't tried the "beep_mode=2" mute switch option, so I'm not sure what it does.
User avatar
enok
 
Posts: 1
Joined: 2012-01-22 13:33


Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable