shutdown hangs *stopping enhanced syslogd: rsyslogd*

Kernels & Hardware, configuring network, installing services

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby enle » 2011-11-01 16:18

nilssn wrote:Does anyone have more information or a permanent solution to this problem?


If your PC hangs on shutdown with "stopping enhanced syslogd: rsyslogd" caused by NFS that cannot be unmounted, then there is a workaround.
Have a look at:
https://bugs.launchpad.net/ubuntu/+sour ... bug/859075

Stevan Kew Ell (slql) wrote on 2011-10-29: #41

I have a hack that works for me. I should say that I have a very incomplete understanding of the way the umount* files work with each other, but I don't think the hack is likely to affect anything else.

I have edited the file /etc/init.t/umountnfs.sh

Somewhere around line 84, alter the following line:-
fstab-decode umount $FLAGS $DIRS
to

fstab-decode /sbin/umount.nfs $DIRS $FLAGS

Note that the two options need to be switched around to $DIRS $FLAGS

This works on Wheezy too.

S


Regards
enle
 
Posts: 9
Joined: 2011-10-11 15:26
Location: Belgium-Antwerp

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby nilssn » 2011-11-01 17:42

Thanks for the tip. Unfortunately it didn't work. Probably because I mount nfs using /etc/rc.local and not fstab.
nilssn
 
Posts: 54
Joined: 2010-04-26 17:28

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby patryk007 » 2011-11-01 17:56

I have identical problem.
If someone has already found nice workaround then share with us, please.
patryk007
 
Posts: 43
Joined: 2011-01-07 12:03
Location: Poland

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby riptorn » 2011-11-16 02:28

Sorry if I'm too late to this thread, but did not see a solution posted.
On my system it seems that wicd is killed before umountnfs.sh in file rc0.d and rc6.d, causing the system to hang
I have remote nfs mounts that are auto mounted in fstab that hang on shutdown.
I cannot find an easy way to change the order in rc0.d, and rc6.d with with update-rc.d
but if i manually change it it shuts down correctly, so it seems the order is the culprit.

probably a better way is to add:
umount -a -t nfs

below do_stop() in the wicd script in /etc/init.d
then it shuts down quickly without having to change script orders.
I'm sure there must be a better solution.
Would there be a automated way to change wicd kill order to after umountnfs.sh ?
riptorn
 
Posts: 1
Joined: 2011-11-16 02:02


Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby go4linux » 2011-12-02 05:08

nilssn wrote:After further investigation I think the problem is that the network is taken down (network-manager/wicd killed) before nfs is unmounted causing the umount command to hang.
As a temporary fix I have disabled network-manager and configured my wireless with the interfaces file.

I have the same problem, and I agree on the cause. So I looked at /etc/rc0.d, and I don't understand a couple of things:

- why is network-manager called before umountnfs.sh?
- why is sendsigs not called at last? and why is rpcbind one of the processes excluded from the list of processes to kill?
go4linux
 
Posts: 16
Joined: 2011-12-02 04:56

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby Christopher888 » 2012-01-01 04:30

Hi,

I am experiencing this problem on wheezy and cannot shutdown my system.

I can confirm that this is related to nfs. Any word on a fix?
Christopher888
 
Posts: 7
Joined: 2011-11-28 04:10

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby jpaulb » 2012-01-01 22:01

I did an update and the problem went away.
jpaulb
 
Posts: 56
Joined: 2007-12-19 17:23

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby nilssn » 2012-01-27 19:51

Still having this problem with an updated Testing.
nilssn
 
Posts: 54
Joined: 2010-04-26 17:28

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby jpaulb » 2012-01-27 21:08

I have done a couple updates and the problem has gone away for the time being :roll:
jpaulb
 
Posts: 56
Joined: 2007-12-19 17:23

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby layr » 2012-03-06 20:22

Still no solution for this issue?
EDIT: my workaround:
being root, create file unmount_nfs.sh in /etc/init.d/ with the following contents and make it executable.
Code: Select all
#!/bin/bash
#script for automatic unmounting of nfs drive on reboot and shutdown
umount /mnt/server
exit
( /mnt/server should be replaced by your mount point)

Then in terminal, also being root, run
Code: Select all
update-rc.d unmount_nfs.sh start 20 0 6 .
(including the period)
User avatar
layr
 
Posts: 81
Joined: 2011-10-11 15:07

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby cuda » 2012-03-14 16:29

I also have this issue with a NFS drive and wireless/network-manager connection on my laptop.

I've been having good luck with this network-manager script which I put in the /etc/NetworkManager/dispatcher.d directory. I called it 00nfs and made it executable. It simply mounts or unmounts all the NFS shares whenever the connection goes up or down. I still kept all of my NFS mount information in /etc/fstab.

/etc/NetworkManager/dispatcher.d/00nfs

Code: Select all
#!/bin/sh

# mount/unmount NFS shares on network-manager up/down events.

case "$2" in
   up)
      mount -a -t nfs4
      ;;
   down)
      umount -a -t nfs4
      ;;
esac


Note that the -t option seems to be finicky about whether you specify nfs or nfs4. If I specify nfs as the filesystem type in fstab, I am able to mount all of my NFS4 shares with -t nfs, but to unmount them I have to use -t nvf4. For consistency, I specify nfs4 everywhere.
Freak of nature.
User avatar
cuda
 
Posts: 19
Joined: 2009-06-22 00:44

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby parmenion » 2013-03-17 12:14

I've had a similar problems having a some cifs filesystems mounted.
I've solved the problem by renaming the kill-scripts to change the order of execution:
Code: Select all
mv /etc/rc0.d/K04rsyslog /etc/rc0.d/K05rsyslog
mv /etc/rc0.d/K05umountnfs.sh /etc/rc0.d/K04umountnfs.sh
mv /etc/rc6.d/K04rsyslog /etc/rc6.d/K05rsyslog
mv /etc/rc6.d/K05umountnfs.sh /etc/rc6.d/K04umountnfs.sh

But i'm not sure if this the right way to fix the problem.
parmenion
 
Posts: 5
Joined: 2013-03-17 12:00

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby llivv » 2013-03-17 17:30

Have any of the first three posters int his thread tried installing the testing default kernel to see if it works?
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: shutdown hangs *stopping enhanced syslogd: rsyslogd*

Postby parmenion » 2013-03-19 18:51

I've to begdown: the renaming did not fix it. I don't know why but the effekt reoccured.

I've investigated a bit further:
My network connection is via WLAN and read about problems with unmounting file systems when the network-manager has already stop.
Last edited by parmenion on 2013-03-19 19:05, edited 1 time in total.
parmenion
 
Posts: 5
Joined: 2013-03-17 12:00

PreviousNext

Return to System configuration

Who is online

Users browsing this forum: No registered users and 18 guests

fashionable