Extremelly sensitive volume applet [GNOME 3, pulse]

Kernels & Hardware, configuring network, installing services

Extremelly sensitive volume applet [GNOME 3, pulse]

Postby g1annos » 2012-02-11 22:34

After kernel upgrade from 3.0 to 3.2 any slight scroll to the volume applet results in disproportional sound volume change. If it is in the highest level, and I just do 3 click scrolling down, I cannot hear anything. The pointer goes follows the scrolling and not the volume. Which means that 3 click clicks scrolling down, makes it go 3 positions down, and NOT to the bottom (as it should do if it was related with the volume level).

I noticed something strange:

if I go to alsamixer and choose (with F6) my nvidia soundcard, there are many levels displayed, and adjusting the MASTER I can adjust my system volume normaly (within alsamixer)
if I choose the default (which is pulse I think), there is ONE ONLY adjuster, which if adjusted to 65% no sound comes out (even with the speakers level at max).

I haven't done any sound relative update to my system since a lot of time.

Any ideas?
g1annos
 
Posts: 122
Joined: 2008-12-01 02:15

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby g1annos » 2012-02-13 21:12

At least, is there anybody who can help me tell if this is a bug of the last kernel release?
g1annos
 
Posts: 122
Joined: 2008-12-01 02:15

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby th3voic3 » 2012-02-27 23:59

Hey,

I can't propose a solution, but I have the same problem.
th3voic3
 
Posts: 5
Joined: 2012-02-06 13:42

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby g1annos » 2012-02-28 10:45

Does it happen to you after kernel update to 3.2 as well?
g1annos
 
Posts: 122
Joined: 2008-12-01 02:15

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby th3voic3 » 2012-02-28 12:02

Yep.
I still have kernel 3.1.0.1 installed and booting with that kernel everything works as it should.
When I start alsamixer from the command line to check the state of the volume sliders I can see that the Master volume for my sound card stays on zero most of the time and then only goes up at about 50% Pulseaudio volume. Apart from that all the sliders seem to change at random as well.
So it seems that pulseaudio and alsa aren't communicating well with the new kernel, but I'm not an expert on that.
th3voic3
 
Posts: 5
Joined: 2012-02-06 13:42

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby g1annos » 2012-02-29 11:47

Could you tell me which is your Sound Card so that I can fill a good bug report.

Mine is this:

Audio device: nVidia Corporation MCP73 High Definition Audio (rev a1)

It is embeded device on my motherboard: ASUS P5N73-CM
g1annos
 
Posts: 122
Joined: 2008-12-01 02:15

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby th3voic3 » 2012-02-29 17:56

Hey,

the one I'm using is:
Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)

(The computer also has:
Audio device: nVidia Corporation HDMI Audio stub (rev a1)
But I don't think that the second one has got anything to do with the bug.)
th3voic3
 
Posts: 5
Joined: 2012-02-06 13:42

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby jonoerik » 2012-03-01 13:21

I'm experiencing similar symptoms running Pulseaudio on KDE4.
Linux Kernel 3.2.0-1-amd64
Pulseaudio version 1.0-4
Playing sound through Microsoft LifeChat LX-3000 USB headset
Reasonable volume is between 35% to 45% on alsamixer's master card (pulseaudio), which matches about 0% to 15% on the card (changing one slider moves the other)

Code: Select all
>>> arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: LX3000 [Microsoft LifeChat LX-3000], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Alsamixer also lists a 3rd card:
Card: HDA NVidia
Chip: Nvidia GPU 0a HDMI/DP

The problem also ocurred on a fresh install of Linux Mint 12 KDE, but not on Mint 10 (which was running Pulseaudio 0.9.21-63)
jonoerik
 
Posts: 9
Joined: 2012-03-01 13:05

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby g1annos » 2012-03-01 13:51

So, it's sure a bug. I tried a new Debian Testing 64bit installation, and I tried a new user in this new installation, and the problem remains.

Shall anybody fill a bug report? I couldn't say I'm an advanced user, so it should be better if another person fill the bug report, and the others just confirm and provide extra information. Otherwise I can fill it and you just confirm and give advanced info.

What do you think?
g1annos
 
Posts: 122
Joined: 2008-12-01 02:15

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby adenukolnis » 2012-03-01 15:28

A bug report because the volume applet is sensitive?
adenukolnis
 
Posts: 459
Joined: 2012-02-24 18:36

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby g1annos » 2012-03-01 18:54

adenukolnis wrote:A bug report because the volume applet is sensitive?
Yes. Is that curious??? You may have to have a look at the screenshots. As you can see for each slight scroll down to the Volume Applet there is a proportional change to Pulse Master Volume, but a totally DIS-proportional change to ALSA Master Volume. When Pulse volume is in 75% almost nothing cannot be heard!

I don't know if it doesn't matter to you, but it is really annoying for me. Anyway, is this thing called somehow else rather that a BUG???

In your opinion isn't it a bug if the Volume Applet is totally useless in a fresh Debian installation with a new Desktop user???

I'm looking forward for a workaround to fix this problem ...if it isn't really a bug. I'm really anxious, because it's almost a month that I cannot use the applet, and I'm using the potentiometer of the speakers in order to adjust the volume.
Attachments
2pvma.jpg
2pvma.jpg (158.56 KiB) Viewed 6112 times
4pvma.jpg
4pvma.jpg (161.46 KiB) Viewed 6112 times
7pvma.jpg
7pvma.jpg (166.84 KiB) Viewed 6112 times
g1annos
 
Posts: 122
Joined: 2008-12-01 02:15

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby jonoerik » 2012-03-02 01:15

adenukolnis wrote:A bug report because the volume applet is sensitive?

Mainly that the system is unreasonably sensitive. Not just alsamixer, but also kmix and pavucontrol. It might be worth requesting from the pulse team a way to restrict volume to a smaller range within the full capability, but in this case, pulse is too sensitive to even allow that range to exist. On my install, reducing the master volume to below 35% causes the headset volume to be scaled to 0%, so any volume adjustment below 35% just results in silence. On the working Mint10 install, these channels weren't linked; so I could leave the headset volume at around 16%, and then the master volume would provide an adequate range or values from 0-100%. Is there a way of unlinking the volumes, so that master and individual cards can be set independently?
jonoerik
 
Posts: 9
Joined: 2012-03-01 13:05

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby jonoerik » 2012-04-03 11:44

I've looked around, and setting 'flat-volumes = no' in /etc/pulse/daemon.conf has helped with managing the unstable volumes by stopping programs from messing with the master volume. I've also recently got a wireless usb headset which doesn't suffer from this problem quite as significantly. Alsamixer just shows the master device (pulse) as having one channel, and the headset as having a single channel (PCM). Changing either of these affects the other almost equally. Is there a setting that disables this linking of volumes, allowing them to be set independently? This would go some way to fixing the sensitivity issue.
jonoerik
 
Posts: 9
Joined: 2012-03-01 13:05

Re: Extremelly sensitive volume applet [GNOME 3, pulse]

Postby th3voic3 » 2012-04-14 12:04

I've switched to Arch Linux and had the issue there, too, but it is fixed with kernel 3.3.1 now.
th3voic3
 
Posts: 5
Joined: 2012-02-06 13:42


Return to System configuration

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable