Hardware clock and dual boot

Kernels & Hardware, configuring network, installing services

Hardware clock and dual boot

Postby dbbolton » 2012-06-06 02:58

I installed Debian stable, and set the HW clock to UTC, installed NTP, and all was well.

Some time later, I installed Windows and things got ugly. Obviously UTC is way to standardized for Microsoft to handle, so Windows will always show the wrong time.

The simple solution would be to tell Debian that the HW clock is now in local time, and then NTP will adjust it accordingly. I've set "UTC=no" in /etc/default/rcS, but I'm not sure if there's anything else I'll need to do.
GitHub | zsh docs in Letter PDF

Telemachus wrote:Put down the CGI.
User avatar
dbbolton
 
Posts: 2133
Joined: 2007-06-20 08:17
Location: Iapetus

Re: Hardware clock and dual boot

Postby squeezy » 2012-06-06 05:27

dbbolton wrote:I've set "UTC=no" in /etc/default/rcS, but I'm not sure if there's anything else I'll need to do.


That's all I've been doing and have had no problems with Windows or Debian showing the correct time.
squeezy
 
Posts: 57
Joined: 2012-05-28 04:34

Re: Hardware clock and dual boot

Postby sotrud_nik » 2012-06-14 11:22

ChangeLog for initscripts says:

sysvinit (2.88dsf-25) experimental; urgency=low

[ Roger Leigh ]
* Build with hardening flags enabled; CFLAGS and LDFLAGS are passed
to all build commands.
* initscripts:
- /etc/default/rcS is no longer managed by ucf, and is a regular
conffile. Drop the UTC setting, which has been migrated to
/etc/adjtime by util-linux. Break util-linux << 2.20.1-5 in order
to ensure correct migration of the UTC setting before the file is
upgraded.
- Use ifquery in /etc/network/if-up.d/mountnfs to replace complex
parsing. Also only run if inet or inet6 interfaces have been
configured, to avoid freezing when the interface hasn't yet
been configured (Closes: #674039).
- %VM tmpfs size calculation works when swap is disabled.
-- Roger Leigh <rleigh@debian.org> Tue, 22 May 2012 23:46:14 +0100


My question here is - how to set this parameter with dpkg-reconfigure or preseed files?
I am building the LiveCD and just putting pre-configured /etc/adjtime does not work, it gets overwritten at boot.
sotrud_nik
 
Posts: 4
Joined: 2011-01-14 07:01

Re: Hardware clock and dual boot

Postby jongkind » 2012-06-14 14:57

I'm using Debian testing. There you can edit the file:
/etc/adjtime

In that file change UTC to LOCAL

grtz, Herman
jongkind
 
Posts: 78
Joined: 2009-05-30 12:24


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable