Unmet Dependencies: default-jdk

Kernels & Hardware, configuring network, installing services

Unmet Dependencies: default-jdk

Postby xpandismo » 2012-06-23 04:31

I'm trying to upgrade from stable to wheezy, and I ran into a couple problems.

The first thing I encountered was while I was doing a dist-upgrade:
E: Internal Error, Could not perform immediate configuration on 'default-jre'


I searched around and did a bunch of commands such as apt-get -f install and apt-get -y install default-jre.

I then went into /var/cache/apt/archives and tried to manually install default-jre, only to encounter dependency errors that tell me things like "default-jre depends on default-jre-headless" and "default-jre-headless depends on openjdk-jre-headless."

Now whenever I try to do a dist-upgrade or install default-jre, I get this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
default-jdk : Depends: default-jre (= 1:1.6-40) but 1:1.6-47 is installed
default-jre-headless : Depends: openjdk-6-jre-headless (>= 6b23~pre8-2~) but 6b18-1.8.13-0+squeeze1 is installed
openjdk-6-jre : Depends: openjdk-6-jre-headless (= 6b24-1.11.1-6) but 6b18-1.8.13-0+squeeze1 is installed
Depends: libjpeg8 (>= 8c) but 8b-1 is installed
Depends: libpulse0 (>= 0.99.1) but 0.9.21-3+squeeze1 is installed
Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not installed
Recommends: icedtea-netx but it is not installed
E: Unmet dependencies. Try using -f.


I tried using -f, but it gave almost the exact same thing.

I'm so confused right now. If anybody could help, that would be great.
xpandismo
 
Posts: 8
Joined: 2011-10-28 01:25

Re: Unmet Dependencies: default-jdk

Postby craigevil » 2012-06-23 04:40

post the output of what happens when you do apt-get -f install

Easiest way might be to just use Synaptic and force the version you need for each package.

What happens when you try doing:
apt-get install openjdk-6-jre-headless
Debian Sid KDE Kernel 3.17 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5192
Joined: 2006-09-17 03:17
Location: Oz

Re: Unmet Dependencies: default-jdk

Postby 4D696B65 » 2012-06-23 05:01

Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not installed

ubuntu package? :roll:
User avatar
4D696B65
 
Posts: 2027
Joined: 2009-06-28 06:09

Re: Unmet Dependencies: default-jdk

Postby xpandismo » 2012-06-23 05:02

apt-get -f install:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
default-jdk : Depends: default-jre (= 1:1.6-40) but 1:1.6-47 is installed
default-jre-headless : Depends: openjdk-6-jre-headless (>= 6b23~pre8-2~) but 6b18-1.8.13-0+squeeze1 is installed
openjdk-6-jre : Depends: openjdk-6-jre-headless (= 6b24-1.11.1-6) but 6b18-1.8.13-0+squeeze1 is installed
Depends: libjpeg8 (>= 8c) but 8b-1 is installed
Depends: libpulse0 (>= 0.99.1) but 0.9.21-3+squeeze1 is installed
Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not installed
Recommends: icedtea-netx but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


apt-get install openjdk-6-jre-headless:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
default-jdk : Depends: default-jre (= 1:1.6-40) but 1:1.6-47 is to be installed
openjdk-6-jre : Depends: libjpeg8 (>= 8c) but 8b-1 is to be installed
Depends: libpulse0 (>= 0.99.1) but 0.9.21-3+squeeze1 is to be installed
Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not going to be installed
Recommends: icedtea-netx but it is not going to be installed
openjdk-6-jre-headless : Depends: openjdk-6-jre-lib (= 6b24-1.11.1-6) but 6b18-1.8.13-0+squeeze1 is to be installed
PreDepends: multiarch-support but it is not going to be installed
Recommends: icedtea-6-jre-cacao (= 6b24-1.11.1-6) but it is not going to be installed
Recommends: icedtea-6-jre-jamvm (= 6b24-1.11.1-6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


I tried using Synaptic to install default-jre, but it told me to fix the broken packages.

Thanks for the reply!
xpandismo
 
Posts: 8
Joined: 2011-10-28 01:25

Re: Unmet Dependencies: default-jdk

Postby xpandismo » 2012-06-23 05:03

4D696B65 wrote:
Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not installed

ubuntu package? :roll:


I have no idea how that got in there. I didn't do it :?
xpandismo
 
Posts: 8
Joined: 2011-10-28 01:25

Re: Unmet Dependencies: default-jdk

Postby xpandismo » 2012-06-23 06:41

I switched back to the Squeeze repos and did a apt-get -f install, which fixed the broken packages. However, now I'm back to square one. I still can't do a dist-upgrade. It gives me:
E: Could not perform immediate configuration on 'default-jre'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)


Any ideas on how to fix this? Or could the maintainers have screwed up and put the Ubuntu dependency in there by accident?
xpandismo
 
Posts: 8
Joined: 2011-10-28 01:25

Re: Unmet Dependencies: default-jdk

Postby roseway » 2012-06-23 09:32

Have you tried doing an ordinary upgrade first, then a dist-upgrade after?
Eric
User avatar
roseway
 
Posts: 1479
Joined: 2007-12-31 22:50
Location: Kent, UK

Re: Unmet Dependencies: default-jdk

Postby xpandismo » 2012-06-24 19:27

I managed to get past it by issuing:
sudo apt-get -o APT::Immediate-Configure=false -f dist-upgrade


That went through with barely any problems, but I think it may have broken Gnome. Other than that, all works fine. Thanks for all of your help.
xpandismo
 
Posts: 8
Joined: 2011-10-28 01:25

Re: Unmet Dependencies: default-jdk

Postby michelwilhelm » 2012-10-15 19:23

Thank xpandismo, this fix worked for me
michelwilhelm
 
Posts: 1
Joined: 2012-10-15 19:22


Return to System configuration

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable