Sid - Cinnamon crashes on open Menu after today's upgrade

Everything about X, Gnome, KDE, ... and everything running on it

Sid - Cinnamon crashes on open Menu after today's upgrade

Postby giaur » 2018-08-09 07:49

Packages upgraded today:

Code: Select all
gir1.2-harfbuzz-0.0 (1.8.5-1) to 1.8.6-1
google-chrome-stable (68.0.3440.84-1) to 68.0.3440.106-1
libegl1 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libegl1:i386 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libgl1 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libgl1:i386 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libgles2 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libglvnd-core-dev (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libglvnd-dev (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libglvnd0 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libglvnd0:i386 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libglx0 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libglx0:i386 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libharfbuzz-dev (1.8.5-1) to 1.8.6-1
libharfbuzz-gobject0 (1.8.5-1) to 1.8.6-1
libharfbuzz-icu0 (1.8.5-1) to 1.8.6-1
libharfbuzz0b (1.8.5-1) to 1.8.6-1
libharfbuzz0b:i386 (1.8.5-1) to 1.8.6-1
libmariadbclient18 (1:10.1.34-1) to 1:10.1.35-1
libopengl0 (1.0.0+git20180308-3) to 1.0.0+git20180308-4
libqt5keychain1 (0.9.0-1) to 0.9.0-2
libwps-0.4-4 (0.4.9-1) to 0.4.10-1
python-pickleshare (0.7.4-2) to 0.7.4-3
rsyslog (8.36.0-1) to 8.37.0-1
wpasupplicant (2:2.6-17) to 2:2.6-18


After reverting all of them to previous versions, all is fine again. Do you have any idea which one could cause this problem?
giaur
 
Posts: 64
Joined: 2013-03-08 07:03

Re: Sid - Cinnamon crashes on open Menu after today's upgrad

Postby giaur » 2018-08-09 07:59

Well it seems harfbuzz packages upgrade causes that. Can anybody confirm?
giaur
 
Posts: 64
Joined: 2013-03-08 07:03

Re: Sid - Cinnamon crashes on open Menu after today's upgrad

Postby giaur » 2018-08-10 04:44

I captured logs from .xsession-errors, error message:

Code: Select all
cinnamon: ../../src/hb-machinery-private.hh:642: void hb_lazy_loader_t<WheresFace, Subclass, Returned, Stored>::set_stored(Stored*) [with unsigned int WheresFace = 1; Subclass = hb_table_lazy_loader_t<1, OT::GDEF>; Returned = OT::GDEF; Stored = hb_blob_t]: Condition `instance == nullptr' is not met
Traceback (most recent call last):
  File "/usr/bin/cinnamon-launcher", line 55, in <module>
    os.execvp(FALLBACK_COMMAND, (FALLBACK_COMMAND,) + FALLBACK_ARGS)
  File "/usr/lib/python3.6/os.py", line 559, in execvp
    _execvpe(file, args)
  File "/usr/lib/python3.6/os.py", line 604, in _execvpe
    raise last_exc.with_traceback(tb)
  File "/usr/lib/python3.6/os.py", line 594, in _execvpe
    exec_func(fullname, *argrest)
FileNotFoundError: [Errno 2] No such file or directory


I actually want to avoid downgrading libs, any ideas?
giaur
 
Posts: 64
Joined: 2013-03-08 07:03

Re: Sid - Cinnamon crashes on open Menu after today's upgrad

Postby None1975 » 2018-08-10 13:06

giaur wrote:I actually want to avoid downgrading libs, any ideas?

Report a bug and wait for someone to fix it.
OS: Debian 9.4 / WM: Xmonad
Debian Wiki | DontBreakDebian, My config files in github
Linux User #607425
User avatar
None1975
 
Posts: 559
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable