[SOLVED] Gnome date format

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] Gnome date format

Postby Totoxa » 2019-06-11 01:24

Hi,

I'm running debian testing and sometime ago I reported an issue with the date format in gnome shell (see https://gitlab.gnome.org/GNOME/gnome-shell/issues/592).
That issue is supposed to be fixed upstream and I though that debian still had the problem because I am seeing the same incorrect date format.
That's until I do a new debian testing setup on another laptop and in this setup the date format is correct. See the attached images:
Old debian testing setup (wrong date format)
Image
New debian testing setup (correct date format)
Image

I've compared the translation files and they look the same on both systems.

Where else can I look for differences?
Last edited by Totoxa on 2019-06-14 03:03, edited 1 time in total.
Totoxa
 
Posts: 21
Joined: 2015-01-02 17:19

Re: Gnome date format

Postby Head_on_a_Stick » 2019-06-11 09:14

Is the date format correct on your old system if you create a new user and log in with that user?
User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Gnome date format

Postby Totoxa » 2019-06-12 01:57

I've created another account and the date is shown in a locale different to the one I set.

EDIT: actually it is a mix of english and spanish, notice the day name, the "de" after the day number and "jun" could be either spanish or english.
Image
Head_on_a_Stick wrote:Is the date format correct on your old system if you create a new user and log in with that user?
Totoxa
 
Posts: 21
Joined: 2015-01-02 17:19

Re: Gnome date format

Postby sickpig » 2019-06-12 03:28

well then block the buster release by submitting the discovered fault, its going to released soon as stable
User avatar
sickpig
 
Posts: 315
Joined: 2019-01-23 10:34

Re: Gnome date format

Postby Head_on_a_Stick » 2019-06-12 07:43

Totoxa wrote:it is a mix of english and spanish

OK. perhaps reset the entire configuration of the desktop:
Code: Select all
dconf reset -f /org/gnome/

That will clear all of the settings you have made.

@sickpig: I think this is a configuration issue rather than a bug, the OP doesn't have this problem with a fresh system.
User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Gnome date format

Postby Totoxa » 2019-06-13 00:40

Head_on_a_Stick wrote:
Totoxa wrote:it is a mix of english and spanish

OK. perhaps reset the entire configuration of the desktop:
Code: Select all
dconf reset -f /org/gnome/

That will clear all of the settings you have made.

@sickpig: I think this is a configuration issue rather than a bug, the OP doesn't have this problem with a fresh system.


Resetting the configuration did the trick, the offending key was
Code: Select all
clock-show-date
in
Code: Select all
/org/gnome/desktop/interface/
, it was set to true. I think there is a missing translation.

Now I've noticed that the login screen shows the date in mixed language. The format in the new setup is correct.
Here are two pictures: https://imgur.com/a/wsCcj1R
Is it ok to reset the configuration as root?
Totoxa
 
Posts: 21
Joined: 2015-01-02 17:19

Re: Gnome date format

Postby Head_on_a_Stick » 2019-06-13 17:32

User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Gnome date format

Postby Totoxa » 2019-06-14 03:03

I've solved the issue,

My /etc/default/locale file was
Code: Select all
LANG=es_CL.UTF-8
LANGUAGE=es_CL:es
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_MONETARY=en_GB.UTF-8
LC_PAPER=en_GB.UTF-8
LC_MEASUREMENT=en_GB.UTF-8


I've changed everything to es_CL.UTF-8 and now the date in the login screen is in the correct format. Maybe the installer I used at that time was buggy.
Totoxa
 
Posts: 21
Joined: 2015-01-02 17:19


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable