Pseudo-transparency not working in XFCE4 in wheezy

Everything about X, Gnome, KDE, ... and everything running on it

Pseudo-transparency not working in XFCE4 in wheezy

Postby miriya » 2013-03-28 16:41

I recently installed wheezy from the the weekly testing CD on my 1005HA EeePC. So far everything's worked quite well, except I can't seem to get pseudo-transparency to work in either xfce4-terminal or conky. The strange part is that if I ssh to another machine and run nautilus remotely, it seems to fix the problem. All terminals and conky correctly use the pseudo-transparency until I log out (even if I close nautilus and the ssh connection). Does anyone know what nautilus does when it runs to "activate" pseudo-transparency and is there any way I can ensure that xfce does it on startup? Just for clarification, I do not have nautilus installed on my computer. I've simply run it remotely from our lab server. I'm using thunar locally.

I have compositing turned off because I do not want full transparency. However, when I turn it on, full transparency works correctly. Toggling compositing doesn't enable pseudo transparency. Please let me know what I could try to initialize pseudo-transparency when I log in.
User avatar
miriya
 
Posts: 8
Joined: 2013-03-28 16:27

Re: Pseudo-transparency not working in XFCE4 in wheezy

Postby PhilGil » 2013-03-28 17:00

I can't find the quote right now, but I remember reading that the XFCE devs removed pseudo-transparency in XFCE 4.8 since "anyone who wants transparency can turn on compositing." I found it while looking for a way to enable semi-transparent panels in XFCE without turning on compositing. Maybe pseudo-transparency in conky and the terminal are designed to hook into window manager functionality that no longer exists in 4.8.

Not sure why things work in your ssh session - could the host machine be handling the graphics effects?
PhilGil
 
Posts: 384
Joined: 2010-05-08 16:43

Re: Pseudo-transparency not working in XFCE4 in wheezy

Postby sakamoto » 2013-03-31 12:18

i think i understand your issue as i am facing a similar issue

i have conky set up for my wheezy install with xfce. full transparency is used by enabling compositing under the windows manager tweaks. this correctly results in a full transparent conky panel on my desktop when booting the computer. However when logging out or shutting down the pc, conky results in a black background as i think that full compositing is quited and the pseudo transparency kicks in which uses the background/wallpaper of the root window which is not set by xfce's file manager and therefore results in solid black background during shutting down.


i tried to set the root window wallpaper with feh but it seems not to fix the issue. anyone else who recognizes this issues and/or has a workaround for this? thanks

@ PhilGil : was it removed in 4.8 only or as from 4.8?
debian 7.0 wheezy 3.2.0-4-686-pae gnu/linux
User avatar
sakamoto
 
Posts: 83
Joined: 2012-08-24 23:38

Re: Pseudo-transparency not working in XFCE4 in wheezy

Postby PhilGil » 2013-03-31 21:40

sakamoto wrote:@ PhilGil : was it removed in 4.8 only or as from 4.8?

I ran across the post while googling how to enable semi transparent panels without compositing in XFCE 4.8. I may have misunderstood - I haven't used XFCE for very long so I'm not sure whether fake transperancy was available in earlier versions. I know you could change the panel transparency in Gnome 2 without compositing enabled; I also recall running conky with a transparent background and no compositing in Gnome 2.
PhilGil
 
Posts: 384
Joined: 2010-05-08 16:43

Re: Pseudo-transparency not working in XFCE4 in wheezy

Postby miriya » 2013-04-03 20:43

I'd like to see where that quote came from which says XFCE isn't supporting pseudo-transparency anymore. As for the remote computer inducing pseudo-transparency, I don't think it's continuing to handle it. I close the ssh connection and close my networking and the pseudo-transparency remains. It just seems like the remote computer triggers it. If I could isolate whatever signal is causing the trigger, I could just add it to my startup or something. I haven't used feh and I'm completely unfamiliar with it. Is there a good reference I could read?
User avatar
miriya
 
Posts: 8
Joined: 2013-03-28 16:27

Re: Pseudo-transparency not working in XFCE4 in wheezy

Postby PhilGil » 2013-04-04 04:58

miriya wrote:I'd like to see where that quote came from which says XFCE isn't supporting pseudo-transparency anymore.


This was the thread I was referring to, where an XFCE dev posts, "I don't see the point of fake transpaceny, it involves quite a bit of code for IMHO 'just not it'. You want a transparent panel: enable compositing. And like Jerome already said, other points are implemented in 4.8." Not exactly the official word on fake transparency, but sound pretty definitive to me.
PhilGil
 
Posts: 384
Joined: 2010-05-08 16:43

Re: Pseudo-transparency not working in XFCE4 in wheezy

Postby miriya » 2013-04-05 00:52

That's really disappointing. I don't actually want full transparency. All those words and files just make it hard to read anything in the terminal. The pseudo-transparency is a lovely effect. What I don't get is why it actually *does* work. If the code base weren't there to support it, then why can I get it to trigger when I remotely log into another computer?
User avatar
miriya
 
Posts: 8
Joined: 2013-03-28 16:27

Re: Pseudo-transparency not working in XFCE4 in wheezy

Postby miriya » 2013-06-27 20:11

Sakamoto's comment about conky got me looking in a different direction. I found a post which had the suggestion to use feh to replace the background:

Code: Select all
feh --bg-fill `xfconf-query -c xfce4-desktop -p /backdrop/screen0/monitor0/image-path`

This gives the terminal the pseudo-transparency I was looking for, and it gives conky a proper transparent background without the need to turn on compositing.
User avatar
miriya
 
Posts: 8
Joined: 2013-03-28 16:27


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 16 guests

fashionable