Enlightenment DR17

Everything about X, Gnome, KDE, ... and everything running on it

Postby Bro.Tiag » 2008-11-12 02:53

garrincha wrote:!Ay, caramba! I decided to check my SVN E17 from Morlenxus, and all I could say that it's delicious looking so far. I especially like the fancy penguins module that display tux walking, flying etc around my screen. Much improved indeed.


Aye, I noticed last week end when I installed e17 to my eMac that things were a bit different. So I spent the week end installing e17 via various methods. While I am still fond of OzOs' apt-get the easy_e17.sh method, the stock Morlenxus script still does a fine job. So much so, that I am migrating my old Sid install over to a new one from the week end. What is really great, is that aside form entice no linger working, is all of my custom stuff still works.

Cheers
User avatar
Bro.Tiag
 
Posts: 1937
Joined: 2007-06-02 19:14

Postby garrincha » 2008-11-12 16:42

Bro.Tiag wrote:Aye, I noticed last week end when I installed e17 to my eMac that things were a bit different. So I spent the week end installing e17 via various methods. While I am still fond of OzOs' apt-get the easy_e17.sh method, the stock Morlenxus script still does a fine job. So much so, that I am migrating my old Sid install over to a new one from the week end. What is really great, is that aside form entice no linger working, is all of my custom stuff still works.

Cheers

I haven't been able to find time to mess around with E17, but now there seems to be plenty of stuffs to go around and I'll probably spend the weekend playing with some of these "toys" LOL.

It's slowly becoming functional though. Here's a nice little page for sharing themes, applications and module:

http://exchange.enlightenment.org/
Maurice Green on Usain Bolt's 9.58: "The Earth stopped for a second, and he went to Mars."
User avatar
garrincha
 
Posts: 2340
Joined: 2006-06-02 16:38

Postby Bro.Tiag » 2008-11-12 16:59

garrincha wrote:
Bro.Tiag wrote:Aye, I noticed last week end when I installed e17 to my eMac that things were a bit different. So I spent the week end installing e17 via various methods. While I am still fond of OzOs' apt-get the easy_e17.sh method, the stock Morlenxus script still does a fine job. So much so, that I am migrating my old Sid install over to a new one from the week end. What is really great, is that aside form entice no linger working, is all of my custom stuff still works.

Cheers

I haven't been able to find time to mess around with E17, but now there seems to be plenty of stuffs to go around and I'll probably spend the weekend playing with some of these "toys" LOL.

It's slowly becoming functional though. Here's a nice little page for sharing themes, applications and module:

http://exchange.enlightenment.org/

Thanks for the link. As for functional, I've been functioning in e17 since, '05 :D but this new stuff is very cool.

Cheers
User avatar
Bro.Tiag
 
Posts: 1937
Joined: 2007-06-02 19:14

Postby jongi » 2008-11-12 19:51

Bro.Tiag wrote:A few things, you did un-install all things enlightenment before re-trying? Also, have you tryed to install libecore-imf-evas0 by it's self? Another thing, uninstall & reinstall libeet1, the final thing have you used apt-get install --fix-missing? What 'bout dpkg -a configure ?

Cheers


Thanks. There were some stragglers. After going through what was installed with a fine toothcomb. I then ran aptitude install e17 again and everything was installed from the alphagemini repo.
Desktop: Debian (Sid) 64-bit, Gentoo 64-bit and Ubuntu Jaunty 64-bit
Laptop: Gentoo 32-bit
MythTV: Debian (Testing) 32-bit
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

Postby Bro.Tiag » 2008-11-12 20:09

jongi wrote:
Bro.Tiag wrote:A few things, you did un-install all things enlightenment before re-trying? Also, have you tryed to install libecore-imf-evas0 by it's self? Another thing, uninstall & reinstall libeet1, the final thing have you used apt-get install --fix-missing? What 'bout dpkg -a configure ?

Cheers


Thanks. There were some stragglers. After going through what was installed with a fine toothcomb. I then ran aptitude install e17 again and everything was installed from the alphagemini repo.


Good on ya! You now have something that loos like this, Image?

Cheers
User avatar
Bro.Tiag
 
Posts: 1937
Joined: 2007-06-02 19:14

Postby jongi » 2008-11-12 20:16

Ok. tried to login but I get to see the mouse icon against a black screen and then it throws me back to the kdm login screen. Any ideas?

Code: Select all
[root:~#] dpkg -l | grep enlightenment
rc  enlightenment                        1:0.16.7.2-5                                    The Enlightenment Window Manager
ii  libecore0                            0.9.9.043-1                                     Core abstraction layer for enlightenment DR 0.17
[root:~#] dpkg -l | grep Enlightenment
ii  e17                                  1:0.16.999.050-0cvs20081022                     The Enlightenment DR17 Window Manager
ii  e17-data                             1:0.16.999.050-0cvs20081022                     Enlightenment Window Manager Run Time Data Files
rc  enlightenment                        1:0.16.7.2-5                                    The Enlightenment Window Manager
ii  libeet1                              1.1.0-1                                         Enlightenment DR17 file chunk reading/writing library
ii  libeina0                             0.0.1-0cvs20081022                              Enlightenment DR17 file chunk reading/writing library
ii  libevas0                             0.9.9.050-1                                     Enlightenment DR17 advanced canvas library


EDIT: I previously had one of the e16 themes installed. Could this be causing an issue although I have removed the e16 packages?
Desktop: Debian (Sid) 64-bit, Gentoo 64-bit and Ubuntu Jaunty 64-bit
Laptop: Gentoo 32-bit
MythTV: Debian (Testing) 32-bit
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

Postby Bro.Tiag » 2008-11-12 21:06

jongi wrote:Ok. tried to login but I get to see the mouse icon against a black screen and then it throws me back to the kdm login screen. Any ideas?

Code: Select all
[root:~#] dpkg -l | grep enlightenment
rc  enlightenment                        1:0.16.7.2-5                                    The Enlightenment Window Manager
ii  libecore0                            0.9.9.043-1                                     Core abstraction layer for enlightenment DR 0.17
[root:~#] dpkg -l | grep Enlightenment
ii  e17                                  1:0.16.999.050-0cvs20081022                     The Enlightenment DR17 Window Manager
ii  e17-data                             1:0.16.999.050-0cvs20081022                     Enlightenment Window Manager Run Time Data Files
rc  enlightenment                        1:0.16.7.2-5                                    The Enlightenment Window Manager
ii  libeet1                              1.1.0-1                                         Enlightenment DR17 file chunk reading/writing library
ii  libeina0                             0.0.1-0cvs20081022                              Enlightenment DR17 file chunk reading/writing library
ii  libevas0                             0.9.9.050-1                                     Enlightenment DR17 advanced canvas library


EDIT: I previously had one of the e16 themes installed. Could this be causing an issue although I have removed the e16 packages?


Hum, kdm, I'm not sure of, I do not use a display manager. Anyhow, did you make an ".xsession" file in your ~/home/user folder? If so did you link it to .xinitrc? You might also have to use the whole path to where e17 is installed. IIRC, the deb's you used install to /opt/e17 so the line you need to add would be exec /opt/e17/bin/enlightenment_start .

Cheers
User avatar
Bro.Tiag
 
Posts: 1937
Joined: 2007-06-02 19:14

Postby jongi » 2008-11-12 21:16

is there a log file I can look at to see what causes e17 to crash back to kdm? i ask because it seems to me that e17 does actually start but the crash may be caused by something it is trying to load. my suspicion being the theme.

EDIT: How would I start e17 using startx?
Last edited by jongi on 2008-11-12 21:26, edited 1 time in total.
Desktop: Debian (Sid) 64-bit, Gentoo 64-bit and Ubuntu Jaunty 64-bit
Laptop: Gentoo 32-bit
MythTV: Debian (Testing) 32-bit
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

Postby Bro.Tiag » 2008-11-12 21:25

jongi wrote:is there a log file I can look at to see what causes e17 to crash back to kdm? i ask because it seems to me that e17 does actually start but the crash may be caused by something it is trying to load. my suspicion being the theme.


If you think it is the theme, delete the ~/home/user/.e folder. Without it e sets a new one with all of the default settings.

Cheers
User avatar
Bro.Tiag
 
Posts: 1937
Joined: 2007-06-02 19:14

Postby jongi » 2008-11-12 21:44

Yep you are right it's unlikely to be the theme. i decided to do the following:

Ctrl-Alt-F1
login as root
/etc/init.d/kdm stop
startx /usr/bin/enlightenment_start

I then get this error

Code: Select all
Could not init font path element /usr/share/fonts/x11/cyrillic, removing from list!
Could not init font path element /var/lib/defoma/x-ttcidfont.conf.d/dirs/TrueType, removing from list!
E - PID=28486, do_precache=0
enlightenment: symbol lookup error: enlightenment: undefined symbol: E_CORE_X_ATOM_E_VIRTUAL_KEYBOARD_STATE

waiting for xserver to shut down.
Desktop: Debian (Sid) 64-bit, Gentoo 64-bit and Ubuntu Jaunty 64-bit
Laptop: Gentoo 32-bit
MythTV: Debian (Testing) 32-bit
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

Postby jongi » 2008-11-14 19:17

went the svn route and now we are rocking!!
Desktop: Debian (Sid) 64-bit, Gentoo 64-bit and Ubuntu Jaunty 64-bit
Laptop: Gentoo 32-bit
MythTV: Debian (Testing) 32-bit
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

Postby jongi » 2008-11-14 19:34

My laptop connects to my router via wifi using KNetworkManager. Is there a network manager for e17 or how can I get KNetworkManager to start at boot when e17 loads?
Last edited by jongi on 2008-11-14 19:43, edited 2 times in total.
Desktop: Debian (Sid) 64-bit, Gentoo 64-bit and Ubuntu Jaunty 64-bit
Laptop: Gentoo 32-bit
MythTV: Debian (Testing) 32-bit
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

Postby garrincha » 2008-11-14 19:41

jongi wrote:My laptop connects to my router via wifi using KNetworkManager. Is there a network manager for e17 or how can I get KNetworkManager to start at boot when e17 loads?


I'm not sure if it's a network manager, but there's a module called wlan. Otherwise, I would think that a gnome (or kde) network manager should work fine - in fact some gnome apps work well with E17.
Maurice Green on Usain Bolt's 9.58: "The Earth stopped for a second, and he went to Mars."
User avatar
garrincha
 
Posts: 2340
Joined: 2006-06-02 16:38

Postby jongi » 2008-11-14 19:43

Also, why does IBox only show apps that have been minimised?

wlan doesn't show as a gadget having installed from svn. is there a way i can install it?
Desktop: Debian (Sid) 64-bit, Gentoo 64-bit and Ubuntu Jaunty 64-bit
Laptop: Gentoo 32-bit
MythTV: Debian (Testing) 32-bit
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

Postby garrincha » 2008-11-14 19:58

jongi wrote:Also, why does IBox only show apps that have been minimised?

The apps that are minimised (or inconified) are placed in IBox, isn't that's supposed to be that function? You can remove it (IBox) if you want.
wlan doesn't show as a gadget having installed from svn. is there a way i can install it?

It should load from modules, in menu click on 'configuration > modules > shelf' and load it. Then right click on one of the shelfs, click on 'shelf > configure shelf contents' and add the wlan gadget. I'm not sure about SVN, it should be in e_modules (?) package I think. I got my E17 from morlenxus' easy_e17.sh script and wlan is included.
Maurice Green on Usain Bolt's 9.58: "The Earth stopped for a second, and he went to Mars."
User avatar
garrincha
 
Posts: 2340
Joined: 2006-06-02 16:38

PreviousNext

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 16 guests

fashionable