Easy Netflix (No WINE needed)

Everything about X, Gnome, KDE, ... and everything running on it

Easy Netflix (No WINE needed)

Postby inktitan » 2014-10-10 20:53

Feel free to remove this if it has already been addressed.

Ok I never got Netflix-Desktop to work but recently Google did some awesomeness and you can get Netflix to run easy peasy in Chrome 37 or newer. Just install libnss3 3.17
https://packages.debian.org/jessie/libnss3 scroll to the bottom for your architecture.
If you already have libnss3-1d it will break due to a dependency on the the older (current) libnss3 3.14. If you do not have libnss3-1d installed you can install libnss3.17 from the above link I used GDebi package installer and can now watch Netflix easy like it should be.

I hope this was helpful and enjoy.


EDIT: I am running Wheezy 64bit with libc6 2.19-11. Though I have had no problems on my system it has been brought to my attention that this setup could cause problems with future updates.
Last edited by inktitan on 2014-11-20 22:56, edited 2 times in total.
User avatar
inktitan
 
Posts: 26
Joined: 2013-11-12 04:21

Re: Easy Netflix (No WINE needed)

Postby Sepuro77 » 2014-11-13 09:57

Hi,

I never got Netflix to work (with pipelight) either.
So I followed your lead and downloaded "libnss3.17" from the jessie repository. Before installing via GDebi I deinstalled "libnss3-1d" via apt. Everything went flawless. However I am still not able to watch Netlfix with Chrome 38 on my 32bit Wheezy.

Could this be because of a problem with "libc6"? I'm currently running on 2.13-38.
Furthermore I would not be able to install "libnss3-1d" due a dependencies conflict.

I appreciate any help on this :)
User avatar
Sepuro77
 
Posts: 3
Joined: 2014-11-13 09:44

Re: Easy Netflix (No WINE needed)

Postby inktitan » 2014-11-19 05:01

Sorry it took so long for me to respond. I did not get an email. I am testing this on my 32 bit system right now and will get back to you with an answer.
User avatar
inktitan
 
Posts: 26
Joined: 2013-11-12 04:21

Re: Easy Netflix (No WINE needed)

Postby inktitan » 2014-11-19 05:28

OK I can not get it to work on the 32 bit wheezy. It could be, and I suspect it is, an issue with chrome browser itself. There are some sites that it will not play videos for despite having all the appropriate plugins. Twitch.tv will not run for me at ll in Chrome 32bit but has no problems in 64 bit. I've spent a lot of time trying to figure that issue out and no solution worked. I had always assumed it was a flash problem. Netflix uses Silverlight but now HTML 5 so it should not share the same problem as Twitch but I can not get Netflix to run in Chrome 32 bit. I am sorry I haven't been more helpful and I hope you do find a solution. If you do can you please post it here for me and I will do likewise.
User avatar
inktitan
 
Posts: 26
Joined: 2013-11-12 04:21

Re: Easy Netflix (No WINE needed)

Postby stevepusser » 2014-11-19 19:36

No doubt the OP ended up with an updated libc6 from Jessie by getting libnss3 from there, and that will probably cause issues down the road with some packages refusing to install.

We already worked this out over on the MEPIS forums; Chrome includes a library for HTML5 digital rights management called libwidevine.so, and whoever built that plugin (though it does not show in chrome:plugins) did it so that it requires libc6 >=2.14. That's the only part of Chrome that requires that newer libc6, so it runs fine until you try Netflix.

We also backported libnss3 and libnspr4 from Jessie so that they would be safe to install, and then backported libc 6 2.17 (with a lot of trepidation) into its own special repo, but everything ended up working perfectly. The MEPIS 12 packages are
compatible with Wheezy. We have a load of backports in the MEPIS repo, so I'd recommend only upgrading libnss3 at this time, then disabling the MEPIS repos, but leaving the experimental libc6 repository enabled, as there may be other packages you need from it down the road.

libnss3 (MEPIS) repos:
deb http://main.mepis-deb.org/mepiscr/repo/ mepis12cr main non-free
deb http://main.mepis-deb.org/mepiscr/testrepo/ mepis12cr test

The libc6 repo:
deb http://main.mepis-deb.org/mepiscr/experimental/ experimental test

So far the libc6 repo has turned out to be safe, and enabled for Wheezy:

Steam
Netflix in Chrome
NEURON
Viber
Google Earth 7
Scrivener (64-bit tested only)
TeamViz
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Chromium 78.0.3904.87, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.0
User avatar
stevepusser
 
Posts: 11248
Joined: 2009-10-06 05:53

Re: Easy Netflix (No WINE needed)

Postby inktitan » 2014-11-19 22:47

Hey thanks for that info. I am running libc6 2.19-11on my 64 bit. I have not encountered any errors as of yet.
User avatar
inktitan
 
Posts: 26
Joined: 2013-11-12 04:21

Re: Easy Netflix (No WINE needed)

Postby stevepusser » 2014-11-20 01:37

If you don't get problems, count yourself as extremely lucky.

As a test, enable multiarch and try to install ia32-libs. You may do it if the Jessie repo is still enabled, but then other problems are in your future...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Chromium 78.0.3904.87, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.0
User avatar
stevepusser
 
Posts: 11248
Joined: 2009-10-06 05:53

Re: Easy Netflix (No WINE needed)

Postby inktitan » 2014-11-20 02:07

I disable Jessie repos after I get what I go in for. Enbaling it to install ia32-libs, I get a message that the package is obsoleted or missing. Then it lists lib32z1 and lib32ncurses5 as possible alternatives.
User avatar
inktitan
 
Posts: 26
Joined: 2013-11-12 04:21

Re: Easy Netflix (No WINE needed)

Postby stevepusser » 2014-11-20 03:58

Yes, so now Wheezy's ia32-libs can't be installed. I leave it to you to find out how much else is broken in the future.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Chromium 78.0.3904.87, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.0
User avatar
stevepusser
 
Posts: 11248
Joined: 2009-10-06 05:53

Re: Easy Netflix (No WINE needed)

Postby inktitan » 2014-11-20 06:11

Nothing on my system has asked for ia32-libs. So I am confused about how this is a problem.
User avatar
inktitan
 
Posts: 26
Joined: 2013-11-12 04:21

Re: Easy Netflix (No WINE needed)

Postby stevepusser » 2014-11-20 19:48

You are free to do whatever you want with your system, of course, but it's not a nice thing to give advice that could lead others into breaking their systems. How about reading the advice in the Debian wiki? https://wiki.debian.org/DontBreakDebian
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Chromium 78.0.3904.87, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.0
User avatar
stevepusser
 
Posts: 11248
Joined: 2009-10-06 05:53

Re: Easy Netflix (No WINE needed)

Postby inktitan » 2014-11-20 21:44

Very well but you are suggesting that they use mepis which goes against the advice given in your link. I'll edit the OP to reflect a caution.
User avatar
inktitan
 
Posts: 26
Joined: 2013-11-12 04:21

Re: Easy Netflix (No WINE needed)

Postby milomak » 2014-11-20 22:22

am i missing something in this argument?
Code: Select all
$ aptitude show chromium/stable | grep Version
Version: 37.0.2062.120-1~deb7u1


Code: Select all
$ aptitude show chromium/stable | grep libnss
         8c), libnspr4 (>= 2:4.9-2~), libnss3 (>= 2:3.14.3), libpango1.0-0 (>=


Code: Select all
$ aptitude show chromium/stable | grep libc6
Depends: gconf-service, libasound2 (>= 1.0.16), libc6 (>= 2.11), libcairo2 (>=


both of these seem to be met in stable
Code: Select all
$ apt-cache policy libnss3 libc6             
libnss3:
  Installed: 2:3.17.2-1
  Candidate: 2:3.17.2-1
  Version table:
 *** 2:3.17.2-1 0
        500 http://ftp.leg.uct.ac.za/debian/ testing/main amd64 Packages
        700 http://ftp.leg.uct.ac.za/debian/ sid/main amd64 Packages
        700 http://free.hands.com/debian/ sid/main amd64 Packages
        500 http://free.hands.com/debian/ testing/main amd64 Packages
        500 http://ukdebian.mirror.anlx.net/debian/ testing/main amd64 Packages
        700 http://ukdebian.mirror.anlx.net/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     2:3.14.5-1+deb7u2 0
        500 http://ftp.leg.uct.ac.za/debian/ stable/main amd64 Packages
        500 http://free.hands.com/debian/ stable/main amd64 Packages
        500 http://ukdebian.mirror.anlx.net/debian/ stable/main amd64 Packages
libc6:
  Installed: 2.19-13
  Candidate: 2.19-13
  Version table:
 *** 2.19-13 0
        500 http://ftp.leg.uct.ac.za/debian/ testing/main amd64 Packages
        700 http://ftp.leg.uct.ac.za/debian/ sid/main amd64 Packages
        700 http://free.hands.com/debian/ sid/main amd64 Packages
        500 http://free.hands.com/debian/ testing/main amd64 Packages
        500 http://ukdebian.mirror.anlx.net/debian/ testing/main amd64 Packages
        700 http://ukdebian.mirror.anlx.net/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     2.13-38+deb7u6 0
        500 http://ftp.leg.uct.ac.za/debian/ stable/main amd64 Packages
        500 http://free.hands.com/debian/ stable/main amd64 Packages
        500 http://ukdebian.mirror.anlx.net/debian/ stable/main amd64 Packages
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Sid (External SSD)
Laptop: Lenovo ideapad Y700 [nVidia Optimus] (64-bit) - Sid, Win10, Solus
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 1998
Joined: 2009-06-09 22:20

Re: Easy Netflix (No WINE needed)

Postby inktitan » 2014-11-20 22:46

Libc6 2.19-11+ does not appear to be in Wheezy main.
User avatar
inktitan
 
Posts: 26
Joined: 2013-11-12 04:21

Re: Easy Netflix (No WINE needed)

Postby milomak » 2014-11-20 23:05

stevepusser - you are part of the package team for libc6?
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Sid (External SSD)
Laptop: Lenovo ideapad Y700 [nVidia Optimus] (64-bit) - Sid, Win10, Solus
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 1998
Joined: 2009-06-09 22:20

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable