Hah! Who needs PPAs? I have my own multimedia+ repo!

Everything about X, Gnome, KDE, ... and everything running on it

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-11-02 00:42

Added: Luminance-hdr HDR image editor 2.5.1 for Stretch, and Hugin photo stitcher 2018.0.0 for Jessie and Stretch.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-11-03 17:38

Fixed a bug in MKVToolnix where it wasn't pulling in a newer libebml and libmatroska like it needed to, and added Pithos 1.4.1 (Linux Pandora music service desktop client).
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-11-06 02:30

Quod Libet music player updated to latest 4.2.0 for Stretch.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-11-16 22:54

SMTube (standalone Youtube player) updated to 18.11.0
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-11-18 22:01

Clipgrab updated to 3.7.2 for Jessie and Stretch.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-12-03 20:21

Added a backport of PhotoFlare 1.5.6 for Stretch.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-12-09 19:41

Update: 9 Dec 2018: All OBS repos seem to need a new key, as the old ones have been marked expired, so just repeat the step to download and install the Release.key file in the first post.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby fred44nl » 2018-12-10 08:29

thank you for the heads up.
should this be done once, or for each OBS-package ??
Debian 9.6 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 88
Joined: 2018-07-14 08:54

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-12-11 22:03

fred44nl wrote:thank you for the heads up.
should this be done once, or for each OBS-package ??


Just once for each repository, not package. I now have 167 packages in this one multimedia OBS repo, but then I also have other OBS repos, such as GIMP 2.10.8 backports, Pale Moon, Veracrypt, and so on.

Today multimedia update in this repo: MKVToolnix to 29.0.0. :D
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby fred44nl » 2018-12-12 16:36

when I do:
Code: Select all
wget -nv https://download.opensuse.org/repositories/home:/stevenpusser:/sabnzdbplus-backports/Debian_9.0/Release.key -O Release.key

I get:
W: GPG-fout: http://download.opensuse.org/repositori ... Debian_9.0 Release: De volgende ondertekeningen konden niet geverifieerd worden omdat de publieke sleutel niet beschikbaar is: NO_PUBKEY 0FAD31CA8719FCE4
W: De pakketbron 'http://download.opensuse.org/repositories/home:/stevenpusser:/sabnzdbplus-backports/Debian_9.0 Release' is niet ondertekend.


after disabling sabnzbdplus-backports, there is no complaint.
Debian 9.6 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 88
Joined: 2018-07-14 08:54

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-12-12 21:38

Hmmm-that's for another repo altogether...and I can confirm that I get the same error with it.

But it works for this multimedia repo.

There is a workaround where you can edit the file in /etc/apt/sources.list.d that holds the source, in this case "home:stevenpusser:sabnzdbplus-backports.list", and tell apt to trust the source by adding [trusted=yes]:
Code: Select all
deb [trusted=yes] http://download.opensuse.org/repositories/home:/stevenpusser:/sabnzdbplus-backports/Debian_9.0/ /
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2018-12-14 20:25

Added the new Krita 4.1.7+dfsg for Stretch. :)

Hunh, the OBS is now accepting package versions with the "+" symbol in them, and has been doing that for at least two months now. Wish I noticed that sooner!
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Previous

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable