Hah! Who needs PPAs? I have my own multimedia+ repo!

Everything about X, Gnome, KDE, ... and everything running on it

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-06-01 17:19

Kodi updated to 17.3
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-06-10 21:00

QMPlay2 updated to 17.06.09
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby golinux » 2017-06-10 22:48

@stevepusser . . . There is something I've been meaning to ask you about your multimedia repo. You know that in the past, I have always felt comfortable using it. Now with systemd in the picture, I 'm unsure whether it would be compatible with Devuan. Although MX installs with sysvinit, it does so according to Debian's instructions which iiuc does nothing to address systemd 'entanglements'. I assume that would also be true of your repos. Could you please clarify the status of systemd 'entanglements' in MX and more importantly, in your personal repo? Thanks.
May the FORK be with you!
User avatar
golinux
 
Posts: 1227
Joined: 2010-12-09 00:56
Location: not a 'buntard!

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-06-11 00:46

The packages in this repo are built against the Jessie virtual machines that the OBS spawns for each build, which I would assume includes systemd. That said, I would say that most, possibly all, of the packages won't drag in any systemd packages. You could always add the repo to a Devuan install and simulate the install of any packages you want to make sure that's the case for those.

I'm not the only packager for the MX repo, so can't comment about packages that I haven't added to it. I try to remove any unnecessary systemd dependencies when I can, but as far as I know, the packages in our repo will work with it, but not require it.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-06-20 21:18

Added Zoneminder 1.30 for Jessie and Stretch. It's tweaked by Debian to use the "real" ffmpeg instead of Jessie's libav, which is why I have the Jessie version in this repo. I have the ffmpeg build here disabled for Stretch, so that version just builds against Stretch's. Zoneminder isn't in Stretch at all, but I haven't been able to find out if it's a problem with the package or the packager.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby eor2004 » 2017-06-21 00:20

stevepusser wrote:A better question would be to ask why deb-multimedia continues putting out a version of ffmpeg and vlc that could break user's media systems. I think Christian may be set in his path.

I don't use deb-multimedia anymore, since it was the cause of a lot of problems when trying to upgrade from wheezy to jessie, well... maybe I could use it once to get libdvdcss2 package only and nothing more! :)
Debian Stretch x64, Cinnamon 3.2.7, Kernel Linux 4.9.0-1-amd64, Pentium Dual-Core E5300 @ 2.6Ghz, Gigabyte G41M-ES2L, Intel 4 Series Integrated Graphics Controller, 1Tb Caviar Black WD1001FALS.
User avatar
eor2004
 
Posts: 144
Joined: 2013-10-01 22:49
Location: Puerto Rico

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-06-21 00:28

Debian has a package that downloads source, builds, and installs the very latest libdvdcss2 deb, so you really don't need DMO for that, either: https://packages.debian.org/search?keyw ... ection=all
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-06-28 18:49

Updated ffmpeg to 3.2.6 for both Jessie and Stretch. This might get DVD Styler and gimp-edge built on Stretch; for some mysterious reason it kept saying it could not find ffmpeg in the standard Stretch repos that it uses when creating the virtual build environment.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-06-28 23:24

Updating gimp-edge development versions to 2.9.117. This requires a newer version of libglib2.0 for Jessie to build, so I added the sources from jessie-backports for its 2.48 version. Also got the new gimp building on the Stretch platform, so let's see if it finishes.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-07-01 23:35

Did a little trick with the build-depends for SMTube so it builds against Qt 5 if it's >= 5.6, which is the first version to support HDPI, and Qt 4 otherwise. So that means that Jessie gets Qt 4, Stretch get the Qt 5. The alternatives in the build-depends are:

Code: Select all
qt5-default (>= 5.6) | libqt4-dev (>= 4.6),
 libqt5webkit5-dev (>= 5.6) | libqtwebkit-dev,
 qttools5-dev-tools (>= 5.6) | libqt4-dev (>= 4.6),
 qtscript5-dev (>= 5.6) | libqt4-dev (>= 4.6)


Trying the same thing with smplayer.

Edit: SMPlayer was a little tougher--had to add a bit of code that detected if it was building on Stretch, and then only export a qtchooser qt5 environment setting if that was true. I suppose that it could also detect sid and buster, plus the various Ubuntu codenames, but I'm not building for those.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-07-10 01:46

Just uploaded the SMPlayer 17.7.0 source files, so it will take a few minutes to build and publish the updated packages.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8403
Joined: 2009-10-06 05:53

Previous

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable