Hah! Who needs PPAs? I have my own multimedia+ repo!

Everything about X, Gnome, KDE, ... and everything running on it

Re: Hah! Who needs PPAs?

Postby stevepusser » 2017-03-18 18:39

Adding apulse 0.1.9. This will fool Firefox 52 that you have pulseaudio installed when you only have ALSA sound.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2017-03-19 22:33

QMPlay2 17.03.17 packages building right now, should be ready in a couple minutes.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-03-23 17:35

Updating Audacity to the new 2.1.3 release. It also needed an update of the Flac libraries to avoid a FTBFS, so backported the Stretch flac package. Since ffmpeg also builds against flac, this again triggered a rebuild of ffmpeg and all its dependant packages, but that should sort itself out in an hour or so.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby larry77 » 2017-03-24 09:05

Hello,
I am on Jessie+ backports.
If I add your multimedia repo, will I be able to use Firefox > 52 even if it will not exist in the backports due to the rust compiler being absent in Jessie and backports?
I am afraid to mess up my system so, if I am OK with my seasoned multimedia, can I use your repo in a backports style: e.g. I install only firefox from it and update only firefox and its dependencies?
User avatar
larry77
 
Posts: 475
Joined: 2006-09-24 17:59

Re: Hah! Who needs PPAs?

Postby golinux » 2017-03-24 13:52

stevepusser wrote:Adding apulse 0.1.9. This will fool Firefox 52 that you have pulseaudio installed when you only have ALSA sound.

Kudos for finding a workaround to the pulseaudio requirement!
May the FORK be with you!
User avatar
golinux
 
Posts: 1235
Joined: 2010-12-09 00:56
Location: not a 'buntard!

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-03-24 17:45

larry77 wrote:Hello,
I am on Jessie+ backports.
If I add your multimedia repo, will I be able to use Firefox > 52 even if it will not exist in the backports due to the rust compiler being absent in Jessie and backports?
I am afraid to mess up my system so, if I am OK with my seasoned multimedia, can I use your repo in a backports style: e.g. I install only firefox from it and update only firefox and its dependencies?


Firefox won't require rustc to build until version 54, I think. I believe we can still use the compiled binary directly from Mozilla, even for versions >= 54, on Jessie. We bundle that into a deb file anyway for the MX packages--I could start doing that when the next updates come out.

Also, Firefox is in a separate OBS repo than my multimedia stuff, since it doesn't really have much to do with multimedia. However, I'll add apulse to the Firefox repo, remove the firefox 52.0 package, and add the firefox-esr 52.0.1 package with the fix for alsa, since it patches a security hole. I'll change the version so it will be seen as an upgrade. Edit: The firefox-esr from mozilla.debian.net already has alsa re-enabled, so I recommend that one for the moment.
Last edited by stevepusser on 2017-03-24 18:09, edited 1 time in total.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-03-24 17:48

Removed compiz 0.8.4 packages from the repo since it really did not fit into the multimedia theme, and there is now a much better Jessie repo for it at tuxfamily.org which features compiz-reloaded 0.8.12.X.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-03-25 19:01

Gradio 5.0 added, now that it no longer needs a newer gtk 3 than Jessie has.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-03-28 01:37

Added Handbrake 1.0.3, backported from Debian Experimental.

Also upgraded Peek to 1.0.0, which adds mp4 and webm encoding to the animated GIF already there.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby anmys » 2017-03-29 05:27

Sorry, if this has been answered elsewhere (I could not find). Can your repo be used with debain testing/unstable? I tried and could not install gimp.
anmys
 
Posts: 9
Joined: 2011-11-30 05:06

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-03-29 17:33

I would have to guess that some of the packages will install and work on Stretch, but some won't. I haven't done any testing. Can you provide the exact error messages that prevent the development gimp from installing? It just might be running into interference from leftover parts of the standard Stretch gimp, and removing those first could let my version install.

Eventually, the OBS will make a Stretch build platform/repo available to normal packagers like myself, though I have read that "advanced" packagers can already get access to it.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby anmys » 2017-03-31 03:11

Sorry for the delay.

/etc/apt/sources.lisr
Code: Select all
deb http://debian.nctu.edu.tw/debian/ testing  main contrib non-free
deb http://debian.nctu.edu.tw/debian/  unstable main contrib non-free
deb http://debian.nctu.edu.tw/debian/ experimental main contrib non-free

# The unoficial repository for mpeg and related stuff
deb ftp://ftp.deb-multimedia.org testing main non-free
deb ftp://ftp.deb-multimedia.org sid main non-free

# Virtualbox
deb http://download.virtualbox.org/virtualbox/debian stretch contrib

# liquorix kernels and wine
deb http://liquorix.net/debian/ sid main

# WINE
deb https://dl.winehq.org/wine-builds/debian/ sid main

# newer versions of some packages
deb http://download.opensuse.org/repositories/home:/stevepassert/Debian_8.0/ /


After, apt-get update, the output of what I did:
Code: Select all
# apt-cache policy gimp
gimp:
  Installed: 2.8.20-1
  Candidate: 2.8.20-1
  Version table:
     2.9.5.93-0bpo8.obs 500
        500 http://download.opensuse.org/repositories/home:/stevepassert/Debian_8.0  Packages
 *** 2.8.20-1 600
        600 http://debian.nctu.edu.tw/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     2.8.18-1 800
        800 http://debian.nctu.edu.tw/debian testing/main amd64 Packages
# apt-get install gimp=2.9.5.93-0bpo8.obs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gimp : Depends: libgimp2.0 (>= 2.9.5.93-0bpo8.obs) but 2.8.20-1 is to be installed
        Depends: gimp-data (>= 2.9.5.93) but 2.8.20-1 is to be installed
        Depends: libmypaint (>= 1.3.0-0bpo8.obs) but it is not going to be installed
        Depends: libjson-c2 (>= 0.10) but it is not installable
E: Unable to correct problems, you have held broken packages.
# apt-get install gimp=2.9.5.93-0bpo8.obs libgimp2.0=2.9.5.93-0bpo8.obs gimp-data=2.9.5.93-0bpo8.obs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gimp : Depends: libmypaint (>= 1.3.0-0bpo8.obs) but it is not going to be installed
        Depends: libjson-c2 (>= 0.10) but it is not installable
E: Unable to correct problems, you have held broken packages.
# apt-get install gimp=2.9.5.93-0bpo8.obs libgimp2.0=2.9.5.93-0bpo8.obs gimp-data=2.9.5.93-0bpo8.obs libmypaint=1.3.0-0bpo8.obs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gimp : Depends: libjson-c2 (>= 0.10) but it is not installable
 libmypaint : Depends: libjson-c2 (>= 0.10) but it is not installable
E: Unable to correct problems, you have held broken packages.
root@hri:~# apt-cache policy libjson-c2
libjson-c2:
  Installed: (none)
  Candidate: (none)
  Version table:
#


In an earlier session, I also recall of a missing libjasper1 package. I have to recheck (maybe from gimp-gmic).
anmys
 
Posts: 9
Joined: 2011-11-30 05:06

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-04-03 00:47

Yes, those packages are built on and for Jessie, so it's a dice roll as to whether they will work on upstream Debian.

I just updated QMPlay2 to today's 17.04.02 release.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-04-04 02:40

Kodi upgraded to the 17.1 version, backported from Debian Experimental.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2017-04-04 20:56

Just added VLC 2.2.5.1, which is based on the 2.2.5 release currently in Sid, but with the newer source. I can't find any news on the net about the 2.2.5 release, though. :?: The Sid changelog says it's a release, though.

Vlc-nox becomes a dummy transitional package with this version, and can safely be removed after the upgrade. There's more vlc-plugin-* packages than before, too, so you might want to see if you need any of them.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

PreviousNext

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable