Hah! Who needs PPAs? I have my own multimedia+ repo!

Everything about X, Gnome, KDE, ... and everything running on it

Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2016-03-18 00:16

Update 11 June 2017: The OBS has added support for Stretch builds, so I will go through and see what packages I can also upgrade to that platform--Stretch already has many of the backports in it already. I will probably change the names of many of them to remove the "bpo8" and instead use "obs" or the like, so I can build both Stretch and Jessie versions from the same source upload.

Warning: now that Stretch has frozen, some of the packages in this repo are going to be newer versions than Stretch has available, and may interfere with an in-place upgrade from Jessie to Stretch. The workaround is to remove the offending package (such as my mpv which is newer than Stretch's 0.23) and then reinstall the Stretch version after the upgrade. I also plan to add Stretch builds to the repository as soon as the OBS makes it available to users.

Edited to reflect current situation: I've added packages to this Jessie-backports-multimedia project that are related to multimedia in some way, or require the newer ffmpeg, such as the development GIMP. Many of the packages are not available in Debian at all, such as DVD Styler, ClipGrab, or QMPlay2.

Instructions for adding the repository:
https://software.opensuse.org/download. ... ackage=mpv

You can view the project here, and see what programs are in it currently: https://build.opensuse.org/project/show ... evepassert

Edit: Note that the commands to "wget" the repository key should be run as a regular user, but the "apt-key" command must be again run as root or with sudo, and watch the name of the keyfile that is downloaded--substitute that name in the add-key command if it differs, which you'll get if adding multiple OBS repositories and you download the key file into the same directory as previous key files.

I don't know if anyone else wants information on how to use the OBS--it's free and rather easy to set up and use in a web interface, and you can get as many free repositories as you wish.
Last edited by stevepusser on 2017-06-11 23:33, edited 9 times in total.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby Innovate » 2016-03-18 15:28

Thanks for provide us repo on Opensuse sometimes I've go there to stay away from launchpad.net
I use to get stuff like Lightzone.
User avatar
Innovate
 
Posts: 120
Joined: 2015-12-27 01:28
Location: /dev/urandom

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-03-18 18:00

PPAs are very problematical on Debian; some packages from them may work, but you can never be sure.

The OBS is building the packages from the sources I upload on a straight, basic Jessie system, which mean they will work.

Hmmm--I see that though I have smtube and mpv in the same repository for Jessie, the instructions say to add a separate repo entry for each, which would mean that you would get a warning about duplicate repo entries when updating apt. I guess if you just added the mpv repo, you could also update smtube and try the Liquorix kernel, which I also threw in there to see how long it took to build.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby Güy » 2016-03-24 10:25

What about deb-multimedia? It seems not updated enough, but both of these are on there, although earlier versions.
Güy
 
Posts: 7
Joined: 2015-12-13 00:17

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-03-24 18:23

What about deb-multimedia? I don't see any SMTube there for Jessie, the mpv is rather old, and my version won't break anything.

I could expand this to a multimedia backports repo that would include the real ffmpeg from jessie-backports, then I could add the newer mplayer, mencoder, VLC, etc from upstream, and it wouldn't break anything like DMO often does.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-03-24 23:34

I've added ffmpeg 2.8.6, mplayer+mencoder 1.2.1, and VLC 2.2-5, all the latest from upstream Debian, to that backports repo. The latest VLC has new patches that are supposed to fix problems with hardware acceleration and mkv files, also problems with resuming at the same spot when it's built against qt4, which my version is.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby Güy » 2016-03-29 03:13

About what I said, my bad, I was thinking of the testing deb-multimedia repo, not stable.
Güy
 
Posts: 7
Joined: 2015-12-13 00:17

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-03-30 21:12

I've just added avidemux2.6-qt 2.6.12, the new SMPlayer 16.4.0, and gstreamer0.10-ffmpeg to the repo. SMPlayer and the gstreamer package are also available for Wheezy users.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby Güy » 2016-04-01 06:45

Why not contribute to deb-multimedia backports? If that is possible, more people would be helped that way.
Güy
 
Posts: 7
Joined: 2015-12-13 00:17

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-04-01 18:14

A better question would be to ask why deb-multimedia continues putting out a version of ffmpeg and vlc that could break user's media systems. I think Christian may be set in his path.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-04-27 21:34

Just added DeaDBeeF 0.7.2 for Jessie and Wheezy users, as well as updating VLC, mpv to 0.17, mplayer to 1.3.0, and ffmpeg to 3.0.1.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-05-03 00:04

Added kodi-16.1 from upstream Debian. I had to backport a newer libcec-dev and libcrossguid0-dev to support it.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby Head_on_a_Stick » 2016-05-03 07:15

stevepusser wrote:Added kodi-16.1

Very nice, thank you, I didn't even realise the official backport was only version 15 :)
"Are you quite sure that all those bells and whistles, all those wonderful facilities of your so called powerful programming languages, belong to the solution set rather than the problem set?" — Edsger W. Dijkstra
User avatar
Head_on_a_Stick
 
Posts: 6578
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-05-04 02:26

Updated VLC to 2.2.3 from Sid. It's using an internal ffmpeg 2.8.7 that the Debian maintainer added, because it's not compatible with the ffmpeg 3.x series yet.

Edit: Backported the latest 2.2.4 bugfix release from Sid.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-08-31 22:31

Still keeping it up to date. Jessie now has VLC 2.2.4, though. When I update ffmpeg, such as up to 3.1.3, everything that depends on its libav libraries automatically gets deleted and rebuilt against the new versions. mpv is now up to 0.20, DVD Styler 3.0.2, SMTube at 16.7.0, SMPlayer 16.8.0, added QWinFF 0.2.1 and the latest QMPlay2, too. Also Aqualung 1.0 in that repo will run on Jessie or Stretch.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8804
Joined: 2009-10-06 05:53

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable