Hah! Who needs PPAs? I have my own multimedia+ repo!

Everything about X, Gnome, KDE, ... and everything running on it

Re: Hah! Who needs PPAs?

Postby deborah-and-ian » 2016-09-01 05:42

Thanks for all of your work. I occasionally get stuff from the MX-15 repo. Probably some of yours in there too?

stevepusser wrote:I don't know if anyone else wants information on how to use the OBS--it's free and rather easy to set up and use in a web interface, and you get as many free repositories as you wish.


Would be lovely to get a short intro into it. :)
deborah-and-ian
 
Posts: 106
Joined: 2016-07-13 08:40

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-09-01 20:36

deborah-and-ian wrote:Thanks for all of your work. I occasionally get stuff from the MX-15 repo. Probably some of yours in there too?

stevepusser wrote:I don't know if anyone else wants information on how to use the OBS--it's free and rather easy to set up and use in a web interface, and you get as many free repositories as you wish.


Would be lovely to get a short intro into it. :)


Probably most of the stuff in there, still. We have some more packagers now, though--one's doing the humungous Flightgear backport from Stretch right, and he also does the MX 15 Liquorix kernel backports after I have the OBS build 'em on Jessie first. :)

I'll write a guide in the How-To section here on using the OBS for Debian and Ubuntu builds. If the Debian versions don't contain any forbidden characters like "+" in their version string, you can just drop the Debian source packages directly into the OBS and see if they build--that's what I did for most of the 32 packages in the experimental MATE 1.14.1 backport I did there, to speed things up.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-10-07 19:00

I just upgraded ffmpeg to 3.1.4 in there, and that'll trigger rebuilds of everything built against it, such as mplayer, mencoder, kodi, dvdstyler, and so on. So they may not be available while the rebuilds are going on--a few hours at the latest.

The guide for doing your own builds and repositories on the OBS is also now in the HOWTO section here.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-10-09 19:29

Just added pithos-1.1.2. It hasn't made it into jessie-backports.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-10-12 01:06

Updated obs-studio to 0.16.2 and added simplescreenrecorder 0.3.6.

update: had to update the obs-studio build to fix a missing shared library that didn't get installed.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby 1624 » 2016-10-13 14:36

.
Last edited by 1624 on 2016-11-02 20:24, edited 1 time in total.
Debian 9.0.0 Stretch XFCE 64-bit.
1624
 
Posts: 56
Joined: 2016-05-22 09:43

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-10-13 17:34

Yes, I think Debian won't include the Monkey audio encoder for Flacon because of trouble with the Debian Free Software Guidelines. I could see if I can add it to my repo--I've already got Avidemux in there, which Debian has the same issues with.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-10-27 22:37

Upgraded mpv to 0.21.0 yesterday...but I just loaded ffmpeg 3.1.5 right now, so that'll trigger a rebuild of everything that uses it. Mpy and others will be offline for an hour or two...Edit: OK, all done except for gimp-next 2.9.6, it should finish soon.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-11-16 23:21

SMPlayer upgraded to 16.11.0, QMPlay2 to 2016.11.01.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby AndyMender » 2016-11-18 14:15

Thank you very much for the extra efforts ;)!

I see you're focusing on multimedia, but how did the Liquorix kernel build proceed? Did it work in the end? I know that building a kernel package "the Debian way" requires some tinkering.
Also, are there any pitfalls regarding the use of OBS for building .debs? So far, I only used Fedora's COPR for .rpms, though that obviously is not compatible with Debian.
AndyMender
 
Posts: 5
Joined: 2016-11-16 14:29

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-11-18 20:21

No real problems with rebuilding a Liquorix kernel on the OBS, but I have to modify some files in the debian folder before regenerating the source files to make sure the headers will require Jessie's gcc-4.9 instead of the original's gcc-5. I've been building them on the OBS for some months now in a separate repository, as well as doing a rebuild of the jessie-backports kernel with the kernel context switch frequency bumped up to 1000 Hz instead of the stock 250, because I heard that's better for desktop use, in yet another repository.

I wrote a rough guide for using the OBS to build Debian packages; it's in the HOW-TO section here. There are a few tweaks that package versions may require because the OBS doesn't see the "+" in a version string and replaces it with a whitespace.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-11-24 01:08

ffmpeg updated to 3.2
Clementine added, backported upstream version from Stretch 1.3.1+git240-g1a2f6e2+dfsg-1
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs?

Postby cylverbak » 2016-11-24 13:34

Would it be possible to include vlc-plugin-samba? After installing the latest VLC I found I wasn't able to access anything on my networked drive. Thanks. Nice to have more up to date programs available.
cylverbak
 
Posts: 8
Joined: 2007-08-31 14:10

Re: Hah! Who needs PPAs?

Postby cylverbak » 2016-11-26 14:24

Thank you for vlc-plugin-samba. Unfortunately the snowball effect seems to be kicking in . . . :D

The following packages have unmet dependencies:
vlc-plugin-samba : Depends: libvlccore8 (= 2.2.4-1jessie1) but 2.2.4-1~deb8u1 is to be installed

Or am I just totally confused here?
cylverbak
 
Posts: 8
Joined: 2007-08-31 14:10

Re: Hah! Who needs PPAs?

Postby stevepusser » 2016-11-26 21:51

You'll have to upgrade that libvlccore package, too. The ones in the OBS have jessie in the version, the Debian ones have deb8u1 in them.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8411
Joined: 2009-10-06 05:53

PreviousNext

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable