Hah! Who needs PPAs? I have my own multimedia+ repo!

Everything about X, Gnome, KDE, ... and everything running on it

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-05-05 02:48

VLC updated to 3.0.10 for Stretch as soon as it finishes building.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-05-08 03:43

Updated Guayadeque to 0.4.6+git20191207, and added Buster builds.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-05-25 02:53

Updated Inkscape to 1.0 for Buster and Audacity to 2.4.1 for Stretch-Sid.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-05-26 03:47

Strawberry updated to 0.6.11 for Stretch-Sid
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-06-19 03:21

Strawberry updated to 0.6.12 for Stretch thru Sid.

Krita 4.3.0 building for Buster and Bullseye.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-06-20 02:59

SMPlayer and SMTube updated to 20.6.0 each. For older distreleases with broken youtube-dl versions, which these new releases have switched to, you may have to manually install a newer youtbue-dl in /usr/local until I figure out how to get newer youtube-dls for Stretch and Jessie in the repo.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-06-26 03:50

Lollypop music player updated to 1.3.2 for Buster and Bullseye.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-07-02 03:17

Deadbeef music player updated to 1.8.4 for Stretch through Sid.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-07-13 02:30

QMPlay2 updated to 20.07.04 for Stretch thru Sid.
Added K3b 19.04.2 for Buster, which is the last version that can be built on Buster's KDE libraries.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-07-14 05:09

Shoot--added Blender 2.83.1 for Buster, which builds on my own laptop for amd64 and i386 for MX Linux, but amd64 builds fail on the OBS, which would be the primary use case....
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-07-18 16:46

Strawberry music player updated to 0.6.13 for Stretch through Sid:
Fixed cut-off text in about dialog.
Fixed increasing play count when stop after track is enabled.
Fixed showing/hiding playing widget when playback is started while window is hidden.
Fixed "Show in file browser" to also work on local songs that are not in the collection.
Fixed "Show in file browser" to work with PCManFM file manager.
Fixed audio analyzer to work with S24LE and F32LE audio formats.
Fixed playlist background image not loading.
Fixed a memory leak when switching between playlists.
Removed use of HTML in systemtray tooltip on KDE, since KDE no longer renders HTML in the systemtray.

Enhancements:

Replaced use of C style casts.
Adapted use of C++11 override.
Improved CMake build files.
Added new on startup options to show maximized or minimized.
Builtin TagLib code is updated and improved.
Made most icon sizes configurable in the settings, and increased default sizes for icons.
Improved fancy tabbar to use font sizes from the theme instead of fixed sizes.
Moving the currently playing song to the top when the playlist is manually shuffled.
Added "a taste of Strawbs" background image.
Fixed unit test for testing playlist model.
Added new unit tests for tagreader.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-07-18 18:00

Debian has since added MystiQ to the Sid and Testing repositories. My policy of versioning below a possible Debian version means that their package is seen as greater than mine, but they don't have the patch that adds those two mkv presets I added. In this case, I'll break the policy and make my version higher to avoid losing that feature.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-07-18 18:13

Oh my. The Debian MystiQ version is restricted to amd64 builds for no apparent reason, and the short description says it's "writed in C++" which nobody really needs to know in the short description anyway. Let's see about fixing that in my build.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby stevepusser » 2020-07-25 03:13

Clipgrab updated to 3.8.13, AzPainter to 2.1.6 for Stretch-Sid.

Blender to 2.83.2 for Buster, except amd64 builds will no doubt fail again.
Last edited by stevepusser on 2020-07-26 03:18, edited 1 time in total.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12139
Joined: 2009-10-06 05:53

Re: Hah! Who needs PPAs? I have my own multimedia+ repo!

Postby sunrat » 2020-07-25 12:44

Thanks for adding the GTK3 GUI plugin to the DeadBeef 1.8.4 package. I only recently noticed it was still on the GTK2 GUI for 1.8.3 and was intending to investigate when I spotted your message at MX about that. :D Was wondering why my GTK3 CSS scrollbar tweak wasn't working in it.
Latest Strawberry is working fine in Buster but still has memory leak in Sid. Same issue from upstream version though.
I imported the new Release.key dated today so that's all copacetic now too. Your OBS repo is becoming quite extensive now! Thanks for your fine work. 8) :wink:
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3316
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

PreviousNext

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable