Headphones No Sound, Debian Wheezy

Everything about X, Gnome, KDE, ... and everything running on it

Headphones No Sound, Debian Wheezy

Postby webmanoffesto » 2016-05-16 12:07

I'm running Debian Wheezy with XFCE desktop. I'm on an Asus K55A Laptop. I get sound through the laptop's built-in speakers, but I don't have sound through my headphones (through the headphone jack).

How do I fix this?

Code: Select all
    tom@TomsAsusK55A:$ lspci -v
    00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
    Subsystem: ASUSTeK Computer Inc. Device 1457
    Flags: bus master, fast devsel, latency 0, IRQ 22
    Memory at f7e10000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel


Code: Select all
 tom@TomsAsusK55A:$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7e10000 irq 22


Code: Select all
tom@TomsAsusK55A:$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC270 Analog [ALC270 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Last edited by webmanoffesto on 2016-05-16 18:05, edited 5 times in total.
webmanoffesto
 
Posts: 4
Joined: 2016-05-15 00:21

Re: Headphones No Sound, Debian Wheezy

Postby bigrigdriver » 2016-05-16 14:16

There are two things to check at the outset. If you have alsa-mixer installed, open alsa-mixer.

On the left, the first control is Master. To the right of that is Headphones. Above the volume control slider is a pair of icons representing speakers. If the speakers are white, they are turned off. Left click on the speakers to turn them on (they will appear grey with sound waves emanating from the speakers).

Below the slider bars is an icon representing a padlock. If the padlock is closed and locked, the volume sliders are locked. Left click on the padlock to unlock it. Then move the slider bars upward to increase volume. It may be that the sliders are turned all the way down.
Registered GNU/Linux user #170078

Go as google before you ask on these boards.

It it isn't broken, Tweak It !!!
bigrigdriver
 
Posts: 132
Joined: 2014-09-01 17:04
Location: East Central Illinois, USA

Re: Headphones No Sound, Debian Wheezy

Postby webmanoffesto » 2016-05-16 17:06

bigrigdriver wrote:If you have alsa-mixer installed, open alsa-mixer.


Image

I opened alsamixer, I turned up the volume on Master, Headphone, and Speaker, but I still don't hear anything via the headphones. I presse "M" to make sure devices are not muted.

Is there anything else you can suggest?
webmanoffesto
 
Posts: 4
Joined: 2016-05-15 00:21

Re: Headphones No Sound, Debian Wheezy

Postby webmanoffesto » 2016-05-18 14:12

Problem Solved using
> xfce4-mixer
Unmute
Image
webmanoffesto
 
Posts: 4
Joined: 2016-05-15 00:21


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable