IBM SurePoint 4820-21x/51x Touch Display and Jessie

Everything about X, Gnome, KDE, ... and everything running on it

IBM SurePoint 4820-21x/51x Touch Display and Jessie

Postby stedy » 2016-06-08 10:22

Greetings!

I need touchscreen interface for a particular application, which would be much easier working with that way and bought a IBM SurePoint 4820-21x/51x Touch Display. To be precise it's a 4820-5GN with Infrared technology.
lsusb reports:
Bus 001 Device 014: ID 04e7:0030 Elo TouchSystems 4500U CarrollTouch® Touchmonitor Interface

Surprisingly it emulates a mouse. When I move my finger on the screen I am able only to move the mouse pointer, single and double click works also.

I tried following the instructions for Linux 64 bit Single-Touch USB Driver (AMD64/Intel - x86_64) (.tgz, 134K) at http://www.elotouch.com/files/install/Elo-Linux-ST-USB-Driver-v4.0.1_Installation-Instructions.txt but it seems outdated as I was not able to create the suggested "symbolic link with selected sequence number XX", 05 in my case and in rc5.d and not rc2.d according to "runlevel". Manually loading the driver causes Kernel panic in seconds and the calibration program does not detect the touchscreen even when the driver is loaded and in ps output I find not only elousbd but elousb which seems the default driver.

I tried the monitor under Windows 7 Home Premium and it works well with the driver installed automatically.

Installing xserver-xorg-input-elographics did no difference.

Could anyone help? Could I disable the default driver and what should be the instructions for installing the Elo driver for the init system in Jessie? Is there a way to switch the mode of the default driver, as not to emulate a mouse? Ideas?
stedy
 
Posts: 1
Joined: 2016-06-08 09:24

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable