Mate 1.14 on Debian Jessie?

Everything about X, Gnome, KDE, ... and everything running on it

Re: Mate 1.14 on Debian Jessie?

Postby stevepusser » 2017-05-10 04:09

Not fully, the Jessie 1.18 marco MATE window manager can't be installed on Stretch because it wants a library version only found in Jessie; libgtop2-7. Everything else was upgradable in my simulation in a Live VBox session of a Stretch-based distro (antiX 17 alpha) When I had it remove marco and the mate-desktop-environment packages and upgrade the rest in antiX, I could log out and back into a MATE 1.18 session--so I guess it fell back onto one of the other lightweight gtk window managers included in antiX. I bet it could also fall back onto xfwm if that was installed in straight Debian.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8797
Joined: 2009-10-06 05:53

Re: Mate 1.14 on Debian Jessie?

Postby Gimz » 2017-05-18 18:37

stevepusser wrote:I made a new Jessie OBS repository for MATE 1.18...

https://software.opensuse.org//download ... nvironment


hi @stevepusser, thank you for your hard work on MATE, i updated my Debian 8.8 Mate 1.16 to Mate 1.18 and i have this error:
Code: Select all
The following packages will be upgraded:
  mate-icon-theme-faenza
1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/21.2 MB of archives.
After this operation, 7,555 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Reading changelogs... Done
(Reading database ... 274725 files and directories currently installed.)
Preparing to unpack .../mate-icon-theme-faenza_1.18.0.dfsg1-0.obs_all.deb ...
Unpacking mate-icon-theme-faenza (1.18.0.dfsg1-0.obs) over (1.16.0-0~bpo80.obs) ...
dpkg: error processing archive /var/cache/apt/archives/mate-icon-theme-faenza_1.18.0.dfsg1-0.obs_all.deb (--unpack):
 unable to open '/usr/share/icons/matefaenzagray/actions/96/package-remove.png.dpkg-new': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/mate-icon-theme-faenza_1.18.0.dfsg1-0.obs_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


how can i resolve this error?
Gimz
 
Posts: 2
Joined: 2013-10-18 06:41

Re: Mate 1.14 on Debian Jessie?

Postby stevepusser » 2017-05-18 18:48

It looks like you got a corrupted/incomplete download. Let's remove it from the apt-cache and see if it redownloads correctly.

As root or sudo in a terminal:

Code: Select all
rm /var/cache/apt/archives/mate-icon-theme-faenza_1.18.0.dfsg1-0.obs_all.deb


And then try the upgrade again--watch to see if it redownloads that file.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8797
Joined: 2009-10-06 05:53

Re: Mate 1.14 on Debian Jessie?

Postby Gimz » 2017-05-18 19:01

thanks for the quick reply @stevepusser, it did download the new file but the error is still this same.

Code: Select all
Do you want to continue? [Y/n] Y
Get:1 http://download.opensuse.org/repositories/home:/stevenpusser:/MATE-1.18/Debian_8.0/  mate-icon-theme-faenza 1.18.0.dfsg1-0.obs [21.2 MB]
Fetched 21.2 MB in 48s (435 kB/s)                                             
Reading changelogs... Done
(Reading database ... 274725 files and directories currently installed.)
Preparing to unpack .../mate-icon-theme-faenza_1.18.0.dfsg1-0.obs_all.deb ...
Unpacking mate-icon-theme-faenza (1.18.0.dfsg1-0.obs) over (1.16.0-0~bpo80.obs) ...
dpkg: error processing archive /var/cache/apt/archives/mate-icon-theme-faenza_1.18.0.dfsg1-0.obs_all.deb (--unpack):
 unable to open '/usr/share/icons/matefaenzagray/actions/96/package-remove.png.dpkg-new': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/mate-icon-theme-faenza_1.18.0.dfsg1-0.obs_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@debian8:/home/pidod/Desktop#


i resolved the error by removing the mate-faenza-icon-theme 1.16.obs using the synaptic package manager and reinstalled version 1.18.0 from there. thanks a lot Steve.
Gimz
 
Posts: 2
Joined: 2013-10-18 06:41

Re: Mate 1.14 on Debian Jessie?

Postby VentGrey » 2017-06-23 00:56

never thought one of my newbie questions would make such progress... :mrgreen:
“I felt myself on the edge of the world; peering over the rim into a fathomless chaos of eternal night.”
― H.P. Lovecraft after trying Debian SidImage
User avatar
VentGrey
 
Posts: 150
Joined: 2016-04-26 23:57
Location: Guanajuato México

Re: Mate 1.14 on Debian Jessie?

Postby stevepusser » 2017-06-26 18:10

For MATE 1.18, updating mate-tweak, mate-control-center, mate-media, libmateweather, and mate-dock-applet. Builds should be finished in a couple minutes up there in "the cloud".
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8797
Joined: 2009-10-06 05:53

Previous

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable