Debian Jessie screen tearing

Everything about X, Gnome, KDE, ... and everything running on it

Debian Jessie screen tearing

Postby dancra » 2016-11-29 21:10

Hi,

Ever since I switched to Debian Jessie I have had noticeable screen tearing with videos played in Firefox, not matter if Flash or HTML 5. I have been through half a dozen different xorg.conf options that I found all over the Internet (including Option "TearFree" "on") and also gave Kernel 4.7 from the backports a try. But no result. Tearing is still there.

Am I the only one experiencing this or does the rest of you simply not care?

My GFX card is a Radeon 7750 and the driver is "radeon".

Thanks
dancra
 
Posts: 12
Joined: 2016-05-03 09:59

Re: Debian Jessie screen tearing

Postby Hallvor » 2016-11-29 21:24

Tearing should disappear if you enable compositing.
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 718
Joined: 2009-04-16 18:35
Location: Norway

Re: Debian Jessie screen tearing

Postby Head_on_a_Stick » 2016-11-29 21:46

dancra wrote:Option "TearFree" "on"

That only applies to Intel cards.

If your chosen mystery desktop does not offer an effective compositor, try:
Code: Select all
compton -b --backend glx --vsync opengl-mswc

https://github.com/chjj/compton/wiki/vsync-guide

https://packages.debian.org/jessie/compton

That jessie version is quite old, we have a newer version in the BunsenLabs repositories that is jessie-compatible:

https://eu.pkg.bunsenlabs.org/debian/po ... c/compton/
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian Jessie screen tearing

Postby GarryRicketson » 2016-11-29 21:59


Am I the only one experiencing this or does the rest of you simply not care?

The OP should have at least tried to do a search, and this statement
shows they did not .
A lot of people have had this problem.

The question has been asked before :
Debian Jessie screen tearing

And it goes into great detail here :
[Solved] Screen tearing Debian Jessie

===========
More details : Debian Jessie screen tearing
User avatar
GarryRicketson
 
Posts: 4069
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Debian Jessie screen tearing

Postby dancra » 2016-12-01 18:22

I did in fact run a search and my "don't you care" was not alluding to a lack of discussion but to a lack of solutions (that work).
Now I tried again the quoted config
Code: Select all
Option "RegistryDwords" "PerfLevelSrc=0x2233"
Option "TripleBuffer" "True"

But it does not solve the problem fully. I still see segmented lines in various directions during heavy movements in videos. Maybe tearing is not the perfect word, as it is not horizontal lines across the entire screen but more like the picture is cut out from pieces of paper (sorry, English is not my native language).

My desktop is Gnome 3. Is that "compositing"?

Thanks
dancra
 
Posts: 12
Joined: 2016-05-03 09:59

Re: Debian Jessie screen tearing

Postby GarryRicketson » 2016-12-01 18:31

That is ok, no problem, one thing for sure , it does seem to be a very common problem.
Most evey body here is just " Debian users" the same as you are, Thanks
for telling us which DE,...............
I don't know the reasons, but I do know, I stopped using "Gnome" over a year
ago, it kind of went from being my favorite DE, to being the worst, and has become
rather problamatic for many users (like me) ,instead of getting better, getting worse,
...my solution was to start using a good "windows manager"
instead, but any way that might be another topic.
User avatar
GarryRicketson
 
Posts: 4069
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Debian Jessie screen tearing

Postby dancra » 2016-12-01 19:39

Gnome3 is in fact the worst desktop I have ever seen, but I managed to make it look a bit like Unity, which is not great either, but I am used to it =8-)
Reason being that I prefer to stick with the distro default and the modifications I made are just fonts, a theme, and some common extensions. I learned the hard way that when you use a 0.1% OS (like Linux) and on top you try to be too creative in tinkering your very personal desktop, you will soon be on your own with your own problems and the problems will be more weird and more frequent.

BTW I just noticed another tearing symptom, which is, when I scroll down certain web pages in Firefox, there is sometimes a horizontal line across the screen, like a "wave", about 1/3 down from the top of the screen.

Maybe that is what you get when you are with 0.1% of the population.... :)
dancra
 
Posts: 12
Joined: 2016-05-03 09:59

Re: Debian Jessie screen tearing

Postby Head_on_a_Stick » 2016-12-01 20:24

For GNOME 3.16, edit the file at /etc/environment (as root!) and add this line:
Code: Select all
CLUTTER_PAINT=disable-clipped-redraws:disable-culling

Be aware that this hack is not needed for the newer GNOME versions in stretch & sid and this line should be removed if you ever `dist-upgrade` to those branches.
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian Jessie screen tearing

Postby sunrat » 2016-12-02 00:56

Do you have firmware-linux-nonfree installed?
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 1934
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Debian Jessie screen tearing

Postby Thorny » 2016-12-02 12:30

dancra wrote:Gnome3 is in fact the worst desktop I have ever seen, but I managed to make it look a bit like Unity, which is not great either, but I am used to it =8-)
Reason being that I prefer to stick with the distro default and the modifications I made are just fonts, a theme, and some common extensions. I learned the hard way that when you use a 0.1% OS (like Linux) and on top you try to be too creative in tinkering your very personal desktop, you will soon be on your own with your own problems and the problems will be more weird and more frequent.


You're already getting good help with your video problem but I want to respond to the above.

If you're not happy with an operating system that has a low "market share", then you should use Windows. By the way, Linux is just the kernel.

As well as the Gnome environment there are Debian Jessie install disks in the iso repository for KDE, LXDE, XFCE which would give you a different desktop than Gnome. Many people here prefer one of those. By the way, I don't have the problems that you do customising my system the way I want it but I don't just tinker, I research and study before I try things and record what I do so I can reverse it if I encounter a problem. I've had very good luck searching for answers when I've encountered a problem and never had to ask a forum, so I don't know why a power user like you has had such trouble. If you want your system to look like Unity, my suggestion would be that the easiest way would be to use Ubuntu.

Clearly there is the freedom to use what you like and are able to configure.
Thorny
 
Posts: 295
Joined: 2011-02-27 13:40

Re: Debian Jessie screen tearing

Postby dancra » 2016-12-02 20:23

sunrat wrote:Do you have firmware-linux-nonfree installed?

yes
dancra
 
Posts: 12
Joined: 2016-05-03 09:59

Re: Debian Jessie screen tearing

Postby dancra » 2016-12-02 20:24

Head_on_a_Stick wrote:For GNOME 3.16, edit the file at /etc/environment (as root!) and add this line:
Code: Select all
CLUTTER_PAINT=disable-clipped-redraws:disable-culling

Be aware that this hack is not needed for the newer GNOME versions in stretch & sid and this line should be removed if you ever `dist-upgrade` to those branches.

Tested. No change. But thanks for the hint.
dancra
 
Posts: 12
Joined: 2016-05-03 09:59

Re: Debian Jessie screen tearing

Postby stevepusser » 2016-12-02 22:47

Is there some setting for VSync in the desktop preferences or gnome-tweak? That's what's suggested for other desktop environments, but I don't know much about GNOME.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8427
Joined: 2009-10-06 05:53

Re: Debian Jessie screen tearing

Postby Head_on_a_Stick » 2016-12-02 23:13

I recommend switching to a more shiny distribution (or perhaps the development branches of Debian) and using GNOME on Wayland instead -- the compositing is much improved compared to the X server and my usually troublesome Intel HD4600 card is completely tear-free with no tweaks under Wayland.
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian Jessie screen tearing

Postby dancra » 2017-07-08 18:12

For the record (and the sake of those having the same problem): I found the solution to my tearing problem with Firefox in fullscreen mode (this only works for Gnome):

Code: Select all
mkdir -p ~/.config/autostart
cat <<EOF >~/.config/autostart/mutterfix.desktop
[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Terminal=true
Exec=gdbus call --session --dest org.gnome.Shell --object-path /org/gnome/Shell --method org.gnome.Shell.Eval 'Meta.disable_unredirect_for_screen(global.screen);'
Name=Mutter Tear Fix
EOF
reboot

Can someone please make sure this fix is rolled out to all users? Debian 8 is still under support, isn't it ;-)

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1192888
http://forums.fedoraforum.org/showthread.php?t=303945
dancra
 
Posts: 12
Joined: 2016-05-03 09:59


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable