Intel HD Graphics 510 on Debian Testing

Everything about X, Gnome, KDE, ... and everything running on it

Intel HD Graphics 510 on Debian Testing

Postby luguercio » 2017-01-10 03:57

Hi, i couln't find any official instructions as to what's the best way to get the integrated graphics of skylake processors (in this case g4400, and it comes with intel HD Graphics 510) properly working. So i just installed the following packages: xserver-xorg-video-intel and libegl1-mesa. I've seen different recommendations, so i wonder, what's the correct way of doing this, there is one?
luguercio
 
Posts: 38
Joined: 2009-10-02 16:50

Re: Intel HD Graphics 510 on Debian Testing

Postby stevepusser » 2017-01-10 05:18

There's a very good chance you also need the firmware-misc-nonfree package to load firmware for that graphics hardware, since the 510 is Skylake hardware: https://packages.debian.org/stretch/fir ... sc-nonfree
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.4, Pale Moon 27.9.4, wine-staging 3.12, MPC-QT 18.03, Linux kernel 4.17.6, Krita 4.1.1
User avatar
stevepusser
 
Posts: 9726
Joined: 2009-10-06 05:53

Re: Intel HD Graphics 510 on Debian Testing

Postby luguercio » 2017-01-10 15:24

Now lightdm doesn't start. I first installed the package xserver-xorg-video-intel, and everything worked fine except 3D acceleration. I tried to make it work by installing libegl1-mesa, and now the X server seems to not work. I now also installed the package firmware-misc-nonfree, and still get a black screen after everything finishes loading :(
luguercio
 
Posts: 38
Joined: 2009-10-02 16:50

Re: Intel HD Graphics 510 on Debian Testing

Postby luguercio » 2017-01-10 17:51

Ok, now i got it to work again :D . I entered in text mode (by adding "text" to the linux kernel parameters in grub, by pressing 'e') because i couldn't do anything in normal mode, and in recovery mode i didn't had network support, so then i reinstalled the following packages: firmware-misc-nonfree xserver-xorg-core xserver-xorg-video-intel libegl1-mesa libgl1-mesa-glx libgl1-mesa-dri.

Now everything works fine. I will now see how i can tweak some parameters of the integrated video card
luguercio
 
Posts: 38
Joined: 2009-10-02 16:50

Re: Intel HD Graphics 510 on Debian Testing

Postby Talkless » 2018-01-03 11:22

luguercio wrote:Now everything works fine.


Could you confirm that you have 3D acceleration? Does `glxgears -info` confirms that it uses Intel driver, not some LLVM Pipe software rasterizer..?

I am interested in some Skylake-based board that has Intel HD 510. After burning due to Atom with GMA500, I would like to be sure I would get proper OpenGL support...

Thanks!
Talkless
 
Posts: 35
Joined: 2013-05-13 10:18

Re: Intel HD Graphics 510 on Debian Testing

Postby stevepusser » 2018-01-03 18:02

Stretch defaults to using the "modesetting" driver from the kernel for this hardware instead of "intel", but you can force the system to use the intel driver if desired with a 20-intel.conf file in /etc/X11/xorg.conf.d. I do so for my Intel 520 graphics to exercise the TearFree option.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.4, Pale Moon 27.9.4, wine-staging 3.12, MPC-QT 18.03, Linux kernel 4.17.6, Krita 4.1.1
User avatar
stevepusser
 
Posts: 9726
Joined: 2009-10-06 05:53


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable