pulse audio volume reseting to 100% on stretch/sid

Everything about X, Gnome, KDE, ... and everything running on it

pulse audio volume reseting to 100% on stretch/sid

Postby aglomerator » 2017-02-07 18:24

I find that starting some applications (notably KDE ones) causes their volume in pulse audio to be set to 100%. If subsequently another application (a gnome one) is started, its volume is also set to 100%, instead of what it was the last time it ran.

This is probably not the bug reported here: https://bugs.launchpad.net/ubuntu/+sour ... bug/204536 I've also tried changing the flat-volumes config option as suggested on https://bbs.archlinux.org/viewtopic.php?id=196044 , but with no effect.

Here is a log of what happens when a KDE application such as kolourpaint is started. The error is shown on the last line, but might be a consequence of one of the earlier lines.

Thanks for any help.

( 122.268| 0.007) D: [pulseaudio] sink-input.c: Negotiated format: pcm, format.sample_format = "\"float32le\"" format.rate = "48000" format.channels = "2" format.channel_map = "\"front-left,front-right\""
( 122.268| 0.000) I: [pulseaudio] sink-input.c: Trying to change sample rate
( 122.268| 0.000) I: [pulseaudio] sink.c: Cannot update rate, monitor source is RUNNING
( 122.268| 0.000) D: [pulseaudio] module-stream-restore.c: Not restoring volume for sink input sink-input-by-media-role:video, because already set.
( 122.268| 0.000) I: [pulseaudio] module-stream-restore.c: Restoring mute state for sink input sink-input-by-media-role:video.
( 122.268| 0.000) D: [pulseaudio] module-suspend-on-idle.c: Sink alsa_output.pci-0000_00_1b.0.analog-stereo becomes busy, resuming.
( 122.268| 0.000) D: [pulseaudio] resampler.c: Resampler:
( 122.268| 0.000) D: [pulseaudio] resampler.c: rate 48000 -> 44100 (method speex-float-1)
( 122.268| 0.000) D: [pulseaudio] resampler.c: format float32le -> s16le (intermediate float32le)
( 122.268| 0.000) D: [pulseaudio] resampler.c: channels 2 -> 2 (resampling 2)
( 122.268| 0.000) I: [pulseaudio] speex.c: Choosing speex quality setting 1.
( 122.268| 0.000) D: [pulseaudio] memblockq.c: memblockq requested: maxlength=33554432, tlength=0, base=4, prebuf=0, minreq=1 maxrewind=0
( 122.268| 0.000) D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=33554432, tlength=33554432, base=4, prebuf=0, minreq=4 maxrewind=0
( 122.268| 0.000) I: [pulseaudio] sink-input.c: Created input 9 "audio stream" on alsa_output.pci-0000_00_1b.0.analog-stereo with sample spec float32le 2ch 48000Hz and channel map front-left,front-right
( 122.268| 0.000) I: [pulseaudio] sink-input.c: media.role = "video"
( 122.268| 0.000) I: [pulseaudio] sink-input.c: media.name = "audio stream"
( 122.268| 0.000) I: [pulseaudio] sink-input.c: application.name = "kolourpaint"
( 122.268| 0.000) I: [pulseaudio] sink-input.c: native-protocol.peer = "UNIX socket client"
( 122.268| 0.000) I: [pulseaudio] sink-input.c: native-protocol.version = "31"
.......
( 122.268| 0.000) I: [pulseaudio] sink-input.c: application.process.binary = "kolourpaint"
( 122.268| 0.000) I: [pulseaudio] sink-input.c: window.x11.display = ":0"
( 122.268| 0.000) I: [pulseaudio] sink-input.c: module-stream-restore.id = "sink-input-by-media-role:video"
( 122.268| 0.000) I: [pulseaudio] protocol-native.c: Requested tlength=120.00 ms, minreq=40.00 ms
( 122.268| 0.000) D: [pulseaudio] protocol-native.c: Traditional mode enabled, modifying sink usec only for compat with minreq.
( 122.269| 0.000) D: [pulseaudio] protocol-native.c: Requested latency=40.00 ms, Received latency=40.00 ms
( 122.269| 0.000) D: [pulseaudio] memblockq.c: memblockq requested: maxlength=4194304, tlength=46080, base=8, prebuf=0, minreq=15360 maxrewind=0
( 122.269| 0.000) D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=4194304, tlength=46080, base=8, prebuf=0, minreq=15360 maxrewind=0
( 122.269| 0.000) I: [pulseaudio] protocol-native.c: Final latency 160.00 ms = 40.00 ms + 2*40.00 ms + 40.00 ms
( 122.269| 0.000) D: [pulseaudio] sink.c: The reference volume of sink alsa_output.pci-0000_00_1b.0.analog-stereo changed from front-left: 20996 / 32% / -29.66 dB, front-right: 20996 / 32% / -29.66 dB to front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB.
aglomerator
 
Posts: 5
Joined: 2015-04-05 23:25

Re: pulse audio volume reseting to 100% on stretch/sid

Postby gradinaruvasile » 2017-03-01 22:31

I don't use KDE but the flat_volumes option set to "no" in /etc/pulse/daemon.conf is usually the fix in cases like this.
Did you restart pulseaudio after the option was set?
Also, did you empty the PA cache by deleting the contents of ~/.config/pulse/ after you stopped pulseaudio?
User avatar
gradinaruvasile
 
Posts: 932
Joined: 2010-01-31 22:03
Location: Cluj, Romania


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable