Get rid of gnome on screen keyboard

Everything about X, Gnome, KDE, ... and everything running on it

Get rid of gnome on screen keyboard

Postby workoft » 2017-03-03 16:15

Hi,

This question can be found a couple of times on the Internet, but the solutions aren't satisfactory.

I have a laptop with touchscreen, and whenever I use the touch screen the on screen keyboard pops up, despite the fact that the laptop has a built in keyboard and I have an external keyboard connected as well. So the only situation I would want this to show up is when I'm using the computer in tablet mode with no external keyboard connected. I guess there'd be a script for that, but in the meantime I'd rather just get rid of it altogether or have it show up only on demand. There is a button for that in the Universal access menu - but even when it's off, the keyboard pops up when I start using the touch screen. When the option is on, the keyboard is permanently present.
I still haven't figured out for sure which application it is - it appears to be caribou. The most common suggestion I could find is to just un-install it. Unfortunately that removes task-gnome-desktop, which I'd like to keep. Another suggestion is to just rename the executable or make it an empty file. Unfortunately that doesn't remove the keyboard, possibly it isn't caribou after all.

So, does anyone know how I permanently disable the on-screen keyboard or make it appear only in the scenarios that I have described?
It doesn't even obey my layout settings.

Thanks
workoft
 
Posts: 1
Joined: 2017-03-03 16:02

Re: Get rid of gnome on screen keyboard

Postby bw123 » 2017-03-06 14:43

I don't use gnome, but seems like that might be something related to "accessibility"

most common suggestion I could find is to just un-install it. Unfortunately that removes task-gnome-desktop, which I'd like to keep.


This (uninstall package removes other packages) is easily fixed if you read up a little on automatically installed packages. Even if you renamed the binary, the desktop may be getting its 'juice' from a libcaribou or some such. So I'd try uninstalling caribou, see if that solves it, and in the meantime read up on 'gsettings' 1-2 and/or 3 or 'dconf' or whatever app is used to get at the lower level gnome settings nowadays.

Maybe removing this will break gnome, I don't know, anything is possible. It does look like a hard dependency of gnome-core so maybe it's impossible.

Code: Select all
$ man apt-mark


There's also another package called 'caibou-antler' listed as dependency of gnome-core on jessie, so maybe this 'antler' needs to be cut off until you can figure out how to reattach it the way you want?

If all else fails, maybe check /usr/share/doc/caribou for some clues.
User avatar
bw123
 
Posts: 2411
Joined: 2011-05-09 06:02
Location: TN_USA


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable