Firefox text rendering is poor

Everything about X, Gnome, KDE, ... and everything running on it

Firefox text rendering is poor

Postby Magnusmaster » 2017-04-02 22:36

Ever since I updated Firefox to version 52, the font rendering for the websites (not the UI) is very poor, and different from that of any other app. It seems it uses full hinting, instead of the slight hinting which is the font setting I use. Here are some screenshots: http://imgur.com/a/Wv3hQ

How can I fix this?
Magnusmaster
 
Posts: 168
Joined: 2010-06-12 22:50

Re: Firefox text rendering is poor

Postby bw123 » 2017-04-02 23:13

I couldn't see the image with links2 or find a clickable link to view on your imgur link. I don't use javascript, not even for pron sites. javascript is insecure, so my best guess is it looks horrible?

How can I fix this?


Don't know, but maybe if you post more info about debian version, how (and where) you got the ff52, and what desktop you are using, some other nice people will give you some hints?
User avatar
bw123
 
Posts: 2396
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Firefox text rendering is poor

Postby Magnusmaster » 2017-04-03 01:06

I am using debian sid, with firefox-esr from experimental. Upstream Firefox has the same issue.
Magnusmaster
 
Posts: 168
Joined: 2010-06-12 22:50

Re: Firefox text rendering is poor

Postby Bulkley » 2017-04-03 01:21

Magnusmaster wrote:I am using debian sid, with firefox-esr from experimental.


That explains it.
Bulkley
 
Posts: 5318
Joined: 2006-02-11 18:35

Re: Firefox text rendering is poor

Postby debiman » 2017-04-03 18:00

you definitely should have included that information in your op.

i can see the font doesn't look too perfect on your scrot.

have you scoured firefox' font settings in about:config?

could it have sth to do with FF's switch to gtk3?
User avatar
debiman
 
Posts: 1511
Joined: 2013-03-12 07:18

Re: Firefox text rendering is poor

Postby TonyT » 2017-04-03 22:05

You can handle hinting for the UI with userchrome.css and the Body of Webpages with usercontent.css.

Firefox supports:

font-smooth: auto;
font-smooth: never;
font-smooth: always;

text-rendering: auto;
text-rendering: optimizeSpeed;
text-rendering: optimizeLegibility;
text-rendering: geometricPrecision;
TonyT
 
Posts: 525
Joined: 2006-09-04 11:57

Re: Firefox text rendering is poor

Postby Magnusmaster » 2017-04-03 22:48

TonyT wrote:You can handle hinting for the UI with userchrome.css and the Body of Webpages with usercontent.css.

Firefox supports:

font-smooth: auto;
font-smooth: never;
font-smooth: always;

text-rendering: auto;
text-rendering: optimizeSpeed;
text-rendering: optimizeLegibility;
text-rendering: geometricPrecision;


Sadly setting those properties in usercontent.css does nothing.
Magnusmaster
 
Posts: 168
Joined: 2010-06-12 22:50

Re: Firefox text rendering is poor

Postby TonyT » 2017-04-04 10:57

In about:config try changing:

gfx.canvas.azure.backends =
gfx.content.azure.backends =

to the way it used to be: cairo
TonyT
 
Posts: 525
Joined: 2006-09-04 11:57

Re: Firefox text rendering is poor

Postby Magnusmaster » 2017-04-04 23:26

That was the first thing I tried. Sadly, it didn't do anything.
Magnusmaster
 
Posts: 168
Joined: 2010-06-12 22:50

Re: Firefox text rendering is poor

Postby debiman » 2017-04-05 15:53

Magnusmaster wrote:That was the first thing I tried.

really?
why didn't you mention this in your original post?
makes me wonder, what was the second thing you tried? and the third?
User avatar
debiman
 
Posts: 1511
Joined: 2013-03-12 07:18

Re: Firefox text rendering is poor

Postby ruffwoof » 2017-04-05 22:15

Try ...

apt-get install ttf-mscorefonts-installer
apt-get install ttf-liberation

In Firefox Edit, Preferences, Content and set the default font to perhaps Arial, then click advanced and uncheck 'Allow pages to choose their own font'
ruffwoof
 
Posts: 211
Joined: 2016-08-20 21:00

Re: Firefox text rendering is poor

Postby Magnusmaster » 2017-04-07 23:29

I managed to fix it by adding these settings in my fonts.conf file. Firefox should have picked up the XFCE settings, but didn't.
Code: Select all
<edit mode="assign" name="lcdfilter">
   <const>lcddefault</const>
  </edit>
   <edit mode="assign" name="hinting">
   <const>true</const>
  </edit>
   <edit mode="assign" name="hintstyle">
   <const>hintslight</const>
  </edit>
  <edit mode="assign" name="embeddedbitmap">
   <bool>false</bool>
  </edit>
Magnusmaster
 
Posts: 168
Joined: 2010-06-12 22:50


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable