Can't Start LXDE on Minimal Debian 8.7.1 Install

Everything about X, Gnome, KDE, ... and everything running on it

Can't Start LXDE on Minimal Debian 8.7.1 Install

Postby broadsworde » 2017-04-17 16:35

In preparation for migrating from Ubuntu to Debian when Stretch is released, I installed 8.7.1 on a VM using the debian-8.7.1-amd64-netinst.iso media, and selected no desktop environment as I want to use the minimal lxde-core.
The installation completed without error, and once booted I then installed lxde-core, again without error.
I then rebooted expecting LXDE to start automatically, but no such luck.

Having researched online, I tried starting LXDE manually, so far without success:
Code: Select all
# startlxde
** Message: main.vala:99: Session is LXDE
** Message: main.vala:100: DE is LXDE
(lxsession:823): Gtk-WARNING **: cannot open display:

# exec startlxde
** Message: main.vala:99: Session is LXDE
** Message: main.vala:100: DE is LXDE
(lxsession:823): Gtk-WARNING **: cannot open display:

# lxdm start
bash: lxdm: command not found

# startx
bash: lxdm: command not found

# update-alternatives --config x-session-manager
update-alternatives: error: no alternatives for x-session-manager


I thought lxde-core would be stand-alone, but do I need to install other packages, like xserver-xorg, lightdm?

Thanks
broadsworde
 
Posts: 13
Joined: 2017-03-01 13:50

Re: Can't Start LXDE on Minimal Debian 8.7.1 Install

Postby arochester » 2017-04-17 17:15

You have no xorg installed. X.org is the backend graphical system used by all major desktop environments.

Debian does not use sudo by default. You will not have sudo unless you install it. Sudo allows you to run individual commands as root.

You will have no browser, unless you install one.

You will have no sound unless you install something like pulseaudio. PulseAudio is one of the sound systems most commonly used in Linux.
Debian Users Forum - for questions specific to the Debian official distribution (stable, testing, or unstable); if you are using a derivative of Debian (e.g. Mint, Ubuntu, Kali, etc), then please use that distribution’s forum.
arochester
 
Posts: 870
Joined: 2010-12-07 19:55

Re: Can't Start LXDE on Minimal Debian 8.7.1 Install

Postby broadsworde » 2017-04-17 17:21

Many thanks arochester. I just installed lightdm, rebooted and now I have the LXDE GUI. I'll now install the things I need/want.
broadsworde
 
Posts: 13
Joined: 2017-03-01 13:50

Re: Can't Start LXDE on Minimal Debian 8.7.1 Install

Postby ruffwoof » 2017-04-17 18:28

apt-get update; apt-get install numlockx pavucontrol
are amongst others that you'll probably want to install
ruffwoof
 
Posts: 75
Joined: 2016-08-20 21:00

Re: Can't Start LXDE on Minimal Debian 8.7.1 Install

Postby peer » 2017-04-18 05:50

minimal: lxde-core xorg lightdm
I also install:
network-manager (network-manager-gnome wireless-tools voor wireless)
alsa-utils alsamixergui libalsaplayer0 (sound)
peer
 
Posts: 10
Joined: 2017-03-26 10:14

Re: Can't Start LXDE on Minimal Debian 8.7.1 Install

Postby broadsworde » 2017-04-18 07:53

Genius peer, thanks very much.

I have been trying to get the sound to work, I'd installed alsa-utils and alsamixergui, but didn't know about libalsaplayer0... just installed that and I can once again hear!

Question on xorg, do I really need this, the gui seems to be working fine with just lxde-core and lightdm? What will xorg do for me?

Thanks
broadsworde
 
Posts: 13
Joined: 2017-03-01 13:50

Re: Can't Start LXDE on Minimal Debian 8.7.1 Install

Postby None1975 » 2017-04-18 10:57

broadsworde wrote:Question on xorg, do I really need this, the gui seems to be working fine with just lxde-core and lightdm? What will xorg do for me?
Thanks

X.Org (X Window System) provides the components for a standalone workstation running the X Window System. It provides the X libraries, an X server, a set of fonts, and a group of basic X clients and utilities. Higher level metapackages, such as those for desktop environments, can depend on this package and simplify their dependencies. It should be noted that a package providing x-window-manager should also be installed to ensure a comfortable X experience.
Source https://packages.debian.org/jessie/xorg
Image
User avatar
None1975
 
Posts: 68
Joined: 2015-11-29 18:23

Re: Can't Start LXDE on Minimal Debian 8.7.1 Install

Postby broadsworde » 2017-04-18 11:23

Many thanks None1975, I'm convinced.
broadsworde
 
Posts: 13
Joined: 2017-03-01 13:50


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable