MATE 1.18 in /usr/local/

Everything about X, Gnome, KDE, ... and everything running on it

Re: MATE 1.18 in /usr/local/

Postby Verequies » 2017-06-15 23:51

Awesome, I received all updates except for Pluma? I'll have a go at compiling Brisk Menu, may be able to figure it out.
User avatar
Verequies
 
Posts: 13
Joined: 2016-07-05 02:46

Re: MATE 1.18 in /usr/local/

Postby Verequies » 2017-06-16 00:24

Okay, got it to compile just fine - no errors. I uploaded the .deb here - removed. Before installing I had to just install all the MATE development files and then compiled with ./configure --prefix=/usr. It may be because I'm using Debian Unstable? What was the syntax error you received?
Last edited by Verequies on 2017-06-17 06:50, edited 1 time in total.
User avatar
Verequies
 
Posts: 13
Joined: 2016-07-05 02:46

Re: MATE 1.18 in /usr/local/

Postby stevepusser » 2017-06-16 17:28

Well,sometime the OBS has quirks that don't appear when the same code is rebuilt on our own machines. This one is stumping me, though 0.2.0 builds just fine. Maybe if I change the autoreconf procedure...

Go to this link: https://build.opensuse.org/package/show ... menu-0.4.5

and click on the "failed" result on the right to see the build log, though it will be changing as I experiment. The lines are currently:
Code: Select all
[  236s] checking for MENU... yes
[  236s] checking for APPLET... yes
[  236s] ./configure: line 13339: syntax error near unexpected token `0.50.0'
[  236s] ./configure: line 13339: `IT_PROG_INTLTOOL(0.50.0)'
[  236s] /usr/share/cdbs/1/class/autotools.mk:44: recipe for target 'debian/stamp-autotools' failed
[  236s] make: *** [debian/stamp-autotools] Error 2
[  236s] dpkg-buildpackage: error: debian/rules build gave error exit status 2
[  236s]
[  236s] lamb68 failed "build brisk-menu_0.4.5-0.obs.dsc" at Fri Jun 16 18:06:26 UTC 2017.
[  236s]
[  236s] ### VM INTERACTION START ###
[  239s] [  220.926585] reboot: Power down


So something in the configure script that was regenerated caused the failure.

Edit: Googling the error shows it may be a missing "intltool" build-depend in the debian/control file that causes that syntax error, so I'll try adding it...

Yeah, that fixed it. Forehead slap for me for not just webresearching the error message earlier, but somehow intltool must get pulled in automatically in a PPA build, but not in a Debian Stretch OBS virtual machine.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8342
Joined: 2009-10-06 05:53

Re: MATE 1.18 in /usr/local/

Postby Verequies » 2017-06-17 06:50

Funny how just a quick Google search can fix most issues in seconds, and yet its one of the last things we check sometimes - oh well we are only Human :D. Also I noticed why Pluma hadn't updated. I think you accidentally uploaded the Engrampa source to the Pluma folder? https://build.opensuse.org/package/show ... 1.18/pluma
User avatar
Verequies
 
Posts: 13
Joined: 2016-07-05 02:46

Re: MATE 1.18 in /usr/local/

Postby stevepusser » 2017-06-17 15:09

D'oh! OK, that's fixed now, thanks for catching that.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8342
Joined: 2009-10-06 05:53

Previous

Return to Desktop & Multimedia

Who is online

Users browsing this forum: kopper, Lysander and 9 guests

fashionable