Stretch / nvidia : can't connect to xserver

Everything about X, Gnome, KDE, ... and everything running on it

Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-18 07:04

I have been running stretch with nvidia drivers for more than a month now.
Yesterday did an update which included some kernel stuff. Kernel headers were kept back but that was solved with a dist-upgrade.
I always start X with startx, so no display manager login thingies:-)
Attached is the output of startx -logverbose 6 and the Xorg logfile.

I just get:
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

I have already zapped .Xauthority which is then rebuilt.

Any hints what could have caused this?
Previous failures with X and nvidia always gave me some errors which helped me fix things.
I did completely purge and reinstall all the nvidia related packages.

Ok, somehow I can't attach logfiles because of complaints about extensions so here are the contents:-)

Output from startx -logverbose 6:
Code: Select all
X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-4-amd64 i686 Debian
Current Operating System: Linux dakka 4.9.0-3-686-pae #1 SMP Debian 4.9.25-1 (2017-05-02) i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-3-686-pae root=UUID=27aa4035-0322-4a6d-8310-cd41f764de92 ro quiet
Build Date: 03 March 2017  03:15:35PM
xorg-server 2:1.19.2-1 (https://www.debian.org/support)
Current version of pixman: 0.34.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu May 18 09:29:39 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error


And Xorg.0.log:
Code: Select all
[   493.699]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[   493.699] X Protocol Version 11, Revision 0
[   493.700] Build Operating System: Linux 3.16.0-4-amd64 i686 Debian
[   493.700] Current Operating System: Linux dakka 4.9.0-3-686-pae #1 SMP Debian 4.9.25-1 (2017-05-02) i686
[   493.700] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-3-686-pae root=UUID=27aa4035-0322-4a6d-8310-cd41f764de92 ro quiet
[   493.700] Build Date: 03 March 2017  03:15:35PM
[   493.700] xorg-server 2:1.19.2-1 (https://www.debian.org/support)
[   493.700] Current version of pixman: 0.34.0
[   493.700]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   493.700] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   493.700] (==) Log file: "/var/log/Xorg.0.log", Time: Thu May 18 09:29:39 2017
[   493.727] (==) Using config file: "/etc/X11/xorg.conf"
[   493.727] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   493.772] (==) ServerLayout "Default Layout"
[   493.772] (**) |-->Screen "Default Screen" (0)
[   493.772] (**) |   |-->Monitor "DELL 2408WFP"
[   493.774] (**) |   |-->Device "nVidia Corporation NVIDIA Default Card"
[   493.774] (**) |-->Screen "Default Screen" (1)
[   493.774] (**) |   |-->Monitor "DELL 2408WFP"
[   493.774] (**) |   |-->Device "nVidia Corporation NVIDIA Default Card"
[   493.774] (**) |-->Input Device "Generic Keyboard"
[   493.774] (**) |-->Input Device "Configured Mouse"
[   493.774] (==) Automatically adding devices
[   493.774] (==) Automatically enabling devices
[   493.774] (==) Automatically adding GPU devices
[   493.787] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   493.840] (WW) The directory "/usr/X11R6/lib/X11/fonts/misc" does not exist.
[   493.840]    Entry deleted from font path.
[   493.840] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   493.840]    Entry deleted from font path.
[   493.840] (WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
[   493.841]    Entry deleted from font path.
[   493.860] (WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
[   493.860]    Entry deleted from font path.
[   493.881] (WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi/" does not exist.
[   493.881]    Entry deleted from font path.
[   493.899] (WW) The directory "/usr/X11R6/lib/X11/fonts/Type1" does not exist.
[   493.899]    Entry deleted from font path.
[   493.899] (WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi" does not exist.
[   493.899]    Entry deleted from font path.
[   493.899] (WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi" does not exist.
[   493.899]    Entry deleted from font path.
[   493.925] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   493.925]    Entry deleted from font path.
[   493.926] (**) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[   493.926] (==) ModulePath set to "/usr/lib/xorg/modules"
[   493.926] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   493.926] (WW) Disabling Generic Keyboard
[   493.926] (WW) Disabling Configured Mouse
[   493.926] (II) Loader magic: 0x80320720
[   493.926] (II) Module ABI versions:
[   493.926]    X.Org ANSI C Emulation: 0.4
[   493.926]    X.Org Video Driver: 23.0
[   493.926]    X.Org XInput driver : 24.1
[   493.926]    X.Org Server Extension : 10.0
[   493.928] (++) using VT number 1

[   493.939] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_33
[   493.940] (II) xfree86: Adding drm device (/dev/dri/card0)
[   493.941] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
[   493.944] (--) PCI:*(0:1:0:0) 10de:0fc1:1043:83f3 rev 161, Mem @ 0xfa000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/131072
[   493.945] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   493.945] (II) LoadModule: "i2c"
[   493.945] (II) Module "i2c" already built-in
[   493.945] (II) LoadModule: "ddc"
[   493.945] (II) Module "ddc" already built-in
[   493.945] (II) LoadModule: "extmod"
[   493.945] (II) Module "extmod" already built-in
[   493.945] (II) LoadModule: "glx"
[   493.958] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[   494.896] (II) Module glx: vendor="NVIDIA Corporation"
[   494.896]    compiled for 4.0.2, module version = 1.0.0
[   494.896]    Module class: X.Org Server Extension
[   494.896] (II) NVIDIA GLX Module  375.39  Tue Jan 31 19:16:46 PST 2017
[   494.897] (II) LoadModule: "int10"
[   494.932] (II) Loading /usr/lib/xorg/modules/libint10.so
[   494.957] (II) Module int10: vendor="X.Org Foundation"
[   494.957]    compiled for 1.19.2, module version = 1.0.0
[   494.957]    ABI class: X.Org Video Driver, version 23.0
[   494.957] (II) LoadModule: "vbe"
[   494.978] (II) Loading /usr/lib/xorg/modules/libvbe.so
[   494.989] (II) Module vbe: vendor="X.Org Foundation"
[   494.989]    compiled for 1.19.2, module version = 1.1.0
[   494.989]    ABI class: X.Org Video Driver, version 23.0
[   494.989] (II) LoadModule: "nvidia"
[   494.990] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   495.087] (II) Module nvidia: vendor="NVIDIA Corporation"
[   495.087]    compiled for 4.0.2, module version = 1.0.0
[   495.087]    Module class: X.Org Video Driver
[   495.102] (II) NVIDIA dlloader X Driver  375.39  Tue Jan 31 18:51:54 PST 2017
[   495.102] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   495.103] (II) systemd-logind: releasing fd for 226:0
[   495.128] (II) Loading sub module "fb"
[   495.128] (II) LoadModule: "fb"
[   495.128] (II) Loading /usr/lib/xorg/modules/libfb.so
[   495.156] (II) Module fb: vendor="X.Org Foundation"
[   495.156]    compiled for 1.19.2, module version = 1.0.0
[   495.156]    ABI class: X.Org ANSI C Emulation, version 0.4
[   495.156] (II) Loading sub module "wfb"
[   495.156] (II) LoadModule: "wfb"
[   495.156] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   495.163] (II) Module wfb: vendor="X.Org Foundation"
[   495.163]    compiled for 1.19.2, module version = 1.0.0
[   495.163]    ABI class: X.Org ANSI C Emulation, version 0.4
[   495.164] (II) Loading sub module "ramdac"
[   495.164] (II) LoadModule: "ramdac"
[   495.164] (II) Module "ramdac" already built-in
[   495.180] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   495.180] (==) NVIDIA(0): RGB weight 888
[   495.180] (==) NVIDIA(0): Default visual is TrueColor
[   495.181] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   495.182] (**) NVIDIA(0): Option "CustomEDID" "DFP-0:/etc/X11/2408wfp_0.edid.bin; DFP-2:/etc/X11/2408wfp_0.edid.bin"
[   495.182] (**) NVIDIA(0): Enabling 2D acceleration
[   496.058] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[   496.058] (--) NVIDIA(0):     CRT-0
[   496.058] (--) NVIDIA(0):     DFP-0 (boot)
[   496.058] (--) NVIDIA(0):     DFP-1
[   496.058] (--) NVIDIA(0):     DFP-2
[   496.060] (II) NVIDIA(0): NVIDIA GPU GeForce GT 640 (GK107) at PCI:1:0:0 (GPU-0)
[   496.060] (--) NVIDIA(0): Memory: 2097152 kBytes
[   496.060] (--) NVIDIA(0): VideoBIOS: 80.07.26.00.b3
[   496.060] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   496.062] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   496.062] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   496.062] (--) NVIDIA(GPU-0):
[   496.068] (--) NVIDIA(GPU-0): DELL 2408WFP (DFP-0): connected
[   496.068] (--) NVIDIA(GPU-0): DELL 2408WFP (DFP-0): Internal TMDS
[   496.068] (--) NVIDIA(GPU-0): DELL 2408WFP (DFP-0): 330.0 MHz maximum pixel clock
[   496.068] (--) NVIDIA(GPU-0):
[   496.068] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   496.068] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   496.068] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   496.068] (--) NVIDIA(GPU-0):
[   496.068] (--) NVIDIA(GPU-0): DFP-2: disconnected
[   496.068] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[   496.068] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[   496.068] (--) NVIDIA(GPU-0):
[   496.078] (WW) NVIDIA(0): No valid modes for "DFP-0:720x400"; removing.
[   496.079] (II) NVIDIA(0): Validated MetaModes:
[   496.079] (II) NVIDIA(0):     "DFP-0:1920x1200"
[   496.079] (II) NVIDIA(0):     "DFP-0:1600x1200"
[   496.079] (II) NVIDIA(0):     "DFP-0:1280x1024"
[   496.079] (II) NVIDIA(0):     "DFP-0:1152x864"
[   496.079] (II) NVIDIA(0):     "DFP-0:1024x768"
[   496.079] (II) NVIDIA(0):     "DFP-0:800x600"
[   496.079] (II) NVIDIA(0):     "DFP-0:640x480"
[   496.079] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1200
[   496.105] (--) NVIDIA(0): DPI set to (93, 95); computed from "UseEdidDpi" X config
[   496.105] (--) NVIDIA(0):     option
[   496.105] (--) Depth 24 pixmap format is 32 bpp
[   496.106] (II) NVIDIA: Using 1024.00 MB of virtual memory for indirect memory
[   496.106] (II) NVIDIA:     access.
[   496.189] (II) NVIDIA(0): Setting mode "DFP-0:1920x1200"
[   496.275] (==) NVIDIA(0): Disabling shared memory pixmaps
[   496.275] (==) NVIDIA(0): Backing store enabled
[   496.275] (==) NVIDIA(0): Silken mouse enabled
[   496.277] (**) NVIDIA(0): DPMS enabled
[   496.278] (II) Loading sub module "dri2"
[   496.278] (II) LoadModule: "dri2"
[   496.278] (II) Module "dri2" already built-in
[   496.278] (II) NVIDIA(0): [DRI2] Setup complete
[   496.278] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   496.278] (--) RandR disabled
[   496.288] (II) SELinux: Disabled on system
[   496.289] (II) Initializing extension GLX
[   496.289] (II) Indirect GLX disabled.
Last edited by fritsk on 2017-05-18 08:23, edited 1 time in total.
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Re: Stretch / nvidia : can't connect to xserver

Postby orythem27 » 2017-05-18 07:56

fritsk wrote:Ok, somehow I can't attach logfiles because of complaints about extensions so here are the contents:-)

You can use a pastebin service such as http://paste.debian.net/ to keep your post neat and tidy. Choose a long expiration duation if you would like to keep the infomation visible for longer. It's also possible to post to your distro(Debian) 's oficial pastebin service directly in the command line. Just do something like:
Code: Select all
apt install pastebinit
startx -logverbose 6 | pastebinit
cat /var/log/Xorg.0.log | pastebinit

And post the links here.

If you prefer to post the log outputs directly in the thread, it always helps to include the code in [code] tags to improve readability.
User avatar
orythem27
 
Posts: 252
Joined: 2017-05-11 07:59
Location: P.R. China

Re: Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-18 08:24

Thanks, those code tags did the trick.
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Re: Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-18 09:16

Ok, just to be sure I zapped my xorg.conf file and ran nvidia-xconfig.
Still the same result so it has nothing to do with my dual screen shenanigans.

I'll zap all nvidia stuff again as well as xorg.conf and .Xauthority to see whether nouveau does work.
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Re: Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-18 09:29

Ok, with nouveau kde does start up and it even finds both of my screens (one of which is a bit borked).
So the conclusion seems to be (even after reinstalling them) the the nvidia drivers have been borked somehow.
uname -a:
Linux dakka 4.9.0-3-686-pae #1 SMP Debian 4.9.25-1 (2017-05-02) i686 GNU/Linux
ii linux-headers-4.9.0-3-686-pae 4.9.25-1 i386 Header files for Linux 4.9.0-3-686-pae
ii linux-headers-4.9.0-3-common 4.9.25-1 all Common header files for Linux 4.9.0-3
lspci:
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 640] (rev a1)

Could it be that with the latest headers in stretch the nvidia packages won't work?
Something has happened in the last few weeks (I don't update that often:-))
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Re: Stretch / nvidia : can't connect to xserver

Postby phenest » 2017-05-18 10:09

fritsk wrote:Yesterday did an update which included some kernel stuff. Kernel headers were kept back but that was solved with a dist-upgrade.

fritsk wrote:Could it be that with the latest headers in stretch the nvidia packages won't work?

I think your answer lies here. Packages were held back but you upgraded anyway. If the kernel headers were kept back, it was for a good reason.
You possibly have an nVidia kernel module compiled against a different kernel image. Are your kernel image and headers exactly the same version?
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-18 10:26

Hmm, image and headers seem to be matching.

ii linux-image-4.9.0-3-686 4.9.25-1 i386 Linux 4.9 for older PCs
ii linux-image-4.9.0-3-686-pae 4.9.25-1 i386 Linux 4.9 for modern PCs
ii linux-headers-4.9.0-3-686-pae 4.9.25-1 i386 Header files for Linux 4.9.0-3-686-pae
ii linux-headers-4.9.0-3-common 4.9.25-1 all Common header files for Linux 4.9.0-3

But you may be right that the headers being held back is a sign something is not quite kosher.
I suspect I may need to wait a few days to see whether any more updates appear.
In the mean time things seem to work with nouveau.
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Re: Stretch / nvidia : can't connect to xserver

Postby phenest » 2017-05-18 10:33

I using the same image and headers as you, which I upgraded yesterday, but I saw nothing held back.

What happens if you reinstall them? Do you have an older kernel to boot into? If so, What about doing that and removing the new ones, then upgrade again?
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Stretch / nvidia : can't connect to xserver

Postby phenest » 2017-05-18 10:40

fritsk wrote:ii linux-image-4.9.0-3-686 4.9.25-1 i386 Linux 4.9 for older PCs
ii linux-image-4.9.0-3-686-pae 4.9.25-1 i386 Linux 4.9 for modern PCs
ii linux-headers-4.9.0-3-686-pae 4.9.25-1 i386 Header files for Linux 4.9.0-3-686-pae

Probably not related, but how come you have 2 different kernel images, and only 1 matching header? You have a PAE image and a non-PAE image.
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-18 11:08

Yup, that non-pae kernel is probably an inheritance form the time i didn't have that much memory. It can probably go.
I do have some older kernels available but this will have to wait until after I have done some tax related stuff:-)
I am happy that nouveau at least works but I will put more effort into this getting the nvidia drivers working again.
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Re: Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-21 10:29

Ok, I am stumped.
Booted with linux-image-4.9.0-2-686-pae.
Zapped linux-image-4.9.0-3-686-pae and all header files.
Zapped all nvidia stuff.
Then reinstalled the ...-3-... kerel and tried everything again. Still the same result.
My card GT640 should work with the nvidia 375.39-1 driver.
I am going back now to nouveaux to have something working.

What I did do was removing the latest kernel. I can try purging it as well.
What I can also try is to do all the shenanigans with the ...-2-... kernel, but i haven't figured out yet how to get the matching linux headers to install again. apt-get seems to want to install the ..-3-... headers as these are the latest.

The most frustrating bit is that there is no feedback what is actually going wrong when connecting to the xserver.
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Re: Stretch / nvidia : can't connect to xserver

Postby phenest » 2017-05-21 18:30

Are you using a xorg.conf file? I don't use one as it's not needed any more unless you have a specific setup like multi monitors.

Also, as you're using the nouveau driver, are you remembering to blacklist it after installing the nvidia driver?
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-21 18:34

Hmm, blacklisting might be it, but I think I saw that happening automatically. I'll try to do it explicitly.
Update : installing 'nvidia' automatically blacklists nouveau so that is not the problem.
To be continued:-)
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Re: Stretch / nvidia : can't connect to xserver

Postby stevepusser » 2017-05-21 18:44

I use a script that comes with module-assistant to make sure that the headers matching the running kernel are installed:

Code: Select all
# m-a prepare


There's probably a flag to specify other kernels or all installed, but I'm too lazy to read the man page right now. :roll:
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.4.2, Liquorix kernel 4.12-8, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8707
Joined: 2009-10-06 05:53

Re: Stretch / nvidia : can't connect to xserver

Postby fritsk » 2017-05-21 19:37

Ok, I am back to nouveau again:-)

That m-a script might be of some help as well.
More googling also shows the same symptoms with fixes in Xwrapper.config and root rights which I shall try out.
Improbable though as that would not explain why nouveau is working and nvidia isn't.

Will be continued in a few days...
fritsk
 
Posts: 10
Joined: 2017-05-18 06:46

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable