Protege incompatible with awesome WM

Everything about X, Gnome, KDE, ... and everything running on it

Protege incompatible with awesome WM

Postby hgeorg » 2017-05-24 08:11

I try to get protege 5.2.0 (https://protegewiki.stanford.edu/wiki/Main_Page) to work. It is java application, and I have tried both the version bundled with JRE and the unbundled one. Most of the testing is with the latter.

My main system, where I really need it to work, is running jessie, with LXDE and awesome WM. All of these from the official repo. The system is fully up to date.

Starting Protege, I get a blank window with only the border and titlebar supplied by the WM. However, if I replace awesome with openbox (LXDE default) it works. It does not help just to remove custom config for awesome, so clearly there is something in awesome which is incompatible with Protege.

I have never experienced anything similar. I thought the client and the WM would be entirely oblivious to each other.

Can anyone suggest what the problem might be, and how it might be fixed?
TIA
:-- George
hgeorg
 
Posts: 31
Joined: 2013-08-27 22:29

Re: Protege incompatible with awesome WM

Postby debiman » 2017-05-25 11:20

User avatar
debiman
 
Posts: 1017
Joined: 2013-03-12 07:18

Re: Protege incompatible with awesome WM

Postby hgeorg » 2017-06-20 11:22

Thanks a lot. That is very useful to know.
At the end of the day, I found that the problem disappeared by itself in stretch, saving me the hack.
hgeorg
 
Posts: 31
Joined: 2013-08-27 22:29


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable