How do I set en_DK-UTF-8 for LC_TIME?

Everything about X, Gnome, KDE, ... and everything running on it

How do I set en_DK-UTF-8 for LC_TIME?

Postby kcbagr » 2017-05-25 21:08

I have en_US-UTF-8 set as the default locale. I want to use en_DK-UTF-8 formatting for LC_TIME and LC_MEASUREMENT.

I followed the directions here: wiki but it had not effect. What is going on? How can I set this?

I am using up to date Debian 8.
kcbagr
 
Posts: 17
Joined: 2016-09-22 18:10

Re: How do I set en_DK-UTF-8 for LC_TIME?

Postby debiman » 2017-05-26 13:46

English in Denmark?

...well a quick search cleared that up, i found:
https://unix.stackexchange.com/question ... ish-locale
summary:
- en_DK-UTF-8 has been dropped
- en_IE-UTF-8 does the same (and i'm using that on my system for precisely the same reason)
User avatar
debiman
 
Posts: 1305
Joined: 2013-03-12 07:18

Re: How do I set en_DK-UTF-8 for LC_TIME?

Postby kcbagr » 2017-05-26 14:44

debiman wrote:English in Denmark?

...well a quick search cleared that up, i found:
https://unix.stackexchange.com/question ... ish-locale
summary:
- en_DK-UTF-8 has been dropped
- en_IE-UTF-8 does the same (and i'm using that on my system for precisely the same reason)


Thanks for the reply, but I don't think you understand my question.

I want to use en_DK.utf8 for the LC_TIME variable while en_US.utf8 is being used as system default. This wiki (https://wiki.debian.org/Locale#First_day_of_week) indicates that it can be done. But the described method does not work (so I assume it's out of date). I am looking for how to accomplish it on Debian 8 Stable.
kcbagr
 
Posts: 17
Joined: 2016-09-22 18:10

Re: How do I set en_DK-UTF-8 for LC_TIME?

Postby phenest » 2017-05-26 15:34

NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: How do I set en_DK-UTF-8 for LC_TIME?

Postby kcbagr » 2017-05-26 17:11



Yeah, that looks to be it. Thanks! But I find it hard to believe that that is the "proper" way to set that. That is rather involved and there should be a simpler way. This is what I'm looking for. For example, the debian wiki says to simply edit /etc/default/locale. this is much more reasonable.

I have discovered why editing /etc/default/locale appears to not work. It is working but something in the GNOME DE is overriding the PAM environment Debian is setting. So the real solution to this problem may lie with GNOME.
kcbagr
 
Posts: 17
Joined: 2016-09-22 18:10

Re: How do I set en_DK-UTF-8 for LC_TIME?

Postby phenest » 2017-05-26 19:08

kcbagr wrote:Thanks! But I find it hard to believe that that is the "proper" way to set that.

If you want a "proper" way to do this specifically for Gnome, then look at this:
https://unix.stackexchange.com/questions/136920/set-custom-locales-in-gnome3-on-fedora-20
kcbagr wrote:That is rather involved and there should be a simpler way.

If you're Gnome user, it's even more involved. I like one of the comments from that link:
I'm sure if they try really hard, they could make setting up custom locales just a little bit harder still.

Still, as I always say, if it's a one off, it's worth doing. (Actually, that's the first time I've said that.)
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: How do I set en_DK-UTF-8 for LC_TIME?

Postby kcbagr » 2017-05-26 20:41

phenest wrote:If you want a "proper" way to do this specifically for Gnome, then look at this:
https://unix.stackexchange.com/questions/136920/set-custom-locales-in-gnome3-on-fedora-20


I actually already tried that before posting here. I could not get that to work, specifically I could never get the custom file to appear in /etc/locale.gen. do you know how to do that? I followed the directions carefully with localedef etc.

phenest wrote:If you're Gnome user, it's even more involved. I like one of the comments from that link:
I'm sure if they try really hard, they could make setting up custom locales just a little bit harder still.

Still, as I always say, if it's a one off, it's worth doing. (Actually, that's the first time I've said that.)


Lol. Yes, GNOME is idiotic about this. every other OS allows people to change format of date, but not GNOME.
kcbagr
 
Posts: 17
Joined: 2016-09-22 18:10

Re: How do I set en_DK-UTF-8 for LC_TIME?

Postby phenest » 2017-05-26 21:03

I just made a stab in the dark and...
dconf-editor > /system/locale/region

Is that what you're looking for?
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable