Sound volume at startup

Everything about X, Gnome, KDE, ... and everything running on it

Sound volume at startup

Postby rousou » 2017-06-10 12:38

Hi all! I have two sound cards: the integrated one and an external usb DAC connected to the integrated amplifier.
The volume of the DAC is far too high and the device does some audible distortion (maybe it's preamplifier saturates).

The solution i have found is to lower the gain by 10dB, but i have to set it every time i swich on the DAC. Is there a way to set it automatically the right way?


Thank you all,

Gio
rousou
 
Posts: 7
Joined: 2017-05-15 17:20

Re: Sound volume at startup

Postby phenest » 2017-06-10 12:51

First, some questions:
1. What version of Debian are you using?
2. What make model of sound cards?
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Sound volume at startup

Postby debiman » 2017-06-14 05:48

rousou wrote:The solution i have found is to lower the gain by 10dB, but i have to set it every time i swich on the DAC. Is there a way to set it automatically the right way?

if your system recognizes both cards, well alsa should remember the state (volume etc.) automatically.
maybe it has something to do with plugging it in and out...
how are you setting the volume? through alsamixer (F6 => select sound card etc.) ?
User avatar
debiman
 
Posts: 1341
Joined: 2013-03-12 07:18


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable