debian 9 libreoffice writer fails to start in 32bit inst.

Everything about X, Gnome, KDE, ... and everything running on it

Re: debian 9 libreoffice writer fails to start in 32bit inst

Postby sunrat » 2017-07-25 22:18

It's admirable to file a bug report but you should check if one has already been filed. There are now at least five for this bug starting from June 20.
https://bugs.debian.org/cgi-bin/bugrepo ... bug=865303

There is also a workaround suggested that doesn't require removing packages https://bugs.debian.org/cgi-bin/bugrepo ... 865303#230 -
I've been discussing this regression with upstream develo[pers. It's
now understood and we have several possible fixes but we have not yet
settled on the best one.

You should also be able to work around it by temporarily disabling the
Stack Clash fix using the kernel parameter stack_guard_gap=1
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2041
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: debian 9 libreoffice writer fails to start in 32bit inst

Postby maximus1978 » 2017-07-28 14:00

maximus1978 wrote:I filed a bug report.

https://bugs.debian.org/cgi-bin/bugrepo ... bug=869613


Here are the other opened reports.

869613
865303
865866
869161
869613
maximus1978
 
Posts: 60
Joined: 2015-03-19 12:49

Re: debian 9 libreoffice writer fails to start in 32bit inst

Postby johndonne » 2017-08-29 21:01

Hello,
I had the same problem,
It worked for me with this :
apt-get remove --purge libreoffice-nlpsolver

problem solved !
johndonne
 
Posts: 1
Joined: 2017-08-29 21:00

Re: debian 9 libreoffice writer fails to start in 32bit inst

Postby stroudmw » 2017-09-01 13:24

I've had the same problem. To fix it, go into another LibreOffice app (eg LibreOffice Calc). Click on Tools -> Options -> Advanced. Deselect "Use a java runtime enviroment".
stroudmw
 
Posts: 11
Joined: 2017-09-01 12:55


Re: debian 9 libreoffice writer fails to start in 32bit inst

Postby winnyweg@gmail.com » 2017-09-17 19:04

I'm a newbie and I learnt an easy workround for this problem. Open Libre Office in the terminal with: libreoffice --global. Works every time.
winnyweg@gmail.com
 
Posts: 1
Joined: 2017-05-29 19:30

Previous

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable