Debian no sound after clicked I don't know what in alsa mixe

Everything about X, Gnome, KDE, ... and everything running on it

Debian no sound after clicked I don't know what in alsa mixe

Postby bb5 » 2017-06-27 15:56

Debian no sound after clicked I don't know what in alsa mixer.

Hi there. I have Debian installed. I wanted to adjust alsa mixer sound volume. I do not know what I clicked there and I have no more sound. Even if I adjust Master, or anything I change in the mixer I have no more sound. Can you help me please to restore anything of that to factory defaults or help me get the sound back?
bb5
 
Posts: 3
Joined: 2017-06-27 15:50

Re: Debian no sound after clicked I don't know what in alsa

Postby GarryRicketson » 2017-06-27 16:08

Did you try ? :
How to restore alsa mixer to defaults
First hit :https://bbs.archlinux.org/viewtopic.php?id=155804


Code: Select all
alsactl restore -P


If the first hit, does not work, look at some of the others, I am sure one of them will.
"What we expect you have already Done"

Before doing anything, read the Debian documentation:
Debian Documentation
How to ask the smart way
Debian Foro Español
======================
For the Birds
User avatar
GarryRicketson
 
Posts: 4219
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Debian no sound after clicked I don't know what in alsa

Postby bb5 » 2017-06-27 17:22

Thanks for help. The first hit helped me. Uninstalled with purge alsa-utils, deleted asound.state, rebooted, reinstalled alsa-utils and now sound works. I tried reinstalling alsa-utils before but without deleting asound.state and not rebooting and without success.
Thank you again.
bb5
 
Posts: 3
Joined: 2017-06-27 15:50

Re: Debian no sound after clicked I don't know what in alsa

Postby GarryRicketson » 2017-06-27 19:13

Your welcome, and thanks for sharing what you did.
---- edit -------
Oh, and maybe no need to say, but in the future try to be more careful about which buttons you click, so at least if something goes wrong you know which button you clicked, etc.
User avatar
GarryRicketson
 
Posts: 4219
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Debian no sound after clicked I don't know what in alsa

Postby sunrat » 2017-06-27 22:48

bb5 wrote:Debian no sound after clicked I don't know what in alsa mixer.

If you clicked the "M" key, you activated mute.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2001
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Debian no sound after clicked I don't know what in alsa

Postby bb5 » 2017-06-28 15:55

I clicked and muted again. You are right. That is very likely I did. How to unmute it back without reinstalling?
bb5
 
Posts: 3
Joined: 2017-06-27 15:50

Re: Debian no sound after clicked I don't know what in alsa

Postby GarryRicketson » 2017-06-28 16:59

Does clicking it again not un-mute it ?
It should toggle, if not, via the command line :
What if you try :
Code: Select all
amixer sset Master mute
amixer sset Master unmute

also , maybe in the manual:
Code: Select all
man alsamixer

or
Code: Select all
man amixer

I don't use alsa, so I can not confirm these,
but also just
Code: Select all
amixer

by it's self will give you information on the device.
(at least that is what they say, in some of the search results anyway)
User avatar
GarryRicketson
 
Posts: 4219
Joined: 2015-01-20 22:16
Location: Durango, Mexico


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable