nvidia-driver installation: Failed to start lightdm

Everything about X, Gnome, KDE, ... and everything running on it

nvidia-driver installation: Failed to start lightdm

Postby teo.o70 » 2017-07-03 11:02

Hi all!

I'm new in this forum and quite a newbie as linux user, so sorry if my posts and questions would seem trivial and annoying.

I'm trying to install Debian Stretch on my pc (I had Ubuntu 16.04 before) because of working purpose, but i can't manage with nvidia and wifi driver installation and maybe the installation itself.
After installing Stretch the only way to get a working desktop is to add
Code: Select all
nomodeset
in the GRUB.
After that during the boot some message of missing iwlwifi.something.24 25 26 27.code appear, but in the end wifi is working. I wonder why I'm getting such messages and then all is working fine with wifi.

What totally upset me are nvidia-driver. I
Code: Select all
apt-get nvidia-detect
and
Code: Select all
nvidia-detect

that says:
Code: Select all
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation 107M [GeForce GTX 960M]  [10de:139b] (rev a2)
...
It is recommended to install the
 nvidia-driver
packeage.

I install nvidia-driver following both https://wiki.debian.org/NvidiaGraphicsDrivers#Debian_8_.22Jessie.22 (obviously stretch substitute jessie) and https://linuxconfig.org/how-to-install-the-latest-nvidia-drivers-on-debian-9-stretch-linux, but the result is always a
Code: Select all
[FAILED] Failed to start Light Desktop Manager.
See 'systemctl status lightdm.service' for details.


Code: Select all
systemctl status lightdm.service
says:
Code: Select all
● lightdm.service - Light Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-07-03 12:40:21 CEST; 2min 14s ago
     Docs: man:lightdm(1)
  Process: 2052 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
  Process: 2049 ExecStartPre=/bin/sh -c ["$(cat /etc/X11/default-display-manager 2>/dev/null)" = /usr/sbin/lightdm" ] (code=exited, status=0/SUCCESS)
 Main PID: 2052 (code=exited, status=1/FAILURE)

Jul 03 12:45:00 debian systemd[1]: lightdm.service: Unit entered failed state.
Jul 03 12:45:00 debian systemd[1]: lightdm.service: Failed with result 'exit-code'.
Jul 03 12:45:01 debian systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Jul 03 12:45:01 debian systemd[1]: Stopped Light Display Manager.
Jul 03 12:45:01 debian systemd[1]: lightdm.service: Start request repeated too quickly.
Jul 03 12:45:01 debian systemd[1]: Failed to start Light Display Manager.
Jul 03 12:45:01 debian systemd[1]: lightdm.service: Unit entered failed state.
Jul 03 12:45:01 debian systemd[1]: lightdm.service: Failed with result 'exit-code'.


I attach also x-0.log file:
Code: Select all
X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
Current Operating System: Linux debian 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u2 (2017-06-26) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-3-amd64 root=UUID=5fe00cf1-3c88-43ab-9d32-8c12178422bf ro quiet
Build Date: 03 March 2017  03:14:41PM
xorg-server 2:1.19.2-1 (https://www.debian.org/support)
Current version of pixman: 0.34.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  3 12:45:00 2017
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.


and Xorg.0.log
Code: Select all
[  5260.204]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[  5260.204] X Protocol Version 11, Revision 0
[  5260.204] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
[  5260.204] Current Operating System: Linux debian 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u2 (2017-06-26) x86_64
[  5260.204] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-3-amd64 root=UUID=5fe00cf1-3c88-43ab-9d32-8c12178422bf ro quiet
[  5260.204] Build Date: 03 March 2017  03:14:41PM
[  5260.204] xorg-server 2:1.19.2-1 (https://www.debian.org/support)
[  5260.204] Current version of pixman: 0.34.0
[  5260.204]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  5260.204] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  5260.204] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  3 12:45:00 2017
[  5260.205] (==) Using config file: "/etc/X11/xorg.conf"
[  5260.205] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  5260.205] (==) ServerLayout "Layout0"
[  5260.205] (**) |-->Screen "Screen0" (0)
[  5260.205] (**) |   |-->Monitor "Monitor0"
[  5260.205] (**) |   |-->Device "Device0"
[  5260.205] (**) |-->Input Device "Keyboard0"
[  5260.205] (**) |-->Input Device "Mouse0"
[  5260.205] (==) Automatically adding devices
[  5260.205] (==) Automatically enabling devices
[  5260.205] (==) Automatically adding GPU devices
[  5260.205] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  5260.205] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  5260.205]    Entry deleted from font path.
[  5260.205] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[  5260.205] (==) ModulePath set to "/usr/lib/xorg/modules"
[  5260.205] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  5260.205] (WW) Disabling Keyboard0
[  5260.205] (WW) Disabling Mouse0
[  5260.205] (II) Loader magic: 0x55ce9f8f0e00
[  5260.205] (II) Module ABI versions:
[  5260.205]    X.Org ANSI C Emulation: 0.4
[  5260.205]    X.Org Video Driver: 23.0
[  5260.205]    X.Org XInput driver : 24.1
[  5260.205]    X.Org Server Extension : 10.0
[  5260.206] (++) using VT number 7

[  5260.206] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  5260.207] (II) xfree86: Adding drm device (/dev/dri/card0)
[  5260.207] (II) xfree86: Adding drm device (/dev/dri/card1)
[  5260.219] (--) PCI:*(0:0:2:0) 8086:191b:1558:0152 rev 6, Mem @ 0xdd000000/16777216, 0xa0000000/536870912, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[  5260.219] (--) PCI: (0:1:0:0) 10de:139b:1558:0152 rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[  5260.220] (II) LoadModule: "glx"
[  5260.220] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[  5260.226] (II) Module glx: vendor="NVIDIA Corporation"
[  5260.226]    compiled for 4.0.2, module version = 1.0.0
[  5260.226]    Module class: X.Org Server Extension
[  5260.226] (II) NVIDIA GLX Module  375.66  Mon May  1 14:28:39 PDT 2017
[  5260.226] (II) LoadModule: "nvidia"
[  5260.226] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  5260.227] (II) Module nvidia: vendor="NVIDIA Corporation"
[  5260.227]    compiled for 4.0.2, module version = 1.0.0
[  5260.227]    Module class: X.Org Video Driver
[  5260.227] (II) NVIDIA dlloader X Driver  375.66  Mon May  1 14:03:26 PDT 2017
[  5260.227] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  5260.227] (EE) No devices detected.
[  5260.227] (EE)
Fatal server error:
[  5260.227] (EE) no screens found(EE)
[  5260.227] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  5260.227] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  5260.227] (EE)
[  5260.278] (EE) Server terminated with error (1). Closing log file.


where it seems there is no screen found, but i can't understand how to fix it.
Any ideas?

Thank you so much!
Last edited by teo.o70 on 2017-07-12 22:48, edited 1 time in total.
Matteo
teo.o70
 
Posts: 1
Joined: 2017-07-03 09:28

Re: nvidia-driver installation: Failed to start Light D M

Postby milomak » 2017-07-12 21:01

are you able to login via console and run startx?

if so, check if you have plymouth installed
Code: Select all
p   plymouth                                                  - boot animation, logger and I/O multiplexer


what i have on the laptop described below
Code: Select all
# dpkg -l | grep plymouth
ii  libplymouth4:amd64                          0.9.2-4                              amd64        graphical boot animation and logger - shared libraries
ii  plymouth                                    0.9.2-4                              amd64        boot animation, logger and I/O multiplexer


edit

the interesting thing is that this happened to me on my laptop sid install (which has an nvidia card). but iirc the following error message actually mentioned lightdm and OnFailure in sid
Code: Select all
● lightdm.service - Light Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-07-03 12:40:21 CEST; 2min 14s ago
     Docs: man:lightdm(1)
  Process: 2052 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
  Process: 2049 ExecStartPre=/bin/sh -c ["$(cat /etc/X11/default-display-manager 2>/dev/null)" = /usr/sbin/lightdm" ] (code=exited, status=0/SUCCESS)
 Main PID: 2052 (code=exited, status=1/FAILURE)

Jul 03 12:45:00 debian systemd[1]: lightdm.service: Unit entered failed state.
Jul 03 12:45:00 debian systemd[1]: lightdm.service: Failed with result 'exit-code'.
Jul 03 12:45:01 debian systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Jul 03 12:45:01 debian systemd[1]: Stopped Light Display Manager.
Jul 03 12:45:01 debian systemd[1]: lightdm.service: Start request repeated too quickly.
Jul 03 12:45:01 debian systemd[1]: Failed to start Light Display Manager.
Jul 03 12:45:01 debian systemd[1]: lightdm.service: Unit entered failed state.
Jul 03 12:45:01 debian systemd[1]: lightdm.service: Failed with result 'exit-code'.


which then lead to these following commands
Code: Select all
  420  locate lightdm.service
  421  ls -la /lib/systemd/system/lightdm.service
  422  cat /lib/systemd/system/lightdm.service
  423  apt-file search plymouth-quit.service
  424  apt-cache policy plymouth
  425  aptitude install plymouth


The file in systemd had
Code: Select all
OnFailure=plymouth-quit.service


which led me to install plymouth and resolve the issue

edit - also please write lightdm (capitalise as you want) as one word in the title so searching finds this topic
iMac - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1678
Joined: 2009-06-09 22:20


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable