KDE broken after upgrading to 9

Everything about X, Gnome, KDE, ... and everything running on it

KDE broken after upgrading to 9

Postby otaviusdecimus » 2017-07-29 19:30

Hi there,
After upgrading Jessie to Stretch I found the system somewhat unstable.
For example, KDE is broken. When I try to re-install it via apt install kde-full
I get many errors such as:
...
dpkg: error processing archive /tmp/apt-dpkg-install-PkquRs/482-systemsettings_4%3a5.8.4-1_amd64.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/systemsettings.mo', which is also in package kde-l10n-si 4:4.8.4-2
Selecting previously unselected package translate-toolkit.
Preparing to unpack .../483-translate-toolkit_2.0.0-1_all.deb ...
Unpacking translate-toolkit (2.0.0-1) ...
Selecting previously unselected package translate-toolkit-doc.
Preparing to unpack .../484-translate-toolkit-doc_2.0.0-1_all.deb ...
Unpacking translate-toolkit-doc (2.0.0-1) ...
Selecting previously unselected package user-manager.
Preparing to unpack .../485-user-manager_4%3a5.8.5-2_amd64.deb ...
Unpacking user-manager (4:5.8.5-2) ...
Selecting previously unselected package valgrind.
Preparing to unpack .../486-valgrind_1%3a3.12.0~svn20160714-1+b1_amd64.deb ...
Unpacking valgrind (1:3.12.0~svn20160714-1+b1) ...
Selecting previously unselected package xplanet.
Preparing to unpack .../487-xplanet_1.3.0-4+b1_amd64.deb ...
Unpacking xplanet (1.3.0-4+b1) ...
Selecting previously unselected package xplanet-images.
Preparing to unpack .../488-xplanet-images_1.3.0-4_all.deb ...
Unpacking xplanet-images (1.3.0-4) ...
Selecting previously unselected package kaccounts-providers.
Preparing to unpack .../489-kaccounts-providers_16.08.3-1_amd64.deb ...
Unpacking kaccounts-providers (16.08.3-1) ...
Selecting previously unselected package python-avogadro.
Preparing to unpack .../490-python-avogadro_1.2.0-1+deb9u1_amd64.deb ...
Unpacking python-avogadro (1.2.0-1+deb9u1) ...
Selecting previously unselected package python-iniparse.
Preparing to unpack .../491-python-iniparse_0.4-2.2_all.deb ...
Unpacking python-iniparse (0.4-2.2) ...
Selecting previously unselected package valgrind-dbg.
Preparing to unpack .../492-valgrind-dbg_1%3a3.12.0~svn20160714-1+b1_amd64.deb ...
Unpacking valgrind-dbg (1:3.12.0~svn20160714-1+b1) ...
Errors were encountered while processing:
/tmp/apt-dpkg-install-PkquRs/164-kde-cli-tools-data_4%3a5.8.4-2_all.deb
/tmp/apt-dpkg-install-PkquRs/177-plasma-desktop-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-PkquRs/201-libkf5sysguard-data_4%3a5.8.4-1_all.deb
/tmp/apt-dpkg-install-PkquRs/209-plasma-workspace_4%3a5.8.6-2.1_amd64.deb
/tmp/apt-dpkg-install-PkquRs/328-kgamma5_5.8.4-1_amd64.deb
/tmp/apt-dpkg-install-PkquRs/408-khotkeys-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-PkquRs/410-kinfocenter_4%3a5.8.4-1_amd64.deb
/tmp/apt-dpkg-install-PkquRs/414-kmenuedit_4%3a5.8.4-1_amd64.deb
/tmp/apt-dpkg-install-PkquRs/422-ksysguard-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-PkquRs/426-kwin-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-PkquRs/457-powerdevil-data_4%3a5.8.4-1_all.deb
/tmp/apt-dpkg-install-PkquRs/482-systemsettings_4%3a5.8.4-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@zabriskie:~# apt install kde-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
kde-full is already the newest version (5:92).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
kde-cli-tools : Depends: kde-cli-tools-data (= 4:5.8.4-2) but it is not going to be installed
kde-plasma-desktop : Depends: plasma-workspace (>= 4:5.8) but it is not going to be installed
kdeconnect : Depends: plasma-workspace but it is not going to be installed
kdegraphics : Depends: kgamma5 (>= 5.8) but it is not going to be installed
khotkeys : Depends: khotkeys-data (= 4:5.8.6-1) but it is not going to be installed
ksysguard : Depends: ksysguard-data (= 4:5.8.6-1) but it is not going to be installed
kwin-common : Depends: kwin-data (= 4:5.8.6-1) but it is not going to be installed
libkf5sysguard-bin : Depends: libkf5sysguard-data (= 4:5.8.4-1) but it is not going to be installed
libksgrd7 : Depends: libkf5sysguard-data (= 4:5.8.4-1) but it is not going to be installed
libksignalplotter7 : Depends: libkf5sysguard-data (= 4:5.8.4-1) but it is not going to be installed
libprocesscore7 : Depends: libkf5sysguard-data (= 4:5.8.4-1) but it is not going to be installed
libprocessui7 : Depends: libkf5sysguard-data (= 4:5.8.4-1) but it is not going to be installed
plasma-desktop : Depends: plasma-desktop-data (= 4:5.8.6-1) but it is not going to be installed
Depends: plasma-workspace but it is not going to be installed
Recommends: kgamma5 but it is not going to be installed
Recommends: kinfocenter but it is not going to be installed
Recommends: kmenuedit but it is not going to be installed
Recommends: systemsettings but it is not going to be installed
plasma-widgets-addons : Depends: plasma-workspace but it is not going to be installed
powerdevil : Depends: powerdevil-data (= 4:5.8.4-1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@zabriskie:~# y
bash: y: command not found
root@zabriskie:~# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
ieee-data
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
kde-cli-tools-data kgamma5 khotkeys-data ksysguard-data kwin-data libkf5sysguard-data plasma-desktop-data
plasma-workspace powerdevil-data
The following NEW packages will be installed:
kde-cli-tools-data kgamma5 khotkeys-data ksysguard-data kwin-data libkf5sysguard-data plasma-desktop-data
plasma-workspace powerdevil-data
0 upgraded, 9 newly installed, 0 to remove and 1 not upgraded.
481 not fully installed or removed.
Need to get 0 B/17.9 MB of archives.
After this operation, 83.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 718457 files and directories currently installed.)
Preparing to unpack .../0-libkf5sysguard-data_4%3a5.8.4-1_all.deb ...
Unpacking libkf5sysguard-data (4:5.8.4-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/0-libkf5sysguard-data_4%3a5.8.4-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/ksysguardlsofwidgets.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../1-kde-cli-tools-data_4%3a5.8.4-2_all.deb ...
Unpacking kde-cli-tools-data (4:5.8.4-2) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/1-kde-cli-tools-data_4%3a5.8.4-2_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/filetypes.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../2-plasma-desktop-data_4%3a5.8.6-1_all.deb ...
Unpacking plasma-desktop-data (4:5.8.6-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/2-plasma-desktop-data_4%3a5.8.6-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/joystick.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../3-plasma-workspace_4%3a5.8.6-2.1_amd64.deb ...
Unpacking plasma-workspace (4:5.8.6-2.1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/3-plasma-workspace_4%3a5.8.6-2.1_amd64.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/drkonqi.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../4-kgamma5_5.8.4-1_amd64.deb ...
Unpacking kgamma5 (5.8.4-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/4-kgamma5_5.8.4-1_amd64.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/kcmkgamma.mo', which is also in package kde-l10n-si 4:4.8.4-2
Preparing to unpack .../5-khotkeys-data_4%3a5.8.6-1_all.deb ...
Unpacking khotkeys-data (4:5.8.6-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/5-khotkeys-data_4%3a5.8.6-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/khotkeys.mo', which is also in package kde-l10n-si 4:4.8.4-2
Preparing to unpack .../6-ksysguard-data_4%3a5.8.6-1_all.deb ...
Unpacking ksysguard-data (4:5.8.6-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/6-ksysguard-data_4%3a5.8.6-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/ksysguard.mo', which is also in package kde-l10n-si 4:4.8.4-2
Preparing to unpack .../7-kwin-data_4%3a5.8.6-1_all.deb ...
Unpacking kwin-data (4:5.8.6-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/7-kwin-data_4%3a5.8.6-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/kcm_kwindesktop.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../8-powerdevil-data_4%3a5.8.4-1_all.deb ...
Unpacking powerdevil-data (4:5.8.4-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-MxeR0d/8-powerdevil-data_4%3a5.8.4-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/powerdevil.mo', which is also in package kde-l10n-si 4:4.8.4-2
Errors were encountered while processing:
/tmp/apt-dpkg-install-MxeR0d/0-libkf5sysguard-data_4%3a5.8.4-1_all.deb
/tmp/apt-dpkg-install-MxeR0d/1-kde-cli-tools-data_4%3a5.8.4-2_all.deb
/tmp/apt-dpkg-install-MxeR0d/2-plasma-desktop-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-MxeR0d/3-plasma-workspace_4%3a5.8.6-2.1_amd64.deb
/tmp/apt-dpkg-install-MxeR0d/4-kgamma5_5.8.4-1_amd64.deb
/tmp/apt-dpkg-install-MxeR0d/5-khotkeys-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-MxeR0d/6-ksysguard-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-MxeR0d/7-kwin-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-MxeR0d/8-powerdevil-data_4%3a5.8.4-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@zabriskie:~# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
ieee-data
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
kde-cli-tools-data kgamma5 khotkeys-data ksysguard-data kwin-data libkf5sysguard-data plasma-desktop-data
plasma-workspace powerdevil-data
The following NEW packages will be installed:
kde-cli-tools-data kgamma5 khotkeys-data ksysguard-data kwin-data libkf5sysguard-data plasma-desktop-data
plasma-workspace powerdevil-data
0 upgraded, 9 newly installed, 0 to remove and 1 not upgraded.
481 not fully installed or removed.
Need to get 0 B/17.9 MB of archives.
After this operation, 83.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 718457 files and directories currently installed.)
Preparing to unpack .../0-libkf5sysguard-data_4%3a5.8.4-1_all.deb ...
Unpacking libkf5sysguard-data (4:5.8.4-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/0-libkf5sysguard-data_4%3a5.8.4-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/ksysguardlsofwidgets.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../1-kde-cli-tools-data_4%3a5.8.4-2_all.deb ...
Unpacking kde-cli-tools-data (4:5.8.4-2) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/1-kde-cli-tools-data_4%3a5.8.4-2_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/filetypes.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../2-plasma-desktop-data_4%3a5.8.6-1_all.deb ...
Unpacking plasma-desktop-data (4:5.8.6-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/2-plasma-desktop-data_4%3a5.8.6-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/joystick.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../3-plasma-workspace_4%3a5.8.6-2.1_amd64.deb ...
Unpacking plasma-workspace (4:5.8.6-2.1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/3-plasma-workspace_4%3a5.8.6-2.1_amd64.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/drkonqi.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../4-kgamma5_5.8.4-1_amd64.deb ...
Unpacking kgamma5 (5.8.4-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/4-kgamma5_5.8.4-1_amd64.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/kcmkgamma.mo', which is also in package kde-l10n-si 4:4.8.4-2
Preparing to unpack .../5-khotkeys-data_4%3a5.8.6-1_all.deb ...
Unpacking khotkeys-data (4:5.8.6-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/5-khotkeys-data_4%3a5.8.6-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/khotkeys.mo', which is also in package kde-l10n-si 4:4.8.4-2
Preparing to unpack .../6-ksysguard-data_4%3a5.8.6-1_all.deb ...
Unpacking ksysguard-data (4:5.8.6-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/6-ksysguard-data_4%3a5.8.6-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/ksysguard.mo', which is also in package kde-l10n-si 4:4.8.4-2
Preparing to unpack .../7-kwin-data_4%3a5.8.6-1_all.deb ...
Unpacking kwin-data (4:5.8.6-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/7-kwin-data_4%3a5.8.6-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/kcm_kwindesktop.mo', which is also in package kde-l10n-si 4:4.8.4-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../8-powerdevil-data_4%3a5.8.4-1_all.deb ...
Unpacking powerdevil-data (4:5.8.4-1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-jgjv6L/8-powerdevil-data_4%3a5.8.4-1_all.deb (--unpack):
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/powerdevil.mo', which is also in package kde-l10n-si 4:4.8.4-2
Errors were encountered while processing:
/tmp/apt-dpkg-install-jgjv6L/0-libkf5sysguard-data_4%3a5.8.4-1_all.deb
/tmp/apt-dpkg-install-jgjv6L/1-kde-cli-tools-data_4%3a5.8.4-2_all.deb
/tmp/apt-dpkg-install-jgjv6L/2-plasma-desktop-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-jgjv6L/3-plasma-workspace_4%3a5.8.6-2.1_amd64.deb
/tmp/apt-dpkg-install-jgjv6L/4-kgamma5_5.8.4-1_amd64.deb
/tmp/apt-dpkg-install-jgjv6L/5-khotkeys-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-jgjv6L/6-ksysguard-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-jgjv6L/7-kwin-data_4%3a5.8.6-1_all.deb
/tmp/apt-dpkg-install-jgjv6L/8-powerdevil-data_4%3a5.8.4-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Since then I have tried to reinstall KDE unsuccessfully.
Does anyone have any directions?
I appreciate.
Luiz
otaviusdecimus
 
Posts: 1
Joined: 2017-07-29 19:18

Re: KDE broken after upgrading to 9

Postby dasein » 2017-07-29 19:45

otaviusdecimus wrote:Does anyone have any directions?

Yes.

Dump the entire contents of your hard drive into a follow-up post. It'll be just as informative as what you posted, and will be even more wasteful of system resources.
User avatar
dasein
 
Posts: 7764
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: KDE broken after upgrading to 9

Postby stevepusser » 2017-07-29 21:15

Code: Select all
trying to overwrite '/usr/share/locale/si/LC_MESSAGES/systemsettings.mo', which is also in package kde-l10n-si 4:4.8.4-2


This. kde-l10n-si

It is a package from Debian 7 Wheezy, not Jessie. You need to remove it from your system to get to upgrade. Obviously your system has more of a history than is put forth in your original post.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8505
Joined: 2009-10-06 05:53


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable