[Solved]GDM lost gnome-wayland option after several reboot.

Everything about X, Gnome, KDE, ... and everything running on it

[Solved]GDM lost gnome-wayland option after several reboot.

Postby jasonhui » 2017-08-03 11:07

These days I meet a problem when I return to Nouveau driver from Nvidia driver in Debian 9.1.
I find GDM lost gnome-wayland option.
I try lightDM instead of GDM, it can offer gnome-wayland option and I can login with success.
But there is problem when use lightDM, I cann't use shortcut to lock screen(there isn't lock option in gnome any more).
This afternoon I re-install Debian 9.1.
At first GDM can show gnome-wayland option and I can login with success.
After several reboot to make configuration take effect, I lost gnome-wayland option in GDM again.
I remember the last operation was install qemu-kvm, libvirt-bin, virt-manager.
I tried to remove them, but the gnome-wayland option still isn't there.
I think I lost it for ever.
How can I make it back?
Any help will be appreciated.

B.R.

Update:
I have found why I lost gnome-wayland.
I notice when I install libvirt-bin, it will update initrd.img.
I decompress initrd and find that there isn't gpu driver in it.
So I add "nouveau" to /etc/initramfs-tools/modules, run "update-initramfs -u" then reboot.
It comes back again. :D
If there are warnings, install firmware-misc-nonfree package and run "update-initramfs -u" again.
jasonhui
 
Posts: 1
Joined: 2017-08-03 10:54

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable