[Solved] Webcam not working

Everything about X, Gnome, KDE, ... and everything running on it

[Solved] Webcam not working

Postby Hallvor » 2017-08-11 20:02

I can't remember if this webcam has ever worked or not, but it does not work with Facebook, Skype, Kopete or guvcview. The webcam is not detected anywhere.

A little output:

Code: Select all
root@laptop-hkb:/home/ivar# lsb_release -a && uname -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.9 (jessie)
Release:        8.9
Codename:       jessie
Linux laptop-hkb 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u2 (2017-06-26) x86_64 GNU/Linux
root@laptop-hkb:/home/ivar#



Code: Select all
root@laptop-hkb:/home/ivar# lsmod | grep video
uvcvideo               79048  0
videobuf2_vmalloc      12816  1 uvcvideo
videobuf2_memops       12519  1 videobuf2_vmalloc
videobuf2_core         47787  1 uvcvideo
v4l2_common            12995  1 videobuf2_core
videodev              126451  3 uvcvideo,v4l2_common,videobuf2_core
media                  18305  2 uvcvideo,videodev
video                  18096  1 i915
i2c_core               46012  7 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,v4l2_common,videodev
usbcore               195468  4 uvcvideo,ehci_hcd,ehci_pci,xhci_hcd
thermal_sys            27642  5 video,intel_powerclamp,thermal,processor,x86_pkg_temp_thermal
root@laptop-hkb:/home/ivar#


Code: Select all
root@laptop-hkb:/home/ivar# ls -la /dev/ | grep video
crw-rw----   1 root video    29,   0 aug.  11 23:18 fb0
root@laptop-hkb:/home/ivar#


Code: Select all
root@laptop-hkb:/home/ivar# lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1c.4 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 5 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)


From /var/log/messages:
Code: Select all
Aug 11 23:24:16 laptop-hkb kernel: [  371.889290] Linux video capture interface: v2.00
Aug 11 23:24:16 laptop-hkb kernel: [  371.899183] uvcvideo: Found UVC 1.00 device BisonCam, NB Pro (5986:0400)
Aug 11 23:24:16 laptop-hkb kernel: [  371.904658] input: BisonCam, NB Pro as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.0/input/input18
Aug 11 23:24:16 laptop-hkb kernel: [  371.907307] usbcore: registered new interface driver uvcvideo
Aug 11 23:24:16 laptop-hkb kernel: [  371.907312] USB Video Class driver (1.1.1)
Aug 11 23:24:16 laptop-hkb kernel: [  372.738366] usb 1-1.1: USB disconnect, device number 3


It says that the user is already a member of the group video:
Code: Select all
root@laptop-hkb:/home/ivar# adduser ivar video
Brukeren «ivar» er allerede et medlem av «video».
root@laptop-hkb:/home/ivar#


Any ideas?
Last edited by Hallvor on 2017-08-12 07:09, edited 1 time in total.
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 739
Joined: 2009-04-16 18:35
Location: Norway

Re: Webcam not working

Postby Segfault » 2017-08-12 01:11

As your dmesg tells it disconnects, might be a hardware issue. In cases like this I'd boot with SystemRescueCD (I keep always the latest version on a USB stick) and see if it works.
Segfault
 
Posts: 480
Joined: 2005-09-24 12:24

Re: [Solved] Webcam not working

Postby Hallvor » 2017-08-12 07:13

Thanks. I think I found the problem. The webcam works just fine now. It could be activated with the keyboard - Fn+F10. (One of the buttons had an image of a camera.) :oops:

Marking thread as solved.
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 739
Joined: 2009-04-16 18:35
Location: Norway


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable