Sound Volume Resets to 100% starting Kodi

Everything about X, Gnome, KDE, ... and everything running on it

Sound Volume Resets to 100% starting Kodi

Postby stardotstar » 2017-08-21 23:32

Hi guys,

I posted on the Kodi forums that when I launch it, and/or each time I start a new program in it the volume of the main sound control resets to maximum.

This has been quite a shock as you can imagine when using it at night!

I have checked that when I set the volume to say 33% in Cinnamon and start Kodi, even before playing anything the volume has jumped to 100%. When I set it back to 33% in Kodi (or with Kodi foregrounded) and exit Kodi the volume remains set at 33%. When I start VLC the volume retains its 33% setting, but on launching Kodi it is once again reset to 100%.

I have been through the audio system settings and it is set to the analogue pulseaudio that is the only one available.

A Kodi forums member asserts:
sounds like a pulseaudio config issue. IIRC debian enables "flatten volume" by default


I cannot seem to find a good reference to help work out the way that "flatten volume" can be configured with respect to this problem.
My last search on this produces only my own post on the kodi forums here.

Any ideas?
TIA Will
stardotstar
 
Posts: 13
Joined: 2006-05-10 08:32

Re: Sound Volume Resets to 100% starting Kodi

Postby roseway » 2017-08-22 05:51

I had this problem with Stretch whenever system sounds were played. The fix was to edit
/etc/pulse/daemon.conf, and set the value flat-volumes = no
Eric
User avatar
roseway
 
Posts: 1479
Joined: 2007-12-31 22:50
Location: Kent, UK

Re: Sound Volume Resets to 100% starting Kodi

Postby stardotstar » 2017-08-26 13:40

Thank you Eric, I've uncommented the line and changed it to no.
Let's see how that goes!
W
stardotstar
 
Posts: 13
Joined: 2006-05-10 08:32


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable