[solved] debian 8.8 graphics card [Radeon HD 4350/4550 issue

Everything about X, Gnome, KDE, ... and everything running on it

[solved] debian 8.8 graphics card [Radeon HD 4350/4550 issue

Postby philo_neo » 2017-09-21 16:59

Hello, I have encountered problems with my graphics card under debian 8.8 for AMD64, I followed instalation procedures found on the internet but I get a black screen. here are the commands I have made:

Code: Select all
root@dct-aragone:~# lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV710 [Radeon HD 4350/4550] [1002:954f]
root@dct-aragone:~#


and

Code: Select all
# Debian 8 "Jessie"
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
Update the list of available packages:
# apt-get update
Install the firmware-linux-nonfree, libgl1-mesa-dri and xserver-xorg-video-ati packages:
# apt-get install firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati


what should I do for my graphics card [Radeon HD 4350/4550

Regards
Philippe
Last edited by philo_neo on 2017-09-22 15:17, edited 1 time in total.
User avatar
philo_neo
 
Posts: 68
Joined: 2010-06-18 16:48

Re: debian 8.8 graphics card [Radeon HD 4350/4550 issue

Postby stevepusser » 2017-09-21 18:15

Those are instructions, not the actual commands that you enter into a terminal. Normally, you would just need to download and install this deb package with the "dpkg -i" command: https://packages.debian.org/jessie-back ... d-graphics or the older version: https://packages.debian.org/jessie/firm ... ux-nonfree

The download link is at the bottom of the pages. This assumes that your hardware is not really recent and is supported by Jessie's 2014-vintage free radeon drivers.

By the way, I can recognize that your "instalation procedures found on the internet" are from the Debian wiki or copied from it, but others would no doubt appreciate an actual link to what instructions you followed.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8802
Joined: 2009-10-06 05:53

Re: debian 8.8 graphics card [Radeon HD 4350/4550 issue

Postby philo_neo » 2017-09-21 19:57

yes, I have removed the old packages using the command aptitude remove xserver *, then I add the packages you gave me but still a black screen here is my /var/log/Xorg.0. log file:
[ 15.387]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[ 15.387] X Protocol Version 11, Revision 0
[ 15.387] Build Operating System: Linux 4.9.0-3-amd64 x86_64 Debian
[ 15.387] Current Operating System: Linux dct-aragone 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u3 (2017-08-15) x86_64
[ 15.387] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=b9c164b4-e521-4440-914b-c9c188f92c0a ro quiet
[ 15.387] Build Date: 17 July 2017 01:40:19PM
[ 15.387] xorg-server 2:1.16.4-1+deb8u1+b1 (http://www.debian.org/support)
[ 15.387] Current version of pixman: 0.32.6
[ 15.387] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 15.387] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 15.387] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 21 22:33:48 2017
[ 15.408] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 15.481] (==) No Layout section. Using the first Screen section.
[ 15.481] (==) No screen section available. Using defaults.
[ 15.481] (**) |-->Screen "Default Screen Section" (0)
[ 15.481] (**) | |-->Monitor "<default monitor>"
[ 15.504] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 15.504] (==) Automatically adding devices
[ 15.504] (==) Automatically enabling devices
[ 15.504] (==) Automatically adding GPU devices
[ 15.547] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 15.547] Entry deleted from font path.
[ 15.556] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 15.556] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 15.556] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 15.557] (II) Loader magic: 0x5637f51f3d80
[ 15.557] (II) Module ABI versions:
[ 15.557] X.Org ANSI C Emulation: 0.4
[ 15.557] X.Org Video Driver: 18.0
[ 15.557] X.Org XInput driver : 21.0
[ 15.557] X.Org Server Extension : 8.0
[ 15.560] (--) PCI:*(0:1:0:0) 1002:954f:174b:e990 rev 0, Mem @ 0xc0000000/268435456, 0xdfde0000/65536, I/O @ 0x0000d800/256, BIOS @ 0x????????/131072
[ 15.569] (II) LoadModule: "glx"
[ 15.592] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 15.609] (II) Module glx: vendor="X.Org Foundation"
[ 15.609] compiled for 1.16.4, module version = 1.0.0
[ 15.609] ABI class: X.Org Server Extension, version 8.0
[ 15.609] (==) AIGLX enabled
[ 15.610] (==) Matched ati as autoconfigured driver 0
[ 15.610] (==) Matched modesetting as autoconfigured driver 1
[ 15.610] (==) Matched fbdev as autoconfigured driver 2
[ 15.610] (==) Matched vesa as autoconfigured driver 3
[ 15.610] (==) Assigned the driver to the xf86ConfigLayout
[ 15.610] (II) LoadModule: "ati"
[ 15.629] (WW) Warning, couldn't open module ati
[ 15.629] (II) UnloadModule: "ati"
[ 15.629] (II) Unloading ati
[ 15.629] (EE) Failed to load module "ati" (module does not exist, 0)
[ 15.629] (II) LoadModule: "modesetting"
[ 15.630] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 15.639] (II) Module modesetting: vendor="X.Org Foundation"
[ 15.639] compiled for 1.16.4, module version = 0.9.0
[ 15.639] Module class: X.Org Video Driver
[ 15.639] ABI class: X.Org Video Driver, version 18.0
[ 15.639] (II) LoadModule: "fbdev"
[ 15.640] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 15.640] (II) Module fbdev: vendor="X.Org Foundation"
[ 15.641] compiled for 1.15.99.904, module version = 0.4.4
[ 15.641] Module class: X.Org Video Driver
[ 15.641] ABI class: X.Org Video Driver, version 18.0
[ 15.641] (II) LoadModule: "vesa"
[ 15.641] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 15.642] (II) Module vesa: vendor="X.Org Foundation"
[ 15.642] compiled for 1.15.99.904, module version = 2.3.3
[ 15.642] Module class: X.Org Video Driver
[ 15.642] ABI class: X.Org Video Driver, version 18.0
[ 15.642] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 15.642] (II) FBDEV: driver for framebuffer: fbdev
[ 15.642] (II) VESA: driver for VESA chipsets: vesa
[ 15.642] (++) using VT number 7

[ 15.644] (EE) open /dev/dri/card0: No such file or directory
[ 15.644] (WW) Falling back to old probe method for modesetting
[ 15.644] (EE) open /dev/dri/card0: No such file or directory
[ 15.644] (II) Loading sub module "fbdevhw"
[ 15.644] (II) LoadModule: "fbdevhw"
[ 15.644] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 15.645] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 15.645] compiled for 1.16.4, module version = 0.0.2
[ 15.645] ABI class: X.Org Video Driver, version 18.0
[ 15.645] (EE) open /dev/fb0: No such file or directory
[ 15.645] (WW) Falling back to old probe method for fbdev
[ 15.645] (II) Loading sub module "fbdevhw"
[ 15.645] (II) LoadModule: "fbdevhw"
[ 15.645] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 15.645] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 15.645] compiled for 1.16.4, module version = 0.0.2
[ 15.645] ABI class: X.Org Video Driver, version 18.0
[ 15.645] (EE) open /dev/fb0: No such file or directory
[ 15.646] (EE) Screen 0 deleted because of no matching config section.
[ 15.646] (II) UnloadModule: "modesetting"
[ 15.646] (EE) Screen 0 deleted because of no matching config section.
[ 15.646] (II) UnloadModule: "fbdev"
[ 15.646] (II) UnloadSubModule: "fbdevhw"
[ 15.646] (II) Loading sub module "vbe"
[ 15.646] (II) LoadModule: "vbe"
[ 15.646] (II) Loading /usr/lib/xorg/modules/libvbe.so
[ 15.675] (II) Module vbe: vendor="X.Org Foundation"
[ 15.675] compiled for 1.16.4, module version = 1.1.0
[ 15.675] ABI class: X.Org Video Driver, version 18.0
[ 15.675] (II) Loading sub module "int10"
[ 15.675] (II) LoadModule: "int10"
[ 15.675] (II) Loading /usr/lib/xorg/modules/libint10.so
[ 15.691] (II) Module int10: vendor="X.Org Foundation"
[ 15.691] compiled for 1.16.4, module version = 1.0.0
[ 15.691] ABI class: X.Org Video Driver, version 18.0
[ 15.691] (II) VESA(0): initializing int10
[ 15.700] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[ 15.700] (II) VESA(0): VESA BIOS detected
[ 15.700] (II) VESA(0): VESA VBE Version 3.0
[ 15.700] (II) VESA(0): VESA VBE Total Mem: 16384 kB
[ 15.700] (II) VESA(0): VESA VBE OEM: ATI ATOMBIOS
[ 15.701] (II) VESA(0): VESA VBE OEM Software Rev: 11.13
[ 15.701] (II) VESA(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
[ 15.701] (II) VESA(0): VESA VBE OEM Product: RV710
[ 15.701] (II) VESA(0): VESA VBE OEM Product Rev: 01.00
[ 15.739] (II) VESA(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 15.739] (==) VESA(0): Depth 24, (--) framebuffer bpp 32
[ 15.739] (==) VESA(0): RGB weight 888
[ 15.739] (==) VESA(0): Default visual is TrueColor
[ 15.739] (==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 15.739] (II) Loading sub module "ddc"
[ 15.739] (II) LoadModule: "ddc"
[ 15.739] (II) Module "ddc" already built-in
[ 15.739] (II) VESA(0): VESA VBE DDC supported
[ 15.739] (II) VESA(0): VESA VBE DDC Level 2
[ 15.739] (II) VESA(0): VESA VBE DDC transfer in appr. 1 sec.
[ 16.001] (II) VESA(0): VESA VBE DDC read successfully
[ 16.002] (II) VESA(0): Manufacturer: ___ Model: 101 Serial#: 16843009
[ 16.002] (II) VESA(0): Year: 2008 Week: 1
[ 16.002] (II) VESA(0): EDID Version: 1.3
[ 16.002] (II) VESA(0): Analog Display Input, Input Voltage Level: 0.700/0.300 V
[ 16.002] (II) VESA(0): Sync: Separate
[ 16.002] (II) VESA(0): Max Image Size [cm]: horiz.: 160 vert.: 90
[ 16.002] (II) VESA(0): Gamma: 2.20
[ 16.002] (II) VESA(0): No DPMS capabilities specified; RGB/Color Display
[ 16.002] (II) VESA(0): First detailed timing is preferred mode
[ 16.002] (II) VESA(0): redX: 0.625 redY: 0.340 greenX: 0.277 greenY: 0.595
[ 16.002] (II) VESA(0): blueX: 0.155 blueY: 0.070 whiteX: 0.297 whiteY: 0.298
[ 16.002] (II) VESA(0): Supported established timings:
[ 16.002] (II) VESA(0): 720x400@70Hz
[ 16.002] (II) VESA(0): 640x480@60Hz
[ 16.002] (II) VESA(0): 800x600@60Hz
[ 16.002] (II) VESA(0): 1024x768@60Hz
[ 16.002] (II) VESA(0): Manufacturer's mask: 0
[ 16.002] (II) VESA(0): Supported standard timings:
[ 16.002] (II) VESA(0): #0: hsize: 640 vsize 480 refresh: 60 vid: 16433
[ 16.002] (II) VESA(0): #1: hsize: 800 vsize 600 refresh: 60 vid: 16453
[ 16.002] (II) VESA(0): #2: hsize: 1024 vsize 768 refresh: 60 vid: 16481
[ 16.002] (II) VESA(0): #3: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
[ 16.002] (II) VESA(0): #4: hsize: 1600 vsize 1200 refresh: 60 vid: 16553
[ 16.002] (II) VESA(0): Supported detailed timing:
[ 16.002] (II) VESA(0): clock: 148.5 MHz Image Size: 1600 x 900 mm
[ 16.002] (II) VESA(0): h_active: 1920 h_sync: 2008 h_sync_end 2052 h_blank_end 2200 h_border: 0
[ 16.002] (II) VESA(0): v_active: 1080 v_sync: 1084 v_sync_end 1090 v_blanking: 1125 v_border: 0
[ 16.002] (II) VESA(0): Supported detailed timing:
[ 16.002] (II) VESA(0): clock: 85.5 MHz Image Size: 1600 x 900 mm
[ 16.002] (II) VESA(0): h_active: 1360 h_sync: 1424 h_sync_end 1536 h_blank_end 1792 h_border: 0
[ 16.002] (II) VESA(0): v_active: 768 v_sync: 771 v_sync_end 777 v_blanking: 795 v_border: 0
[ 16.002] (II) VESA(0): Ranges: V min: 57 V max: 63 Hz, H min: 30 H max: 80 kHz, PixClock max 155 MHz
[ 16.002] (II) VESA(0): Monitor name: LCD TV
[ 16.002] (II) VESA(0): EDID (in hex):
[ 16.002] (II) VESA(0): 00ffffffffffff007fff010101010101
[ 16.002] (II) VESA(0): 0112010308a05a780a01c1a057479827
[ 16.002] (II) VESA(0): 124c4ca108003140454061408180a940
[ 16.002] (II) VESA(0): 010101010101023a801871382d40582c
[ 16.002] (II) VESA(0): 460040846300001e662150b051001b30
[ 16.002] (II) VESA(0): 4070360040846300001e000000fd0039
[ 16.002] (II) VESA(0): 3f1e500f000a202020202020000000fc
[ 16.002] (II) VESA(0): 004c43442054560a20202020202000e8
[ 16.002] (II) VESA(0): EDID vendor "___", prod id 257
[ 16.002] (II) VESA(0): Using EDID range info for horizontal sync
[ 16.002] (II) VESA(0): Using EDID range info for vertical refresh
[ 16.002] (II) VESA(0): Printing DDC gathered Modelines:
[ 16.002] (II) VESA(0): Modeline "1920x1080"x0.0 148.50 1920 2008 2052 2200 1080 1084 1090 1125 +hsync +vsync (67.5 kHz eP)
[ 16.002] (II) VESA(0): Modeline "1360x768"x0.0 85.50 1360 1424 1536 1792 768 771 777 795 +hsync +vsync (47.7 kHz e)
[ 16.002] (II) VESA(0): Modeline "800x600"x0.0 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz e)
[ 16.002] (II) VESA(0): Modeline "640x480"x0.0 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz e)
[ 16.002] (II) VESA(0): Modeline "720x400"x0.0 28.32 720 738 846 900 400 412 414 449 -hsync +vsync (31.5 kHz e)
[ 16.002] (II) VESA(0): Modeline "1024x768"x0.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz e)
[ 16.002] (II) VESA(0): Modeline "1280x1024"x0.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[ 16.002] (II) VESA(0): Modeline "1600x1200"x0.0 162.00 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
[ 16.002] (II) VESA(0): Searching for matching VESA mode(s):
[ 16.003] Mode: 100 (640x400)
[ 16.003] ModeAttributes: 0xbb
[ 16.003] WinAAttributes: 0x7
[ 16.003] WinBAttributes: 0x0
[ 16.003] WinGranularity: 64
[ 16.003] WinSize: 64
[ 16.003] WinASegment: 0xa000
[ 16.003] WinBSegment: 0x0
[ 16.003] WinFuncPtr: 0xc0005093
[ 16.003] BytesPerScanline: 640
[ 16.003] XResolution: 640
[ 16.003] YResolution: 400
[ 16.003] XCharSize: 8
[ 16.003] YCharSize: 16
[ 16.003] NumberOfPlanes: 1
[ 16.003] BitsPerPixel: 8
[ 16.003] NumberOfBanks: 1
[ 16.003] MemoryModel: 4
[ 16.003] BankSize: 0
[ 16.003] NumberOfImages: 63
[ 16.003] RedMaskSize: 0
[ 16.003] RedFieldPosition: 0
[ 16.003] GreenMaskSize: 0
[ 16.003] GreenFieldPosition: 0
[ 16.003] BlueMaskSize: 0
[ 16.003] BlueFieldPosition: 0
[ 16.003] RsvdMaskSize: 0
[ 16.003] RsvdFieldPosition: 0
[ 16.003] DirectColorModeInfo: 0
[ 16.003] PhysBasePtr: 0xc0000000
[ 16.003] LinBytesPerScanLine: 640
[ 16.003] BnkNumberOfImagePages: 63
[ 16.003] LinNumberOfImagePages: 63
[ 16.003] LinRedMaskSize: 0
[ 16.003] LinRedFieldPosition: 0
[ 16.003] LinGreenMaskSize: 0
[ 16.003] LinGreenFieldPosition: 0
[ 16.003] LinBlueMaskSize: 0
[ 16.003] LinBlueFieldPosition: 0
[ 16.003] LinRsvdMaskSize: 0
[ 16.003] LinRsvdFieldPosition: 0
[ 16.003] MaxPixelClock: 400000000
[ 16.004] Mode: 101 (640x480)
[ 16.004] ModeAttributes: 0xbb
[ 16.004] WinAAttributes: 0x7
[ 16.004] WinBAttributes: 0x0
[ 16.004] WinGranularity: 64
[ 16.004] WinSize: 64
[ 16.004] WinASegment: 0xa000
[ 16.004] WinBSegment: 0x0
User avatar
philo_neo
 
Posts: 68
Joined: 2010-06-18 16:48

Re: debian 8.8 graphics card [Radeon HD 4350/4550 issue

Postby stevepusser » 2017-09-21 20:08

What version of Debian did you install? Was it with a full desktop, or just a barebones netinstall? With a full desktop, all you have to do is add the firmware package, since the driver needs it.

You are having problems because you removed parts of the graphics display system. All of those should have already been installed with a standard Debian desktop installation--removing parts of it will naturally break it.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8802
Joined: 2009-10-06 05:53

Re: debian 8.8 graphics card [Radeon HD 4350/4550 issue

Postby philo_neo » 2017-09-21 20:57

What version of Debian did you install? Was it with a full desktop, or just a barebones netinstall? With a full desktop, all you have to do is add the firmware package, since the driver needs it.

use the debian 8.8 netinstall with Gnome desktop choise between installation, my server is a biquad cores opteron 2347,
You are having problems because you removed parts of the graphics display system. All of those should have already been installed with a standard Debian desktop installation--removing parts of it will naturally break it.

how can I restore my development server because I have Java EE programs on this computer I use it to develop under Eclipse in full 64bits.
I have to install via ssh a samba server to provide it in * .deb packets, or can I find the missing files.
User avatar
philo_neo
 
Posts: 68
Joined: 2010-06-18 16:48

Re: debian 8.8 graphics card [Radeon HD 4350/4550 issue

Postby stevepusser » 2017-09-21 22:34

You can download the deb packages that you removed from packages.debian.org. You can look in your /var/log/apt/history.log file to see what your command removed.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8802
Joined: 2009-10-06 05:53

Re: debian 8.8 graphics card [Radeon HD 4350/4550 issue

Postby philo_neo » 2017-09-22 15:16

hello,
i re-install my OS, amd apply the patchs of stevepusser , i have a good display, 2k !

Post/thread SOLVED
User avatar
philo_neo
 
Posts: 68
Joined: 2010-06-18 16:48


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable