[SOLVED] SDDM fails at boot - Debian Stable w/ KDE

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] SDDM fails at boot - Debian Stable w/ KDE

Postby LPC11 » 2017-10-03 22:10

Running Debian 9 upgraded from stable. KDE ran fine after the upgrade, and I have had no issues until after the last security update

Now, SDDM service no longer runs at boot. Instead it goes to terminal at tty1. Restarting sddm service from terminal launches sddm successfully, but then at the next reboot, it goes back to tty1. Also, running startx at terminal launches sddm correctly.

My sddm.conf file:

Code: Select all
[Autologin]
Relogin=false
Session=
User=

[General]
HaltCommand=
RebootCommand=

[Theme]
Current=breeze
CursorTheme=breeze_cursors

[Users]
MaximumUid=65000
MinimumUid=1000

[X11]
MinimumVT=7


Running sddm in test mode:

lpc123@debianmain:~$ sddm --test -mode
    [17:26:08.560] (II) DAEMON: Initializing...
    [17:26:08.564] (II) DAEMON: Starting...
    [17:26:08.564] (II) DAEMON: Adding new display on vt 7 ...
    [17:26:08.564] (II) DAEMON: Display server starting...
    [17:26:08.564] (II) DAEMON: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{a97d52c4-7867-486e-b890-8185b57cdcde} -background none -noreset -displayfd 17 vt7
    [17:26:08.566] (EE) DAEMON: Display server failed to start. Exiting
    Aborted

Using Intel integrated graphics in a dual monitor setup (no nvdia or other graphics card).

System info:

System: Host: debianmain Kernel: 4.9.0-3-amd64 x86_64 (64 bit) Desktop: KDE Plasma 5.8.6
Distro: Debian GNU/Linux 9 (stretch)
Machine: Device: desktop Mobo: ASRock model: H97M-ITX/ac UEFI: American Megatrends v: P1.90 date: 06/13/2016
CPU: Dual core Intel Pentium G3258 (-MCP-) cache: 3072 KB
clock speeds: max: 3200 MHz 1: 970 MHz 2: 1262 MHz
Graphics: Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
GLX Renderer: Mesa DRI Intel Haswell Desktop GLX Version: 3.0 Mesa 13.0.6
Audio: Card-1 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel
Card-2 Intel 9 Series Family HD Audio Controller driver: snd_hda_intel
Card-3 Texas Instruments Audio Codec driver: USB Audio
Sound: Advanced Linux Sound Architecture v: k4.9.0-3-amd64
Network: Card-1: Qualcomm Atheros QCA8171 Gigabit Ethernet driver: alx
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: d0:50:99:5b:c2:4a
Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 1750.4GB (16.7% used)
ID-1: /dev/sdb model: HFS500G32TND size: 500.1GB
ID-2: /dev/sdc model: WDC_WD10EZEX size: 1000.2GB
ID-3: /dev/sda model: CT250BX100SSD1 size: 250.1GB
Partition: ID-1: / size: 299G used: 112G (40%) fs: ext4 dev: /dev/sdb2
ID-2: swap-1 size: 8.27GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
ID-3: swap-2 size: 17.11GB used: 0.00GB (0%) fs: swap dev: /dev/sdb7
Sensors: System Temperatures: cpu: 43.0C mobo: 34.0C
Fan Speeds (in rpm): cpu: N/A fan-1: 363 fan-2: 1146
Info: Processes: 194 Uptime: 36 min Memory: 2059.8/7686.4MB Client: Shell (bash) inxi: 2.3.5


Any other diagnostics that could help, please let me know and I will add to this. Thanks.

SOLUTION
The only thing that worked was to run:

Code: Select all
sudo dpkg-reconfigure sddm


...then reboot.
Last edited by LPC11 on 2017-10-05 23:50, edited 1 time in total.
LPC11
 
Posts: 12
Joined: 2016-10-27 20:21

Re: SDDM fails at boot - Debian Stable w/ KDE

Postby Hallvor » 2017-10-04 21:07

A shot in the dark, but what is the output of

Code: Select all
cat /etc/X11/default-display-manager


and

Code: Select all
systemctl status sddm.service


?
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 739
Joined: 2009-04-16 18:35
Location: Norway

Re: SDDM fails at boot - Debian Stable w/ KDE

Postby LPC11 » 2017-10-04 22:30

Hallvor wrote:A shot in the dark, but what is the output of

Code: Select all
cat /etc/X11/default-display-manager


and

Code: Select all
systemctl status sddm.service


?


lpc123@debianmain:~$ cat /etc/X11/default-display-manager
/usr/bin/sddm

lpc123@debianmain:~$ systemctl status sddm.service
● sddm.service - Simple Desktop Display Manager
Loaded: loaded (/lib/systemd/system/sddm.service; bad; vendor preset: enabled)
Active: inactive (dead)
Docs: man:sddm(1)
man:sddm.conf(5)
LPC11
 
Posts: 12
Joined: 2016-10-27 20:21

Re: [SOLVED] SDDM fails at boot - Debian Stable w/ KDE

Postby Hallvor » 2017-10-06 08:51

I see you marked the thread as solved. How did you solve it?
Intel Core i5 3320-M CPU @ 2.60 GHz, 6 GB RAM, Intel HD 4000 graphics, 300 GB HDD, Debian Stretch (KDE)
User avatar
Hallvor
 
Posts: 739
Joined: 2009-04-16 18:35
Location: Norway

Re: [SOLVED] SDDM fails at boot - Debian Stable w/ KDE

Postby LPC11 » 2017-10-06 15:19

Hallvor wrote:I see you marked the thread as solved. How did you solve it?


Added to initial post:

SOLUTION
The thing that worked was to run:

Code: Select all
sudo dpkg-reconfigure sddm



...then reboot.
LPC11
 
Posts: 12
Joined: 2016-10-27 20:21


Return to Desktop & Multimedia

Who is online

Users browsing this forum: varc and 3 guests

fashionable