(stretch) lightdm 1.18.3-1 XDMCP - greeter doesn't start

Everything about X, Gnome, KDE, ... and everything running on it

(stretch) lightdm 1.18.3-1 XDMCP - greeter doesn't start

Postby Stancil » 2017-10-12 07:03

Have been happily running a remote desktop login via XDMCP from Cygwin/X to a
Deb 7.6 LXDE installation for several years.

I needed to build a replacement server and have installed the latest Deb 9.2.0 LXDE 9.1
from Live DVD on a new PC. This comes with lightdm v1.18.3-1

[UPDATE - just tried lightdm 1.18.3-4 from testing - still broken]

I carried out the same steps I used before on the old install, i.e.

1/ uncommented

Code: Select all

in /etc/lightdm/lightdm.conf

and verified with

Code: Select all
/usr/sbin/lightdm --show-config

Code: Select all
user@yul:/etc/lightdm$ /usr/sbin/lightdm --show-config
A  greeter-session=lightdm-greeter
A  greeter-hide-users=true
A  session-wrapper=/etc/X11/Xsession
B  xserver-allow-tcp=true

B  enabled=true

A  /usr/share/lightdm/lightdm.conf.d/01_debian.conf
B  /etc/lightdm/lightdm.conf


also tried putting the same two extra options in 01_debian.conf in

Code: Select all

with '
Code: Select all
sudo systemctl restart lightdm
' from SSH, or a reboot - to no avail

2/ I then connect from a PC in Cygwin/X with

Code: Select all
C:\cygwin64\bin\run.exe /usr/bin/XWin.exe -query DEB_LAN_IP -from PC_LAN_IP -screen 0 960x720

I see in the Windows networking stack

- a UDP connection between S Cygwin:60556 and D Deb:177
- a TCP connection between S Deb:42248 and D Cygwin:6000
- a TCP connection between S Deb:42250 and D Cygwin:6000

but with the new Deb 9.2 all I see is a black screen and a cursor on the Cygwin window

no login greeter, no desktop pattern.

the log file at /var/log/lightdm/lightdm.log

Code: Select all
[+8.36s] DEBUG: Got Query(authentication_names=[]) from
[+8.36s] DEBUG: Send Willing(authentication_name='' hostname='yul' status='') to
[+8.73s] DEBUG: Got Request(display_number=0 connections=[] authentication_name=
'' authentication_data= authorization_names=['MIT-MAGIC-COOKIE-1' 'XDM-AUTHORIZATION-1'] man
ufacturer_display_id='') from
[+8.73s] CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[+8.73s] DEBUG: Send Accept(session_id=50597 authentication_name='' authentication_data= aut
horization_name='MIT-MAGIC-COOKIE-1' authorization_data=4ACACD6DA144A1040A33621E4C0445B1) to
[+8.73s] DEBUG: Got Manage(session_id=50597 display_number=0 display_class='MIT-unspecified'
) from
[+8.73s] DEBUG: Seat (null): Loading properties from config section Seat:*
[+8.73s] DEBUG: Seat (null): Starting
[+8.73s] DEBUG: Seat (null): Creating greeter session
[+8.73s] DEBUG: Seat (null): Creating display server of type x
[+8.73s] DEBUG: DisplayServer x- Connecting to XServer
[+8.74s] DEBUG: Seat (null): Display server ready, starting session authentication
[+8.74s] DEBUG: Session: Not setting XDG_VTNR
[+8.74s] DEBUG: Session pid=944: Started with service 'lightdm-greeter', username 'lightdm'
[+8.74s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat1
[+8.77s] DEBUG: Session pid=944: Authentication complete with return value 0: Success
[+8.77s] DEBUG: Seat (null): Session authenticated, running command
[+8.77s] DEBUG: Session pid=944: Not setting XDG_VTNR
[+8.77s] DEBUG: Session pid=944: Running command /usr/sbin/lightdm-gtk-greeter
[+8.77s] DEBUG: Session pid=944: Logging to /var/log/lightdm/(null)-greeter.log
[+8.78s] DEBUG: Activating login1 session c4
[+8.78s] WARNING: Error activating login1 session: GDBus.Error:org.freedesktop.DBus.Error.No
tSupported: Operation not supported
[+9.62s] DEBUG: Greeter connected version=1.18.3 resettable=false
[+12.42s] DEBUG: Greeter start authentication
[+12.42s] DEBUG: Session: Not setting XDG_VTNR
[+12.42s] DEBUG: Session pid=963: Started with service 'lightdm', username '(null)'
[+12.44s] DEBUG: Session pid=963: Got 1 message(s) from PAM
[+12.44s] DEBUG: Prompt greeter with 1 message(s)
[+42.16s] DEBUG: Greeter closed communication channel
[+42.16s] DEBUG: Session pid=944: Exited with return value 0
[+42.16s] DEBUG: Seat (null): Session stopped
[+42.16s] DEBUG: Seat (null): Stopping; failed to start a greeter
[+42.16s] DEBUG: Seat (null): Stopping
[+42.16s] DEBUG: Seat (null): Stopping display server
[+42.16s] DEBUG: Seat (null): Display server stopped
[+42.16s] DEBUG: Seat (null): Stopping session
[+42.16s] DEBUG: Session pid=963: Sending SIGTERM
[+42.16s] DEBUG: Session pid=963: Terminated with signal 15
[+42.16s] DEBUG: Session: Failed during authentication
[+42.16s] DEBUG: Seat (null): Session stopped
[+42.16s] DEBUG: Seat (null): Stopped


the critical line where the greeter fails seems to be

Code: Select all
WARNING: Error activating login1 session: GDBus.Error:org.freedesktop.DBus.Error.No
tSupported: Operation not supported

Any clues what is different between my old, working Deb 7.6 XDMCP config and my new broken Deb 9.2 config ?

The same scenario is Debian bug report #852397 from Jan 2017, btw


Also tried the more awkward multi-step SSH Forwarding method as follows - tl;dr - it works.

In Cygwin terminal type

Code: Select all
X -screen 0 960x720 -listen tcp

In PUtty, start an SSH session to the Debian box with X11 Forwarding set to Yes
In the Debian SSH login shell type

Code: Select all
sudo apt-get install consolekit

(for ck-launch-session - which was required for this to work in Deb 7.6 - no consolekit installed ootb in Deb 9.2)

Code: Select all
exec ck-launch-session startlxde

...nothing appears on the Cygwin X screen - it hangs with spinning blue Windows 10 donut cursor


Code: Select all
exec startlxde

works, and displays the expected lxde desktop, but doing a Logout, does not display the greeter for
a login.

[UPDATE - this always fails the first time - works on subsequent invocations]

This works for a single session, but is a multi-step method that can't be encapsulated into a single Windows shortcut, like
the XDMCP method can, so is a PITA and I want to avoid it.
Posts: 1
Joined: 2017-10-12 06:53

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests