LXDE autologin

Everything about X, Gnome, KDE, ... and everything running on it

LXDE autologin

Postby duschaan » 2017-10-13 09:14

Hi guys! I need help setting up autologin on debian 9 LXDE. Changing lightdm configuration in /etc/lightdm/lightdm.conf ( autologin-user=duschaan, autologin-user-timeout=0) didn't help. Any idea? Thank you
duschaan
 
Posts: 1
Joined: 2017-10-13 08:55

Re: LXDE autologin

Postby arochester » 2017-10-13 17:16

Presumably you saw https://wiki.debian.org/LightDM ?

uncomment them

/!\ Note that this has to be in the [?SeatDefaults] section, not the [LightDM] section.
arochester
 
Posts: 1251
Joined: 2010-12-07 19:55

Re: LXDE autologin

Postby debiman » 2017-10-13 18:43

doesn't lxde have a gui utility for this?
User avatar
debiman
 
Posts: 2396
Joined: 2013-03-12 07:18

Re: LXDE autologin

Postby Glenst0rm » 2017-11-01 18:46

duschaan wrote:Hi guys! I need help setting up autologin on debian 9 LXDE. Changing lightdm configuration in /etc/lightdm/lightdm.conf ( autologin-user=duschaan, autologin-user-timeout=0) didn't help. Any idea? Thank you



Did you find a solution to this? I am having similar problems.
Glenst0rm
 
Posts: 1
Joined: 2017-11-01 18:45

Re: LXDE autologin

Postby blanas » 2018-05-13 10:23

duschaan wrote:Hi guys! I need help setting up autologin on debian 9 LXDE. Changing lightdm configuration in /etc/lightdm/lightdm.conf ( autologin-user=duschaan, autologin-user-timeout=0) didn't help. Any idea? Thank you


I had same problem but I found that in /etc/lightdm/lightdm.conf file autologin-user and autologin-user-timeout occur twice, then I set it twice. I also set autologin-session = LXDE twice. In addition, I created a group autologin (groupadd -r autologin) and I added my user to this group (gpasswd -a username autologin). Now it works fine.
blanas
 
Posts: 1
Joined: 2018-05-13 10:03

Re: LXDE autologin

Postby kidgrave » 2018-05-22 18:25

Go to the terminal and type:

nano /etc/lightdm/lightdm.conf

Scroll all the way to the bottom and paste this:

[Seat:*]
pam-service=lightdm
pam-autologin-service=lightdm-autologin
autologin-user=TYPE-YOUR-USERNAME-HERE
autologin-user-timeout=0
session-wrapper=/etc/X11/Xsession
greeter-session=lightdm-greeter

Save the changes. This works with Debian 9 really good.
kidgrave
 
Posts: 4
Joined: 2018-05-22 18:21


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable