Nvidia Optimus - Cannot boot into Gnome

Everything about X, Gnome, KDE, ... and everything running on it

Nvidia Optimus - Cannot boot into Gnome

Postby reefcrazed » 2017-10-14 16:08

I am running Debian Stretch - Non-Free downloaded a week ago. I have followed around different guides on getting this working but so far no luck. After my initial install everything looks great but to my guessing, the Nvidia card is not being used. I want to test things like CUDA bitcoin mining, number crunching, etc. Plus this is a rather expensive laptop, so I might as well use this nice video card. The system is an Asus ROG GL753VE, which I do believe uses Optimus. The video card is an Nvidia GTX 1050ti

Code: Select all
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 3D controller: NVIDIA Corporation Device 1c8c (rev a1)


On one guide using the Official drivers I either get the frownie face going into Gnome saying it cannot start, makes me feel like I am using IOS. Another guide causes a hard freeze after entering gnome. If I try the drivers using Aptitude it still does not go into Gnome, I get an error message.

I went ahead and updated my BIOS this morning and this laptop has no way to disable the Optimus feature, even after the update.

These are the guides I tried...

https://wiki.debian.org/Bumblebee
https://wiki.debian.org/NvidiaGraphicsDrivers/Optimus#
https://linuxconfig.org/how-to-install- ... etch-linux
https://wiki.debian.org/NvidiaGraphicsDrivers

I also tried guides from other distributions like Arch Linux but I am getting nowhere. I really want to get back into using Linux as my desktop. I am doing more research into security at work and I have learned enough Windows to last me for years, time to switch gears and learn Linux again.

Thanks to anyone that can take the time to help here, forever in your debt.
reefcrazed
 
Posts: 3
Joined: 2017-10-14 15:46

Re: Nvidia Optimus - Cannot boot into Gnome

Postby milomak » 2017-10-14 17:24

to summarise quite high level, it means as you can see in your paste there, that it has 2 cards efficitively. one intel, one nvidia

in the normal course of business the intel driver is used and only when you use optirun is the nvidia card used.

what is the error message you get?

the output from cat /var/log/Xorg.0.log could get us going in the right direction

did you create /etc/X11/xorg.conf or any files in /etc/X11/xorg.conf.d/ ?
iMac - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1678
Joined: 2009-06-09 22:20

Re: Nvidia Optimus - Cannot boot into Gnome

Postby reefcrazed » 2017-10-14 17:51

Adding this to the grub file fixed it.

cpi_osi=! acpi_osi="Windows 2009"

So in my grub.cfg I have

Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT='acpi_osi=! acpi_osi="Windows 2009" quiet'


And then I did a

Code: Select all
update-grub
reefcrazed
 
Posts: 3
Joined: 2017-10-14 15:46


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable